summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Shakaryan <omp@gentoo.org>2008-04-24 07:29:45 +0000
committerDavid Shakaryan <omp@gentoo.org>2008-04-24 07:29:45 +0000
commit5c4b106868fd38568bff25c00cf193c77b0562b0 (patch)
tree8ea7bc001b65c66f1d735bbcd608c9d722f09594 /x11-wm/pekwm
parentMake the sources command output properly signed numbers. (diff)
downloadgentoo-2-5c4b106868fd38568bff25c00cf193c77b0562b0.tar.gz
gentoo-2-5c4b106868fd38568bff25c00cf193c77b0562b0.tar.bz2
gentoo-2-5c4b106868fd38568bff25c00cf193c77b0562b0.zip
Compile with GCC 4.3; patch from Debian modified by Peter Alfredsen. (bug #218956)
(Portage version: 2.1.5_rc3)
Diffstat (limited to 'x11-wm/pekwm')
-rw-r--r--x11-wm/pekwm/ChangeLog9
-rw-r--r--x11-wm/pekwm/files/pekwm-0.1.6-gcc-4.3.patch127
-rw-r--r--x11-wm/pekwm/pekwm-0.1.6.ebuild13
3 files changed, 145 insertions, 4 deletions
diff --git a/x11-wm/pekwm/ChangeLog b/x11-wm/pekwm/ChangeLog
index 024c2adf40c9..264b4d9280f8 100644
--- a/x11-wm/pekwm/ChangeLog
+++ b/x11-wm/pekwm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/pekwm
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/pekwm/ChangeLog,v 1.38 2007/09/09 17:58:31 coldwind Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/pekwm/ChangeLog,v 1.39 2008/04/24 07:29:44 omp Exp $
+
+ 24 Apr 2008; David Shakaryan <omp@gentoo.org>
+ +files/pekwm-0.1.6-gcc-4.3.patch, pekwm-0.1.6.ebuild:
+ Compile with GCC 4.3; patch from Debian modified by Peter Alfredsen. (bug
+ #218956)
09 Sep 2007; Santiago M. Mola <coldwind@gentoo.org> pekwm-0.1.5.ebuild,
pekwm-0.1.6.ebuild:
diff --git a/x11-wm/pekwm/files/pekwm-0.1.6-gcc-4.3.patch b/x11-wm/pekwm/files/pekwm-0.1.6-gcc-4.3.patch
new file mode 100644
index 000000000000..3d1e30aa7b7f
--- /dev/null
+++ b/x11-wm/pekwm/files/pekwm-0.1.6-gcc-4.3.patch
@@ -0,0 +1,127 @@
+--- pekwm-0.1.6.orig/src/CfgParser.cc 2007-05-08 10:10:13.000000000 +0200
++++ pekwm-0.1.6/src/CfgParser.cc 2008-04-22 22:41:21.000000000 +0200
+@@ -11,10 +11,11 @@
+ #include "Util.hh"
+
+ #include <iostream>
+ #include <memory>
+ #include <cassert>
++#include <cstring>
+
+ #ifdef HAVE_GETTEXT
+ #include <libintl.h>
+ #define _(S) gettext(S)
+ #else // !HAVE_GETTEXT
+--- pekwm-0.1.6.orig/src/CfgParser.hh 2007-05-08 10:10:13.000000000 +0200
++++ pekwm-0.1.6/src/CfgParser.hh 2008-04-22 22:41:21.000000000 +0200
+@@ -30,10 +30,11 @@
+
+ #include <list>
+ #include <map>
+ #include <set>
+ #include <string>
++#include <cstring>
+ #include <iostream>
+ #include <cstdlib>
+
+ //! @brief Configuration file parser.
+ class CfgParser {
+--- pekwm-0.1.6.orig/src/CfgParserSource.cc 2007-05-08 10:10:13.000000000 +0200
++++ pekwm-0.1.6/src/CfgParserSource.cc 2008-04-22 22:41:21.000000000 +0200
+@@ -11,10 +11,11 @@
+ //
+
+ #include "CfgParserSource.hh"
+ #include "Util.hh"
+
++#include <cstdlib>
+ #include <iostream>
+
+ extern "C" {
+ #include <unistd.h>
+ }
+--- pekwm-0.1.6.orig/src/ColorHandler.cc 2007-05-08 10:10:13.000000000 +0200
++++ pekwm-0.1.6/src/ColorHandler.cc 2008-04-22 22:41:21.000000000 +0200
+@@ -5,10 +5,11 @@
+ // See the LICENSE file for more information.
+ //
+
+ #include "ColorHandler.hh"
+ #include "PScreen.hh"
++#include <cstring>
+
+ #ifdef DEBUG
+ #include <iostream>
+ using std::cerr;
+ using std::endl;
+--- pekwm-0.1.6.orig/src/ColorHandler.hh 2007-05-08 10:10:13.000000000 +0200
++++ pekwm-0.1.6/src/ColorHandler.hh 2008-04-22 22:41:21.000000000 +0200
+@@ -13,10 +13,11 @@
+
+ #include "pekwm.hh"
+
+ #include <list>
+ #include <string>
++#include <cstring>
+
+ class ColorHandler {
+ public:
+ class Entry {
+ public:
+--- pekwm-0.1.6.orig/src/PImageNativeLoaderXpm.cc 2007-05-08 10:10:13.000000000 +0200
++++ pekwm-0.1.6/src/PImageNativeLoaderXpm.cc 2008-04-22 22:41:21.000000000 +0200
+@@ -11,10 +11,11 @@
+ #ifdef HAVE_IMAGE_XPM
+
+ #include "PImageNativeLoaderXpm.hh"
+
+ #include <iostream>
++#include <cstring>
+
+ using std::cerr;
+ using std::endl;
+ using std::string;
+
+--- pekwm-0.1.6.orig/src/RegexString.cc 2007-05-08 10:10:13.000000000 +0200
++++ pekwm-0.1.6/src/RegexString.cc 2008-04-22 22:41:21.000000000 +0200
+@@ -9,11 +9,11 @@
+ //
+
+ #include "../config.h"
+
+ #include "RegexString.hh"
+-
++#include <cstdlib>
+ #include <iostream>
+
+ #ifdef HAVE_GETTEXT
+ #include <libintl.h>
+ #define _(S) gettext(S)
+--- pekwm-0.1.6.orig/src/Util.cc 2007-05-08 10:10:13.000000000 +0200
++++ pekwm-0.1.6/src/Util.cc 2008-04-22 22:42:12.000000000 +0200
+@@ -11,10 +11,11 @@
+ //
+
+ #include "../config.h"
+ #include "Util.hh"
+
++#include <cstdlib>
+ #include <algorithm>
+ #include <iostream>
+ #include <sstream>
+
+ #include <unistd.h>
+--- pekwm-0.1.6.orig/src/Util.hh 2007-05-08 10:10:13.000000000 +0200
++++ pekwm-0.1.6/src/Util.hh 2008-04-22 22:41:21.000000000 +0200
+@@ -12,10 +12,11 @@
+ #define _UTIL_HH_
+
+ #include "Types.hh"
+
+ #include <string>
++#include <cstring>
+ #include <vector>
+ #include <functional>
+ #include <sstream>
+
+ //! @brief Namespace Util used for various small file/string tasks.
diff --git a/x11-wm/pekwm/pekwm-0.1.6.ebuild b/x11-wm/pekwm/pekwm-0.1.6.ebuild
index 44b10e0a80d7..3b7f4297dcd2 100644
--- a/x11-wm/pekwm/pekwm-0.1.6.ebuild
+++ b/x11-wm/pekwm/pekwm-0.1.6.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/pekwm/pekwm-0.1.6.ebuild,v 1.3 2007/09/09 17:58:31 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/pekwm/pekwm-0.1.6.ebuild,v 1.4 2008/04/24 07:29:44 omp Exp $
+
+inherit eutils
DESCRIPTION="A small window mananger based on aewm++"
HOMEPAGE="http://www.pekwm.org/"
@@ -23,6 +25,13 @@ DEPEND="media-libs/jpeg
RDEPEND="${DEPEND}
x11-apps/xprop"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-gcc-4.3.patch"
+}
+
src_compile() {
econf \
$(use_enable debug) \