summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Shakaryan <omp@gentoo.org>2008-04-24 08:07:50 +0000
committerDavid Shakaryan <omp@gentoo.org>2008-04-24 08:07:50 +0000
commit93e555e8549c3ee9bc900c4ea0d794abfc1624de (patch)
tree70c384e8ba470ff49d61880291fe6c6c3c317a7c /x11-wm/wmii
parentFix incorrect desktop switching; patch by Tobias Klausmann (bug #216012) (diff)
downloadgentoo-2-93e555e8549c3ee9bc900c4ea0d794abfc1624de.tar.gz
gentoo-2-93e555e8549c3ee9bc900c4ea0d794abfc1624de.tar.bz2
gentoo-2-93e555e8549c3ee9bc900c4ea0d794abfc1624de.zip
Fix launching of dmenu; thanks to Casey Carter. (bug #214224)
(Portage version: 2.1.5_rc3)
Diffstat (limited to 'x11-wm/wmii')
-rw-r--r--x11-wm/wmii/ChangeLog9
-rw-r--r--x11-wm/wmii/wmii-3.6-r2.ebuild54
2 files changed, 61 insertions, 2 deletions
diff --git a/x11-wm/wmii/ChangeLog b/x11-wm/wmii/ChangeLog
index 4a3d18a6d31d..d5702b727917 100644
--- a/x11-wm/wmii/ChangeLog
+++ b/x11-wm/wmii/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/wmii
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/wmii/ChangeLog,v 1.26 2007/11/19 05:40:17 omp Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/wmii/ChangeLog,v 1.27 2008/04/24 08:07:50 omp Exp $
+
+*wmii-3.6-r2 (24 Apr 2008)
+
+ 24 Apr 2008; David Shakaryan <omp@gentoo.org> +wmii-3.6-r2.ebuild:
+ Fix launching of dmenu; thanks to Casey Carter. (bug #214224)
*wmii-3.6-r1 (19 Nov 2007)
diff --git a/x11-wm/wmii/wmii-3.6-r2.ebuild b/x11-wm/wmii/wmii-3.6-r2.ebuild
new file mode 100644
index 000000000000..e0d3d4b480f0
--- /dev/null
+++ b/x11-wm/wmii/wmii-3.6-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/wmii/wmii-3.6-r2.ebuild,v 1.1 2008/04/24 08:07:50 omp Exp $
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="A dynamic window manager for X11"
+HOMEPAGE="http://www.suckless.org/wiki/wmii"
+SRC_URI="http://www.suckless.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=">=sys-libs/libixp-0.4
+ x11-libs/libX11"
+RDEPEND="${DEPEND}
+ x11-apps/xmessage
+ x11-apps/xsetroot
+ x11-misc/dmenu"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "s/dmenu -b/dmenu/" \
+ rc/{rc.wmii.rc,sh.wmii,wmiirc.sh} || die "sed failed"
+
+ sed -i \
+ -e "/^PREFIX/s|=.*|= ${D}/usr|" \
+ -e "/^ETC/s|=.*|= ${D}/etc|" \
+ -e "/^LIBDIR/s|=.*|= /usr/$(get_libdir)|" \
+ config.mk || die "sed failed"
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+ dodoc NOTES README TODO
+
+ # Rid paths of temporary install directory. (bug #199551)
+ sed -i -e "s|${D}||g" "${D}/usr/bin/wmiistartrc"
+
+ echo -e "#!/bin/sh\n/usr/bin/wmii" > "${T}/${PN}"
+ exeinto /etc/X11/Sessions
+ doexe "${T}/${PN}"
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}/${PN}.desktop"
+}