summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-09-28 08:13:06 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-09-28 08:13:06 +0000
commit20cec344b0480f9bcb61aca2e2441b7a5b8f683a (patch)
treefedd526117aa8fdeb83ec2184a0fcc5698e5e77d /x11-wm
parentIncorrect license value now adjusted as per Ulrich Müller in bug #436064; th... (diff)
downloadgentoo-2-20cec344b0480f9bcb61aca2e2441b7a5b8f683a.tar.gz
gentoo-2-20cec344b0480f9bcb61aca2e2441b7a5b8f683a.tar.bz2
gentoo-2-20cec344b0480f9bcb61aca2e2441b7a5b8f683a.zip
Version bump for cinnamon-1.6.x. Compatible with cog-1.12 and clutter-1.12.
(Portage version: 2.2.0_alpha132/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/muffin/ChangeLog8
-rw-r--r--x11-wm/muffin/muffin-1.1.1.ebuild83
2 files changed, 90 insertions, 1 deletions
diff --git a/x11-wm/muffin/ChangeLog b/x11-wm/muffin/ChangeLog
index 3219cec26b3f..0f2594e17f7d 100644
--- a/x11-wm/muffin/ChangeLog
+++ b/x11-wm/muffin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/muffin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/muffin/ChangeLog,v 1.8 2012/09/09 00:31:41 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/muffin/ChangeLog,v 1.9 2012/09/28 08:13:06 tetromino Exp $
+
+*muffin-1.1.1 (28 Sep 2012)
+
+ 28 Sep 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +muffin-1.1.1.ebuild:
+ Version bump for cinnamon-1.6.x. Compatible with cog-1.12 and clutter-1.12.
*muffin-1.0.3_p2 (09 Sep 2012)
diff --git a/x11-wm/muffin/muffin-1.1.1.ebuild b/x11-wm/muffin/muffin-1.1.1.ebuild
new file mode 100644
index 000000000000..53ccd493ec0d
--- /dev/null
+++ b/x11-wm/muffin/muffin-1.1.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/muffin/muffin-1.1.1.ebuild,v 1.1 2012/09/28 08:13:06 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools gnome2
+
+DESCRIPTION="Compositing window manager forked from Mutter for use with Cinnamon"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+
+MY_PV="${PV/_p/-UP}"
+MY_P="${PN}-${MY_PV}"
+
+SRC_URI="https://github.com/linuxmint/muffin/tarball/${MY_PV} -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+introspection test xinerama"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND=">=x11-libs/pango-1.2[X,introspection?]
+ >=x11-libs/cairo-1.10[X]
+ x11-libs/gdk-pixbuf:2[introspection?]
+ >=x11-libs/gtk+-3.3.7:3[introspection?]
+ >=dev-libs/glib-2.25.10:2
+ >=media-libs/clutter-1.9.10:1.0[introspection?]
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=x11-libs/startup-notification-0.7
+ >=x11-libs/libXcomposite-0.2
+ >=gnome-base/gsettings-desktop-schemas-3.3.0[introspection?]
+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXrender
+
+ gnome-extra/zenity
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMON_DEPEND}
+ >=app-text/gnome-doc-utils-0.8
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+ test? ( app-text/docbook-xml-dtd:4.5 )
+ xinerama? ( x11-proto/xineramaproto )
+ x11-proto/xextproto
+ x11-proto/xproto"
+RDEPEND="${COMMON_DEPEND}
+ !x11-misc/expocity"
+
+S="${WORKDIR}/linuxmint-muffin-392f000"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* *.txt doc/*.txt"
+ G2CONF="${G2CONF}
+ --disable-static
+ --enable-shape
+ --enable-sm
+ --enable-startup-notification
+ --enable-xsync
+ --enable-verbose-mode
+ --enable-compile-warnings=maximum
+ --with-libcanberra
+ $(use_enable introspection)
+ $(use_enable xinerama)"
+}
+
+src_prepare() {
+ # Regenerate obsolete Makefile.in
+ eautoreconf
+ gnome2_src_prepare
+}