summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-03-27 17:04:03 +0000
committerJohannes Huber <johu@gentoo.org>2012-03-27 17:04:03 +0000
commiteba95df8d9a68148776b8051d96333f305e875dc (patch)
tree9a7fda6a938e9872a5f746e62d4f3f44fb187913 /x11-wm
parentFix bug #409365 by Marcin Mirosław (broken permissions when attempt to save ... (diff)
downloadgentoo-2-eba95df8d9a68148776b8051d96333f305e875dc.tar.gz
gentoo-2-eba95df8d9a68148776b8051d96333f305e875dc.tar.bz2
gentoo-2-eba95df8d9a68148776b8051d96333f305e875dc.zip
Revision bump. Add missing and fix automagic dependencies by Michael (kensington) <gentoo@scribeofthenile.com>. Fixes bug #405935.
(Portage version: 2.2.0_alpha95/cvs/Linux i686)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/razorqt/ChangeLog10
-rw-r--r--x11-wm/razorqt/files/razorqt-0.4.1-automagic.patch18
-rw-r--r--x11-wm/razorqt/razorqt-0.4.1-r1.ebuild (renamed from x11-wm/razorqt/razorqt-0.4.1.ebuild)22
3 files changed, 47 insertions, 3 deletions
diff --git a/x11-wm/razorqt/ChangeLog b/x11-wm/razorqt/ChangeLog
index e0f8b418e8a1..52a9edce043c 100644
--- a/x11-wm/razorqt/ChangeLog
+++ b/x11-wm/razorqt/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-wm/razorqt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/razorqt/ChangeLog,v 1.1 2012/02/18 11:59:37 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/razorqt/ChangeLog,v 1.2 2012/03/27 17:04:03 johu Exp $
+
+*razorqt-0.4.1-r1 (27 Mar 2012)
+
+ 27 Mar 2012; Johannes Huber <johu@gentoo.org>
+ +files/razorqt-0.4.1-automagic.patch, +razorqt-0.4.1-r1.ebuild,
+ -razorqt-0.4.1.ebuild:
+ Revision bump. Add missing and fix automagic dependencies by Michael
+ (kensington) <gentoo@scribeofthenile.com>. Fixes bug #405935.
*razorqt-0.4.1 (18 Feb 2012)
diff --git a/x11-wm/razorqt/files/razorqt-0.4.1-automagic.patch b/x11-wm/razorqt/files/razorqt-0.4.1-automagic.patch
new file mode 100644
index 000000000000..2ac49c32acd6
--- /dev/null
+++ b/x11-wm/razorqt/files/razorqt-0.4.1-automagic.patch
@@ -0,0 +1,18 @@
+--- razorqt-policykit/CMakeLists.txt
++++ razorqt-policykit/CMakeLists.txt
+@@ -1,4 +1,9 @@
++OPTION(ENABLE_POLICYKIT "Enable policykit integration" ON)
++
++if (ENABLE_POLICYKIT)
++
+ find_package(PolkitQt-1)
++
+ if (NOT POLKITQT-1_LIB_DIR AND NOT POLKITQT-1_INCLUDE_DIR)
+ message(WARNING "Qt bindings for policykit are not found. Razor policykit integration won't be built")
+ message(STATUS "Hint: package libpolkit-qt-1-devel on openSUSE")
+@@ -55,3 +60,5 @@
+ install(TARGETS razor-policykit-agent DESTINATION bin)
+
+ endif()
++
++endif (ENABLE_POLICYKIT)
diff --git a/x11-wm/razorqt/razorqt-0.4.1.ebuild b/x11-wm/razorqt/razorqt-0.4.1-r1.ebuild
index 3333170d1a66..b51789278770 100644
--- a/x11-wm/razorqt/razorqt-0.4.1.ebuild
+++ b/x11-wm/razorqt/razorqt-0.4.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/razorqt/razorqt-0.4.1.ebuild,v 1.1 2012/02/18 11:59:37 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/razorqt/razorqt-0.4.1-r1.ebuild,v 1.1 2012/03/27 17:04:03 johu Exp $
EAPI=4
@@ -23,9 +23,18 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="doc policykit"
-COMMON_DEPEND="policykit? ( sys-auth/polkit-qt )
+COMMON_DEPEND="sys-apps/file
+ policykit? (
+ dev-libs/glib:2
+ sys-auth/polkit-qt
+ )
+ sys-libs/zlib
+ x11-libs/libX11
x11-libs/libXcomposite
+ x11-libs/libXcursor
x11-libs/libXdamage
+ x11-libs/libXfixes
+ x11-libs/libXrender
x11-libs/qt-core:4
x11-libs/qt-dbus:4
x11-libs/qt-gui:4
@@ -47,6 +56,15 @@ RDEPEND="${COMMON_DEPEND}
x11-wm/windowmaker
)"
+PATCHES=( "${FILESDIR}/${P}-automagic.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable policykit)
+ )
+ cmake-utils_src_configure
+}
+
src_compile() {
cmake-utils_src_make