summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-05-09 18:15:27 +0000
committerChristoph Mende <angelos@gentoo.org>2011-05-09 18:15:27 +0000
commit2eb0f10823d845f6a89e6fdfe16f88b0a96b696d (patch)
treee67f50d6d83c7a412875ddde38de616b2041ab81 /xfce-base/exo
parentTweak sys-libs/db requirements to avoid incompatible versions. Should fix bug... (diff)
downloadgentoo-2-2eb0f10823d845f6a89e6fdfe16f88b0a96b696d.tar.gz
gentoo-2-2eb0f10823d845f6a89e6fdfe16f88b0a96b696d.tar.bz2
gentoo-2-2eb0f10823d845f6a89e6fdfe16f88b0a96b696d.zip
Version bump
(Portage version: 2.2.0_alpha32/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/exo')
-rw-r--r--xfce-base/exo/ChangeLog7
-rw-r--r--xfce-base/exo/exo-0.6.1.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/xfce-base/exo/ChangeLog b/xfce-base/exo/ChangeLog
index 09506f780b74..d85807b95be5 100644
--- a/xfce-base/exo/ChangeLog
+++ b/xfce-base/exo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/exo
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.53 2011/02/14 19:18:38 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.54 2011/05/09 18:15:27 angelos Exp $
+
+*exo-0.6.1 (09 May 2011)
+
+ 09 May 2011; Christoph Mende <angelos@gentoo.org> +exo-0.6.1.ebuild:
+ Version bump
14 Feb 2011; Samuli Suominen <ssuominen@gentoo.org> exo-0.6.0.ebuild:
alpha/ia64/sparc stable wrt #349053
diff --git a/xfce-base/exo/exo-0.6.1.ebuild b/xfce-base/exo/exo-0.6.1.ebuild
new file mode 100644
index 000000000000..b9758ab5dcc5
--- /dev/null
+++ b/xfce-base/exo/exo-0.6.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/exo-0.6.1.ebuild,v 1.1 2011/05/09 18:15:27 angelos Exp $
+
+EAPI=3
+PYTHON_DEPEND="python? 2"
+inherit python xfconf
+
+DESCRIPTION="Extensions, widgets and framework library with session management support"
+HOMEPAGE="http://www.xfce.org/projects/exo/"
+SRC_URI="mirror://xfce/src/xfce/exo/0.6/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="debug python"
+
+RDEPEND=">=dev-lang/perl-5.6
+ dev-perl/URI
+ >=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.14:2
+ >=xfce-base/libxfce4util-4.8
+ python? ( >=dev-python/pygtk-2.4 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --disable-static
+ $(use_enable python)
+ $(xfconf_use_debug)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ DOCS="AUTHORS ChangeLog HACKING NEWS README THANKS TODO"
+}
+
+src_prepare() {
+ rm -f py-compile
+ ln -s $(type -P true) py-compile
+
+ xfconf_src_prepare
+}
+
+pkg_postinst() {
+ xfconf_pkg_postinst
+ use python && python_mod_optimize exo-0.6 pyexo.py
+}
+
+pkg_postrm() {
+ xfconf_pkg_postrm
+ use python && python_mod_cleanup exo-0.6 pyexo.py
+}