summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-06-10 18:38:28 +0000
committerChristoph Mende <angelos@gentoo.org>2011-06-10 18:38:28 +0000
commit7a18168c57b039fa1e03492a5b2dcc97d9dd514d (patch)
tree8a22fa945c944e3fabfb9d79ed3d33d91589f085 /xfce-base/exo
parentVersion bump (diff)
downloadgentoo-2-7a18168c57b039fa1e03492a5b2dcc97d9dd514d.tar.gz
gentoo-2-7a18168c57b039fa1e03492a5b2dcc97d9dd514d.tar.bz2
gentoo-2-7a18168c57b039fa1e03492a5b2dcc97d9dd514d.zip
Version bump
(Portage version: 2.2.0_alpha39/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/exo')
-rw-r--r--xfce-base/exo/ChangeLog7
-rw-r--r--xfce-base/exo/exo-0.6.2.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/xfce-base/exo/ChangeLog b/xfce-base/exo/ChangeLog
index 9c7d726e694f..1281b95c1e9c 100644
--- a/xfce-base/exo/ChangeLog
+++ b/xfce-base/exo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/exo
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.56 2011/05/20 17:55:18 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.57 2011/06/10 18:38:28 angelos Exp $
+
+*exo-0.6.2 (10 Jun 2011)
+
+ 10 Jun 2011; Christoph Mende <angelos@gentoo.org> +exo-0.6.2.ebuild:
+ Version bump
20 May 2011; Fabian Groffen <grobian@gentoo.org> exo-0.6.1.ebuild:
Add --disable-visibility on Darwin, bug #366857
diff --git a/xfce-base/exo/exo-0.6.2.ebuild b/xfce-base/exo/exo-0.6.2.ebuild
new file mode 100644
index 000000000000..7491cee91b75
--- /dev/null
+++ b/xfce-base/exo/exo-0.6.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/exo-0.6.2.ebuild,v 1.1 2011/06/10 18:38:28 angelos Exp $
+
+EAPI=3
+PYTHON_DEPEND="python? 2"
+inherit python xfconf
+
+DESCRIPTION="Extensions, widgets and framework library with session management support"
+HOMEPAGE="http://www.xfce.org/projects/exo/"
+SRC_URI="mirror://xfce/src/xfce/exo/0.6/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="debug python"
+
+RDEPEND=">=dev-lang/perl-5.6
+ dev-perl/URI
+ >=dev-libs/glib-2.18:2
+ >=x11-libs/gtk+-2.14:2
+ >=xfce-base/libxfce4util-4.8
+ python? ( >=dev-python/pygtk-2.4 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --disable-dependency-tracking
+ --disable-static
+ $(use_enable python)
+ $(xfconf_use_debug)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+ [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) # 366857
+
+ DOCS=( AUTHORS ChangeLog HACKING NEWS README THANKS TODO )
+}
+
+src_prepare() {
+ rm -f py-compile
+ ln -s $(type -P true) py-compile
+
+ xfconf_src_prepare
+}
+
+pkg_postinst() {
+ xfconf_pkg_postinst
+ use python && python_mod_optimize exo-0.6 pyexo.py
+}
+
+pkg_postrm() {
+ xfconf_pkg_postrm
+ use python && python_mod_cleanup exo-0.6 pyexo.py
+}