summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-10-15 21:08:17 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-10-15 21:08:17 +0000
commitbc656b0342198d5cb9d37de1391b75c55e3d7d59 (patch)
treeac0d2729a985d67c1842b39ce73bef3135c87c2c /xfce-base/exo
parentold (diff)
downloadgentoo-2-bc656b0342198d5cb9d37de1391b75c55e3d7d59.tar.gz
gentoo-2-bc656b0342198d5cb9d37de1391b75c55e3d7d59.tar.bz2
gentoo-2-bc656b0342198d5cb9d37de1391b75c55e3d7d59.zip
Now that python.eclass has EAPI=4 support, convert to EAPI=4 so xfconf.eclass can stop supporting deprecated EAPI=3.
(Portage version: 2.2.0_alpha67/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/exo')
-rw-r--r--xfce-base/exo/ChangeLog7
-rw-r--r--xfce-base/exo/exo-0.6.0.ebuild6
-rw-r--r--xfce-base/exo/exo-0.6.2.ebuild7
3 files changed, 11 insertions, 9 deletions
diff --git a/xfce-base/exo/ChangeLog b/xfce-base/exo/ChangeLog
index 2a4a3aa156e4..f83c91e5cfa7 100644
--- a/xfce-base/exo/ChangeLog
+++ b/xfce-base/exo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/exo
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.58 2011/10/15 21:06:43 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/ChangeLog,v 1.59 2011/10/15 21:08:17 ssuominen Exp $
+
+ 15 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> exo-0.6.0.ebuild,
+ exo-0.6.2.ebuild:
+ Now that python.eclass has EAPI=4 support, convert to EAPI=4 so xfconf.eclass
+ can stop supporting deprecated EAPI=3.
15 Oct 2011; Samuli Suominen <ssuominen@gentoo.org> -exo-0.6.1.ebuild:
old
diff --git a/xfce-base/exo/exo-0.6.0.ebuild b/xfce-base/exo/exo-0.6.0.ebuild
index babd67bb666b..e7a538f057ce 100644
--- a/xfce-base/exo/exo-0.6.0.ebuild
+++ b/xfce-base/exo/exo-0.6.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/exo-0.6.0.ebuild,v 1.7 2011/05/19 22:01:12 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/exo-0.6.0.ebuild,v 1.8 2011/10/15 21:08:17 ssuominen Exp $
-EAPI=3
+EAPI=4
PYTHON_DEPEND="python? 2"
@@ -36,7 +36,6 @@ pkg_setup() {
XFCONF=(
--docdir="${EPREFIX}"/usr/share/doc/${PF}
- --disable-dependency-tracking
--disable-static
$(use_enable python)
$(xfconf_use_debug)
@@ -49,7 +48,6 @@ pkg_setup() {
src_prepare() {
rm -f py-compile
ln -s $(type -P true) py-compile
-
xfconf_src_prepare
}
diff --git a/xfce-base/exo/exo-0.6.2.ebuild b/xfce-base/exo/exo-0.6.2.ebuild
index 7491cee91b75..e9259b15d8fd 100644
--- a/xfce-base/exo/exo-0.6.2.ebuild
+++ b/xfce-base/exo/exo-0.6.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/exo-0.6.2.ebuild,v 1.1 2011/06/10 18:38:28 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/exo/exo-0.6.2.ebuild,v 1.2 2011/10/15 21:08:17 ssuominen Exp $
-EAPI=3
+EAPI=4
PYTHON_DEPEND="python? 2"
inherit python xfconf
@@ -34,12 +34,12 @@ pkg_setup() {
XFCONF=(
--docdir="${EPREFIX}"/usr/share/doc/${PF}
- --disable-dependency-tracking
--disable-static
$(use_enable python)
$(xfconf_use_debug)
--with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
)
+
[[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) # 366857
DOCS=( AUTHORS ChangeLog HACKING NEWS README THANKS TODO )
@@ -48,7 +48,6 @@ pkg_setup() {
src_prepare() {
rm -f py-compile
ln -s $(type -P true) py-compile
-
xfconf_src_prepare
}