summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-30 16:56:11 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-30 16:56:11 +0000
commitf15cdc2f9310440a84173290f3b475e99ec0f6ee (patch)
tree933c7a516a8894a4c76bf9c0685f934ebcfc1159 /xfce-base/xfce-utils
parentia64/sparc stable (diff)
downloadgentoo-2-f15cdc2f9310440a84173290f3b475e99ec0f6ee.tar.gz
gentoo-2-f15cdc2f9310440a84173290f3b475e99ec0f6ee.tar.bz2
gentoo-2-f15cdc2f9310440a84173290f3b475e99ec0f6ee.zip
Version bump.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/xfce-utils')
-rw-r--r--xfce-base/xfce-utils/ChangeLog7
-rw-r--r--xfce-base/xfce-utils/xfce-utils-4.8.1.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/xfce-base/xfce-utils/ChangeLog b/xfce-base/xfce-utils/ChangeLog
index 9bf8b6fa572c..5331a928a97d 100644
--- a/xfce-base/xfce-utils/ChangeLog
+++ b/xfce-base/xfce-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/xfce-utils
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/ChangeLog,v 1.173 2011/01/25 20:24:50 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/ChangeLog,v 1.174 2011/01/30 16:56:11 ssuominen Exp $
+
+*xfce-utils-4.8.1 (30 Jan 2011)
+
+ 30 Jan 2011; Samuli Suominen <ssuominen@gentoo.org> +xfce-utils-4.8.1.ebuild:
+ Version bump.
25 Jan 2011; Jeroen Roovers <jer@gentoo.org> xfce-utils-4.8.0.ebuild:
Stable for HPPA (bug #349053).
diff --git a/xfce-base/xfce-utils/xfce-utils-4.8.1.ebuild b/xfce-base/xfce-utils/xfce-utils-4.8.1.ebuild
new file mode 100644
index 000000000000..d23a32c61a82
--- /dev/null
+++ b/xfce-base/xfce-utils/xfce-utils-4.8.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/xfce-utils-4.8.1.ebuild,v 1.1 2011/01/30 16:56:11 ssuominen Exp $
+
+EAPI=3
+inherit xfconf
+
+DESCRIPTION="Utilities for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/xfce-utils/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/4.8/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="dbus debug +lock"
+
+COMMON_DEPEND="x11-libs/libX11
+ >=x11-libs/gtk+-2.10:2
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/libxfce4ui-4.8
+ >=xfce-base/xfconf-4.8
+ dbus? ( >=dev-libs/dbus-glib-0.88 )"
+RDEPEND="${COMMON_DEPEND}
+ x11-apps/xrdb
+ x11-misc/xdg-user-dirs
+ lock? ( || ( x11-misc/xscreensaver
+ gnome-extra/gnome-screensaver
+ x11-misc/xlockmore
+ x11-misc/slock ) )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --disable-dependency-tracking
+ --disable-xfconf-migration
+ $(use_enable dbus)
+ $(xfconf_use_debug)
+ --with-vendor-info=Gentoo
+ --with-xsession-prefix="${EPREFIX}"/usr
+ )
+
+ DOCS="AUTHORS ChangeLog NEWS"
+}
+
+src_install() {
+ xfconf_src_install
+
+ rm -f "${ED}"/usr/share/applications/xfhelp4.desktop
+
+ echo startxfce4 > "${T}"/Xfce4
+ exeinto /etc/X11/Sessions
+ doexe "${T}"/Xfce4 || die
+}