summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-12-03 21:22:47 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-12-03 21:22:47 +0000
commit26f7865f0cc489ae7b6824c0566aea8f8a9b1069 (patch)
tree76125763472f06604d415afac3c9aaa6428052d6 /xfce-base
parentVersion bump. (diff)
downloadgentoo-2-26f7865f0cc489ae7b6824c0566aea8f8a9b1069.tar.gz
gentoo-2-26f7865f0cc489ae7b6824c0566aea8f8a9b1069.tar.bz2
gentoo-2-26f7865f0cc489ae7b6824c0566aea8f8a9b1069.zip
Version bump.
(Portage version: 2.2.0_alpha6/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfce-utils/ChangeLog7
-rw-r--r--xfce-base/xfce-utils/xfce-utils-4.7.2.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/xfce-base/xfce-utils/ChangeLog b/xfce-base/xfce-utils/ChangeLog
index 1a1a20903328..c3d3ed6418b1 100644
--- a/xfce-base/xfce-utils/ChangeLog
+++ b/xfce-base/xfce-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/xfce-utils
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/ChangeLog,v 1.166 2010/11/11 09:22:14 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/ChangeLog,v 1.167 2010/12/03 21:22:45 ssuominen Exp $
+
+*xfce-utils-4.7.2 (03 Dec 2010)
+
+ 03 Dec 2010; Samuli Suominen <ssuominen@gentoo.org> +xfce-utils-4.7.2.ebuild:
+ Version bump.
11 Nov 2010; Samuli Suominen <ssuominen@gentoo.org>
xfce-utils-4.7.1.ebuild:
diff --git a/xfce-base/xfce-utils/xfce-utils-4.7.2.ebuild b/xfce-base/xfce-utils/xfce-utils-4.7.2.ebuild
new file mode 100644
index 000000000000..1762e244981e
--- /dev/null
+++ b/xfce-base/xfce-utils/xfce-utils-4.7.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce-utils/xfce-utils-4.7.2.ebuild,v 1.1 2010/12/03 21:22:47 ssuominen Exp $
+
+EAPI=3
+inherit xfconf
+
+DESCRIPTION="Collection of utils for Xfce4"
+HOMEPAGE="http://www.xfce.org/projects/xfce-utils/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/4.7/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="dbus debug +lock"
+
+COMMON_DEPEND="x11-libs/libX11
+ >=x11-libs/gtk+-2.10:2
+ >=xfce-base/libxfce4util-4.6
+ >=xfce-base/libxfce4ui-4.7
+ >=xfce-base/xfconf-4.6
+ dbus? ( >=dev-libs/dbus-glib-0.70 )"
+RDEPEND="${COMMON_DEPEND}
+ x11-apps/xrdb
+ x11-misc/xdg-user-dirs
+ lock? ( || ( x11-misc/xscreensaver
+ gnome-extra/gnome-screensaver
+ x11-misc/xlockmore
+ x11-misc/slock ) )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --disable-dependency-tracking
+ --disable-xfconf-migration
+ $(use_enable dbus)
+ $(xfconf_use_debug)
+ --with-vendor-info=Gentoo
+ --with-xsession-prefix="${EPREFIX}"/usr
+ )
+
+ DOCS="AUTHORS ChangeLog NEWS"
+}
+
+src_install() {
+ xfconf_src_install
+
+ rm -f "${ED}"/usr/share/applications/xfhelp4.desktop
+
+ insinto /usr/share/xfce4
+ doins "${FILESDIR}"/Gentoo || die
+
+ echo startxfce4 > "${T}"/Xfce4
+ exeinto /etc/X11/Sessions
+ doexe "${T}"/Xfce4 || die
+}