summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-06-22 21:53:20 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-06-22 21:53:20 +0000
commitf6feff87a0ff5b4f841037b34ba6a35fd81987fb (patch)
tree4298d22927465caf632ccff3e6356a33a30b8de8 /xfce-base
parentFix build with USE=-python. Remove obsolete Python build hack. (diff)
downloadgentoo-2-f6feff87a0ff5b4f841037b34ba6a35fd81987fb.tar.gz
gentoo-2-f6feff87a0ff5b4f841037b34ba6a35fd81987fb.tar.bz2
gentoo-2-f6feff87a0ff5b4f841037b34ba6a35fd81987fb.zip
Version bump; fixing annoying problem with autohiding the panel with the action buttons.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfce4-panel/ChangeLog9
-rw-r--r--xfce-base/xfce4-panel/xfce4-panel-4.11.1.ebuild44
2 files changed, 52 insertions, 1 deletions
diff --git a/xfce-base/xfce4-panel/ChangeLog b/xfce-base/xfce4-panel/ChangeLog
index 80d2f970a482..afd5e18571c9 100644
--- a/xfce-base/xfce4-panel/ChangeLog
+++ b/xfce-base/xfce4-panel/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for xfce-base/xfce4-panel
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-panel/ChangeLog,v 1.252 2014/04/22 13:48:59 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-panel/ChangeLog,v 1.253 2014/06/22 21:53:20 ssuominen Exp $
+
+*xfce4-panel-4.11.1 (22 Jun 2014)
+
+ 22 Jun 2014; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-panel-4.11.1.ebuild:
+ Version bump; fixing annoying problem with autohiding the panel with the
+ action buttons.
22 Apr 2014; Samuli Suominen <ssuominen@gentoo.org>
-files/xfce4-panel-4.10.0-icons.patch, -xfce4-panel-4.10.0-r1.ebuild:
diff --git a/xfce-base/xfce4-panel/xfce4-panel-4.11.1.ebuild b/xfce-base/xfce4-panel/xfce4-panel-4.11.1.ebuild
new file mode 100644
index 000000000000..e3c82c58f0ca
--- /dev/null
+++ b/xfce-base/xfce4-panel/xfce4-panel-4.11.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-panel/xfce4-panel-4.11.1.ebuild,v 1.1 2014/06/22 21:53:20 ssuominen Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Panel for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.24
+ >=x11-libs/cairo-1
+ >=x11-libs/gtk+-2.20:2
+ >=x11-libs/gtk+-3.2:3
+ x11-libs/libX11
+ >=x11-libs/libwnck-2.31:1
+ >=xfce-base/exo-0.8
+ >=xfce-base/garcon-0.3
+ >=xfce-base/libxfce4ui-4.11
+ >=xfce-base/libxfce4util-4.11
+ >=xfce-base/xfconf-4.10"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --enable-gtk3
+ $(xfconf_use_debug)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS THANKS )
+}