summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-06-30 09:29:38 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-06-30 09:29:38 +0000
commit5f157041b26745e5db100d52bcfced97fc4e6b34 (patch)
treebc2cfba4a2222ea42e3a920a29c26aa8736137a9 /xfce-extra/xfce4-battery-plugin
parentVersion bump to proper release from the beta. (diff)
downloadgentoo-2-5f157041b26745e5db100d52bcfced97fc4e6b34.tar.gz
gentoo-2-5f157041b26745e5db100d52bcfced97fc4e6b34.tar.bz2
gentoo-2-5f157041b26745e5db100d52bcfced97fc4e6b34.zip
Version bump.
(Portage version: 2.2.0_alpha113/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra/xfce4-battery-plugin')
-rw-r--r--xfce-extra/xfce4-battery-plugin/ChangeLog8
-rw-r--r--xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.0.5.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/xfce-extra/xfce4-battery-plugin/ChangeLog b/xfce-extra/xfce4-battery-plugin/ChangeLog
index fc2808774aa6..2684747f2b65 100644
--- a/xfce-extra/xfce4-battery-plugin/ChangeLog
+++ b/xfce-extra/xfce4-battery-plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-battery-plugin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-battery-plugin/ChangeLog,v 1.22 2012/06/03 14:02:48 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-battery-plugin/ChangeLog,v 1.23 2012/06/30 09:29:38 ssuominen Exp $
+
+*xfce4-battery-plugin-1.0.5 (30 Jun 2012)
+
+ 30 Jun 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-battery-plugin-1.0.5.ebuild:
+ Version bump.
03 Jun 2012; Anthony G. Basile <blueness@gentoo.org>
xfce4-battery-plugin-1.0.4.ebuild:
diff --git a/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.0.5.ebuild b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.0.5.ebuild
new file mode 100644
index 000000000000..c172d2f7ede4
--- /dev/null
+++ b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.0.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.0.5.ebuild,v 1.1 2012/06/30 09:29:38 ssuominen Exp $
+
+EAPI=4
+inherit linux-info xfconf
+
+DESCRIPTION="A battery monitor panel plugin for the Xfce desktop environment"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-battery-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
+IUSE="debug kernel_linux"
+
+RDEPEND=">=dev-libs/glib-2.24
+ >=x11-libs/gtk+-2.20:2
+ >=xfce-base/libxfce4ui-4.8
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/xfce4-panel-4.8"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+
+ if use kernel_linux; then
+ CONFIG_CHECK="~ACPI_BATTERY"
+ linux-info_pkg_setup
+ fi
+}