summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-04-30 20:04:24 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-04-30 20:04:24 +0000
commit885eba9b5c6d13105a699270a106db49c9a83cd5 (patch)
tree45b59637c5e47a8add947c6a68c6c2a44034724f /xfce-extra/xfce4-battery-plugin
parenteapi=4; vdr-plugin-2.eclass; stable amd64 x86 (diff)
downloadgentoo-2-885eba9b5c6d13105a699270a106db49c9a83cd5.tar.gz
gentoo-2-885eba9b5c6d13105a699270a106db49c9a83cd5.tar.bz2
gentoo-2-885eba9b5c6d13105a699270a106db49c9a83cd5.zip
Version bump.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra/xfce4-battery-plugin')
-rw-r--r--xfce-extra/xfce4-battery-plugin/ChangeLog8
-rw-r--r--xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.0.2.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/xfce-extra/xfce4-battery-plugin/ChangeLog b/xfce-extra/xfce4-battery-plugin/ChangeLog
index 059cd9607a4d..56cf91d2c5e4 100644
--- a/xfce-extra/xfce4-battery-plugin/ChangeLog
+++ b/xfce-extra/xfce4-battery-plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-battery-plugin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-battery-plugin/ChangeLog,v 1.12 2012/04/17 18:16:15 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-battery-plugin/ChangeLog,v 1.13 2012/04/30 20:04:24 ssuominen Exp $
+
+*xfce4-battery-plugin-1.0.2 (30 Apr 2012)
+
+ 30 Apr 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-battery-plugin-1.0.2.ebuild:
+ Version bump.
*xfce4-battery-plugin-1.0.1 (17 Apr 2012)
diff --git a/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.0.2.ebuild b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.0.2.ebuild
new file mode 100644
index 000000000000..edb3238d09c3
--- /dev/null
+++ b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.0.2.ebuild,v 1.1 2012/04/30 20:04:24 ssuominen Exp $
+
+EAPI=4
+inherit linux-info xfconf
+
+DESCRIPTION="A battery monitor panel plugin for the Xfce desktop environment"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-battery-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="debug kernel_linux"
+
+RDEPEND=">=dev-libs/glib-2.24
+ >=x11-libs/gtk+-2.20:2
+ >=xfce-base/libxfce4ui-4.8
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/xfce4-panel-4.8"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+
+ if use kernel_linux; then
+ CONFIG_CHECK="~ACPI_BATTERY"
+ linux-info_pkg_setup
+ fi
+}