summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-05-19 20:26:50 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-05-19 20:26:50 +0000
commit830e680ebc3b61b98c8bc06755306bc5261d8a07 (patch)
treed172acf87b4340d3f9f2da7fab71317b93d84e13 /xfce-extra/xfce4-mpc-plugin
parentBump to final 2.6.0 version. (diff)
downloadgentoo-2-830e680ebc3b61b98c8bc06755306bc5261d8a07.tar.gz
gentoo-2-830e680ebc3b61b98c8bc06755306bc5261d8a07.tar.bz2
gentoo-2-830e680ebc3b61b98c8bc06755306bc5261d8a07.zip
EAPI4
(Portage version: 2.2.0_alpha33/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra/xfce4-mpc-plugin')
-rw-r--r--xfce-extra/xfce4-mpc-plugin/xfce4-mpc-plugin-0.3.6.ebuild20
1 files changed, 7 insertions, 13 deletions
diff --git a/xfce-extra/xfce4-mpc-plugin/xfce4-mpc-plugin-0.3.6.ebuild b/xfce-extra/xfce4-mpc-plugin/xfce4-mpc-plugin-0.3.6.ebuild
index 0fd8ba0830d2..e587f46c8dfe 100644
--- a/xfce-extra/xfce4-mpc-plugin/xfce4-mpc-plugin-0.3.6.ebuild
+++ b/xfce-extra/xfce4-mpc-plugin/xfce4-mpc-plugin-0.3.6.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-mpc-plugin/xfce4-mpc-plugin-0.3.6.ebuild,v 1.4 2011/03/22 10:45:25 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-mpc-plugin/xfce4-mpc-plugin-0.3.6.ebuild,v 1.5 2011/05/19 20:26:50 ssuominen Exp $
-EAPI=3
+EAPI=4
inherit xfconf
DESCRIPTION="Music Player Daemon (mpd) panel plugin"
@@ -14,21 +14,15 @@ SLOT="0"
KEYWORDS="amd64 ~ppc ~ppc64 x86"
IUSE="libmpd"
-RDEPEND=">=xfce-base/exo-0.3.1.1
- >=xfce-base/libxfcegui4-4.3.22
- >=xfce-base/xfce4-panel-4.3.22
+RDEPEND=">=xfce-base/exo-0.6
+ >=xfce-base/libxfcegui4-4.8
+ >=xfce-base/xfce4-panel-4.8
libmpd? ( media-libs/libmpd )"
DEPEND="${RDEPEND}
dev-util/pkgconfig
dev-util/intltool"
pkg_setup() {
- # $(xfconf_use_debug) removed because the package is still using
- # deprecated libxfcegui4 functions. restore when the package has
- # been migrated to libxfce4ui.
- XFCONF=(
- --disable-dependency-tracking
- $(use_enable libmpd)
- )
- DOCS="AUTHORS ChangeLog README TODO"
+ XFCONF=( $(use_enable libmpd) )
+ DOCS=( AUTHORS ChangeLog README TODO )
}