summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-05-01 11:25:06 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-05-01 11:25:06 +0000
commitadb51d82ef3a59f6fe6f87de1fa3518ee572b828 (patch)
tree443a4506e2cdf9017ce6db00afcb6cf2e5b98428 /xfce-extra/xfce4-xkb-plugin
parentVersion bump. (diff)
downloadgentoo-2-adb51d82ef3a59f6fe6f87de1fa3518ee572b828.tar.gz
gentoo-2-adb51d82ef3a59f6fe6f87de1fa3518ee572b828.tar.bz2
gentoo-2-adb51d82ef3a59f6fe6f87de1fa3518ee572b828.zip
New snapshot to plug multiple memory leaks wrt #351546.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra/xfce4-xkb-plugin')
-rw-r--r--xfce-extra/xfce4-xkb-plugin/ChangeLog8
-rw-r--r--xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.5.4.0_p20110501.ebuild38
2 files changed, 45 insertions, 1 deletions
diff --git a/xfce-extra/xfce4-xkb-plugin/ChangeLog b/xfce-extra/xfce4-xkb-plugin/ChangeLog
index 43c493735c13..0c2159b5140d 100644
--- a/xfce-extra/xfce4-xkb-plugin/ChangeLog
+++ b/xfce-extra/xfce4-xkb-plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-xkb-plugin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-xkb-plugin/ChangeLog,v 1.27 2011/04/19 13:08:11 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-xkb-plugin/ChangeLog,v 1.28 2011/05/01 11:25:06 ssuominen Exp $
+
+*xfce4-xkb-plugin-0.5.4.0_p20110501 (01 May 2011)
+
+ 01 May 2011; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-xkb-plugin-0.5.4.0_p20110501.ebuild:
+ New snapshot to plug multiple memory leaks wrt #351546.
*xfce4-xkb-plugin-0.5.4.0 (19 Apr 2011)
diff --git a/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.5.4.0_p20110501.ebuild b/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.5.4.0_p20110501.ebuild
new file mode 100644
index 000000000000..73c49d9a7342
--- /dev/null
+++ b/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.5.4.0_p20110501.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.5.4.0_p20110501.ebuild,v 1.1 2011/05/01 11:25:06 ssuominen Exp $
+
+EAPI=4
+EAUTORECONF=yes
+inherit xfconf
+
+DESCRIPTION="XKB layout switching panel plug-in for the Xfce desktop environment"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-xkb-plugin"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz"
+#SRC_URI="mirror://xfce/src/panel-plugins/${PN}/0.5/${P}.tar.bz2"
+
+LICENSE="BSD-2 GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND=">=xfce-base/libxfce4ui-4.8
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/xfce4-panel-4.8
+ x11-libs/gtk+:2
+ >=x11-libs/libxklavier-5
+ >=x11-libs/libwnck-2.12:1"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ >=gnome-base/librsvg-2.18:2
+ x11-proto/kbproto"
+
+pkg_setup() {
+ XFCONF=(
+ --enable-maintainer-mode
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog README )
+}