summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-02-05 20:10:14 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-02-05 20:10:14 +0000
commit056ff89a3f803e9f3b25913f7aae29621cb3a403 (patch)
tree59254cc1d7adaf40fb0bcb5da21560964605c7b0 /xfce-extra
parentVersion bump. (diff)
downloadgentoo-2-056ff89a3f803e9f3b25913f7aae29621cb3a403.tar.gz
gentoo-2-056ff89a3f803e9f3b25913f7aae29621cb3a403.tar.bz2
gentoo-2-056ff89a3f803e9f3b25913f7aae29621cb3a403.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-clipman-plugin/ChangeLog11
-rw-r--r--xfce-extra/xfce4-clipman-plugin/metadata.xml3
-rw-r--r--xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.2.5.ebuild41
3 files changed, 52 insertions, 3 deletions
diff --git a/xfce-extra/xfce4-clipman-plugin/ChangeLog b/xfce-extra/xfce4-clipman-plugin/ChangeLog
index 42cfc19c7f77..4584fbd59b8a 100644
--- a/xfce-extra/xfce4-clipman-plugin/ChangeLog
+++ b/xfce-extra/xfce4-clipman-plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-clipman-plugin
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-clipman-plugin/ChangeLog,v 1.49 2012/11/28 12:21:29 ssuominen Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-clipman-plugin/ChangeLog,v 1.50 2014/02/05 20:10:14 ssuominen Exp $
+
+*xfce4-clipman-plugin-1.2.5 (05 Feb 2014)
+
+ 05 Feb 2014; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-clipman-plugin-1.2.5.ebuild, metadata.xml:
+ Version bump.
28 Nov 2012; Samuli Suominen <ssuominen@gentoo.org>
xfce4-clipman-plugin-1.2.3.ebuild:
@@ -216,4 +222,3 @@
23 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+xfce4-clipman-plugin-0.8.1.ebuild, +xfce4-clipman-plugin-1.0.2.ebuild:
Rename xfce4-clipman to xfce4-clipman-plugin.
-
diff --git a/xfce-extra/xfce4-clipman-plugin/metadata.xml b/xfce-extra/xfce4-clipman-plugin/metadata.xml
index d56729e92f8e..af782a9ca930 100644
--- a/xfce-extra/xfce4-clipman-plugin/metadata.xml
+++ b/xfce-extra/xfce4-clipman-plugin/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>xfce</herd>
+ <use>
+ <flag name='qrcode'>Enable support for <pkg>media-gfx/qrencode</pkg></flag>
+ </use>
</pkgmetadata>
diff --git a/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.2.5.ebuild b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.2.5.ebuild
new file mode 100644
index 000000000000..b71535c82a50
--- /dev/null
+++ b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.2.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.2.5.ebuild,v 1.1 2014/02/05 20:10:14 ssuominen Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="A clipboard manager plug-in for the Xfce panel"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-clipman-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug qrcode"
+
+RDEPEND=">=dev-libs/glib-2.18
+ dev-libs/libunique:1
+ >=x11-libs/gtk+-2.14:2
+ x11-libs/libXtst
+ >=xfce-base/exo-0.10
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfce4-panel-4.10
+ >=xfce-base/xfconf-4.10
+ qrcode? ( >=media-gfx/qrencode-3.3.0 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-proto/xproto"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable qrcode libqrencode)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}