summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-03-15 14:11:14 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-03-15 14:11:14 +0000
commit4183141505759433876f32ceabf5802ebd89fa1d (patch)
tree9e6c875d92549fbdb3f3894a76bdb3dd99c0a03d /xfce-extra
parentMask new xfce4-indicator-plugin together with required GTK+-3.x version of li... (diff)
downloadgentoo-2-4183141505759433876f32ceabf5802ebd89fa1d.tar.gz
gentoo-2-4183141505759433876f32ceabf5802ebd89fa1d.tar.bz2
gentoo-2-4183141505759433876f32ceabf5802ebd89fa1d.zip
Version bump to version making use of the GTK+-3.x libxfce4ui from Xfce 4.12 (git)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-indicator-plugin/ChangeLog11
-rw-r--r--xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.3.1.ebuild37
2 files changed, 46 insertions, 2 deletions
diff --git a/xfce-extra/xfce4-indicator-plugin/ChangeLog b/xfce-extra/xfce4-indicator-plugin/ChangeLog
index 82ad901e53e5..a82a35b1289b 100644
--- a/xfce-extra/xfce4-indicator-plugin/ChangeLog
+++ b/xfce-extra/xfce4-indicator-plugin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for xfce-extra/xfce4-indicator-plugin
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-indicator-plugin/ChangeLog,v 1.18 2013/07/15 23:23:30 ssuominen Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-indicator-plugin/ChangeLog,v 1.19 2014/03/15 14:11:14 ssuominen Exp $
+
+*xfce4-indicator-plugin-2.3.1 (15 Mar 2014)
+
+ 15 Mar 2014; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-indicator-plugin-2.3.1.ebuild:
+ Version bump to version making use of the GTK+-3.x libxfce4ui from Xfce 4.12
+ (git)
15 Jul 2013; Samuli Suominen <ssuominen@gentoo.org>
-xfce4-indicator-plugin-0.5.0.ebuild:
diff --git a/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.3.1.ebuild b/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.3.1.ebuild
new file mode 100644
index 000000000000..85f25e17dd09
--- /dev/null
+++ b/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.3.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.3.1.ebuild,v 1.1 2014/03/15 14:11:14 ssuominen Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="A panel plugin that uses indicator-applet to show new messages"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-indicator-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/libindicator-12.10.1:3
+ >=x11-libs/gtk+-3.6:3
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.11
+ >=xfce-base/libxfce4util-4.11
+ >=xfce-base/xfce4-panel-4.11
+ >=xfce-base/xfconf-4.10"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ # TODO: libido3-13.10.0 needs ubuntu-private.h from Ubuntu's GTK+ 3.x
+ XFCONF=(
+ --disable-ido
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS )
+}