summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/icalendar/ChangeLog7
-rw-r--r--dev-python/icalendar/icalendar-3.5.ebuild5
-rw-r--r--dev-python/icalendar/icalendar-3.6.1.ebuild5
-rw-r--r--dev-python/icalendar/icalendar-3.6.2.ebuild5
-rw-r--r--dev-python/icalendar/icalendar-3.7.ebuild3
5 files changed, 13 insertions, 12 deletions
diff --git a/dev-python/icalendar/ChangeLog b/dev-python/icalendar/ChangeLog
index e6caa584c078..cc0309e17100 100644
--- a/dev-python/icalendar/ChangeLog
+++ b/dev-python/icalendar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/icalendar
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/icalendar/ChangeLog,v 1.38 2014/06/07 07:06:19 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/icalendar/ChangeLog,v 1.39 2014/07/06 12:42:36 mgorny Exp $
+
+ 06 Jul 2014; Michał Górny <mgorny@gentoo.org> icalendar-3.5.ebuild,
+ icalendar-3.6.1.ebuild, icalendar-3.6.2.ebuild, icalendar-3.7.ebuild:
+ Clean up obsolete dependencies on virtual/python-argparse and virtual/python-
+ unittest2 (those packages were only required for <=python-2.6).
*icalendar-3.7 (07 Jun 2014)
diff --git a/dev-python/icalendar/icalendar-3.5.ebuild b/dev-python/icalendar/icalendar-3.5.ebuild
index ece7d3ed80a4..1857fb2d8c73 100644
--- a/dev-python/icalendar/icalendar-3.5.ebuild
+++ b/dev-python/icalendar/icalendar-3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/icalendar/icalendar-3.5.ebuild,v 1.5 2014/03/31 21:14:15 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/icalendar/icalendar-3.5.ebuild,v 1.6 2014/07/06 12:42:36 mgorny Exp $
EAPI="5"
@@ -23,8 +23,7 @@ DOCS="README.rst"
RDEPEND=">=dev-python/python-dateutil-1.5[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( virtual/python-unittest2[${PYTHON_USEDEP}] )"
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
python_compile_all() {
if use doc; then
diff --git a/dev-python/icalendar/icalendar-3.6.1.ebuild b/dev-python/icalendar/icalendar-3.6.1.ebuild
index 4bf3e38d0125..5101e49c8f03 100644
--- a/dev-python/icalendar/icalendar-3.6.1.ebuild
+++ b/dev-python/icalendar/icalendar-3.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/icalendar/icalendar-3.6.1.ebuild,v 1.3 2014/04/16 04:48:02 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/icalendar/icalendar-3.6.1.ebuild,v 1.4 2014/07/06 12:42:36 mgorny Exp $
EAPI="5"
@@ -24,8 +24,7 @@ RDEPEND="dev-python/python-dateutil:0[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( virtual/python-unittest2[${PYTHON_USEDEP}]
- ${RDEPEND} )"
+ test? ( ${RDEPEND} )"
python_compile_all() {
if use doc; then
diff --git a/dev-python/icalendar/icalendar-3.6.2.ebuild b/dev-python/icalendar/icalendar-3.6.2.ebuild
index 9e72f9588f3f..f31bec44e989 100644
--- a/dev-python/icalendar/icalendar-3.6.2.ebuild
+++ b/dev-python/icalendar/icalendar-3.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/icalendar/icalendar-3.6.2.ebuild,v 1.1 2014/05/09 05:24:08 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/icalendar/icalendar-3.6.2.ebuild,v 1.2 2014/07/06 12:42:36 mgorny Exp $
EAPI="5"
@@ -24,8 +24,7 @@ RDEPEND="dev-python/python-dateutil:0[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( virtual/python-unittest2[${PYTHON_USEDEP}]
- ${RDEPEND} )"
+ test? ( ${RDEPEND} )"
python_compile_all() {
if use doc; then
diff --git a/dev-python/icalendar/icalendar-3.7.ebuild b/dev-python/icalendar/icalendar-3.7.ebuild
index 8fa60225842e..2bd4ae2fe40c 100644
--- a/dev-python/icalendar/icalendar-3.7.ebuild
+++ b/dev-python/icalendar/icalendar-3.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/icalendar/icalendar-3.7.ebuild,v 1.1 2014/06/07 07:04:24 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/icalendar/icalendar-3.7.ebuild,v 1.2 2014/07/06 12:42:36 mgorny Exp $
EAPI="5"
@@ -24,7 +24,6 @@ RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( ${RDEPEND}
- virtual/python-unittest2[${PYTHON_USEDEP}]
dev-python/python-dateutil:0[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}] )"