summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/maruku/ChangeLog6
-rw-r--r--dev-ruby/maruku/maruku-0.6.0-r2.ebuild12
2 files changed, 16 insertions, 2 deletions
diff --git a/dev-ruby/maruku/ChangeLog b/dev-ruby/maruku/ChangeLog
index be573dff31da..a0a596e7ec46 100644
--- a/dev-ruby/maruku/ChangeLog
+++ b/dev-ruby/maruku/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/maruku
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/maruku/ChangeLog,v 1.17 2012/07/25 06:11:32 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/maruku/ChangeLog,v 1.18 2012/07/25 06:25:49 graaff Exp $
+
+ 25 Jul 2012; Hans de Graaff <graaff@gentoo.org> maruku-0.6.0-r2.ebuild:
+ Fix USE=doc with ruby19 as main interpreter, bug 427856. Add tests but
+ restrict them due to failures for now.
25 Jul 2012; Hans de Graaff <graaff@gentoo.org> -maruku-0.6.0-r1.ebuild:
Cleanup.
diff --git a/dev-ruby/maruku/maruku-0.6.0-r2.ebuild b/dev-ruby/maruku/maruku-0.6.0-r2.ebuild
index 200adff613b0..691170389bb7 100644
--- a/dev-ruby/maruku/maruku-0.6.0-r2.ebuild
+++ b/dev-ruby/maruku/maruku-0.6.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/maruku/maruku-0.6.0-r2.ebuild,v 1.5 2012/05/01 18:24:09 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/maruku/maruku-0.6.0-r2.ebuild,v 1.6 2012/07/25 06:25:49 graaff Exp $
EAPI=2
@@ -8,6 +8,7 @@ USE_RUBY="ruby18 ruby19 ree18 jruby"
RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC="-I. rdoc"
RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="docs/changelog.md docs/div_syntax.md docs/entity_test.md
docs/markdown_syntax.md docs/maruku.md docs/math.md docs/other_stuff.md
@@ -23,6 +24,11 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE=""
+# Tests fail in various ways, possibly due to missing
+# dependencies. Since we shipped this without any tests for over a year
+# just restrict them for now and revisit for the next version.
+RESTRICT=test
+
ruby_add_rdepend dev-ruby/syntax
all_ruby_prepare() {
@@ -32,6 +38,10 @@ all_ruby_prepare() {
Rakefile
}
+each_ruby_test() {
+ ${RUBY} -Ilib bin/marutest $(find tests/unittest -name '*.md') || die
+}
+
pkg_postinst() {
elog
elog "You need to emerge app-text/texlive and dev-tex/latex-unicode if"