summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-puzzle/gemdropx/ChangeLog9
-rw-r--r--games-puzzle/gemdropx/gemdropx-0.9-r1.ebuild13
2 files changed, 14 insertions, 8 deletions
diff --git a/games-puzzle/gemdropx/ChangeLog b/games-puzzle/gemdropx/ChangeLog
index 4fffc20ec57e..c225825704a3 100644
--- a/games-puzzle/gemdropx/ChangeLog
+++ b/games-puzzle/gemdropx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-puzzle/gemdropx
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gemdropx/ChangeLog,v 1.7 2007/02/22 01:10:08 peper Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gemdropx/ChangeLog,v 1.8 2009/07/20 22:05:05 mr_bones_ Exp $
+
+ 20 Jul 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ gemdropx-0.9-r1.ebuild:
+ EAPI=2; add use-based deps (bug #278300)
+
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/games-puzzle/gemdropx/gemdropx-0.9-r1.ebuild b/games-puzzle/gemdropx/gemdropx-0.9-r1.ebuild
index 8177f23923df..95d1ccef0751 100644
--- a/games-puzzle/gemdropx/gemdropx-0.9-r1.ebuild
+++ b/games-puzzle/gemdropx/gemdropx-0.9-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gemdropx/gemdropx-0.9-r1.ebuild,v 1.6 2006/02/17 22:01:54 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/gemdropx/gemdropx-0.9-r1.ebuild,v 1.7 2009/07/20 22:05:05 mr_bones_ Exp $
+EAPI=2
inherit games
DESCRIPTION="A puzzle game where it's your job to clear the screen of gems"
@@ -10,11 +11,11 @@ SRC_URI="ftp://ftp.sonic.net/pub/users/nbs/unix/x/gemdropx/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc amd64"
+KEYWORDS="amd64 ppc x86"
IUSE=""
-DEPEND=">=media-libs/libsdl-1.2.3-r1
- >=media-libs/sdl-mixer-1.2.1"
+DEPEND=">=media-libs/libsdl-1.2.3-r1[joystick,video]
+ >=media-libs/sdl-mixer-1.2.1[mikmod]"
src_compile() {
emake \
@@ -26,7 +27,7 @@ src_compile() {
src_install() {
dogamesbin gemdropx || die "dogamesbin failed"
dodir "${GAMES_DATADIR}/${PN}"
- cp -r data/* "${D}/${GAMES_DATADIR}/${PN}/"
+ cp -r data/* "${D}/${GAMES_DATADIR}/${PN}/" || die "cp failed"
dodoc AUTHORS.txt CHANGES.txt ICON.txt README.txt TODO.txt
prepgamesdirs
}