summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-simulation/openttd/ChangeLog7
-rw-r--r--games-simulation/openttd/files/openttd-1.4.4-cflags.patch42
-rw-r--r--games-simulation/openttd/files/openttd-1.4.4-freetype.patch31
-rw-r--r--games-simulation/openttd/openttd-1.4.4.ebuild179
4 files changed, 6 insertions, 253 deletions
diff --git a/games-simulation/openttd/ChangeLog b/games-simulation/openttd/ChangeLog
index c7e2fd2bfe2b..9b002f1d014b 100644
--- a/games-simulation/openttd/ChangeLog
+++ b/games-simulation/openttd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-simulation/openttd
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.159 2015/05/13 09:29:20 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.160 2015/05/13 16:33:13 mr_bones_ Exp $
+
+ 13 May 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ -files/openttd-1.4.4-cflags.patch, -files/openttd-1.4.4-freetype.patch,
+ -openttd-1.4.4.ebuild:
+ old
13 May 2015; Agostino Sarubbo <ago@gentoo.org> openttd-1.5.0.ebuild:
Stable for x86, wrt bug #548882
diff --git a/games-simulation/openttd/files/openttd-1.4.4-cflags.patch b/games-simulation/openttd/files/openttd-1.4.4-cflags.patch
deleted file mode 100644
index bb7f768b3798..000000000000
--- a/games-simulation/openttd/files/openttd-1.4.4-cflags.patch
+++ /dev/null
@@ -1,42 +0,0 @@
---- openttd-1.4.4/config.lib
-+++ openttd-1.4.4/config.lib
-@@ -1450,12 +1450,6 @@
- CFLAGS="-I/gg/os-include -noixemul -fstrict-aliasing -fexpensive-optimizations -mcpu=604 -fno-inline -mstring -mmultiple $CFLAGS"
- LDFLAGS="$LDFLAGS -noixemul"
- fi
--
-- if [ "$enable_profiling" = "0" ]; then
-- # -fomit-frame-pointer and -pg do not go well together (gcc errors they are incompatible)
-- CFLAGS="-fomit-frame-pointer $CFLAGS"
-- fi
-- CFLAGS="-O2 $CFLAGS"
- else
- OBJS_SUBDIR="debug"
-
-@@ -1466,14 +1460,6 @@
- CFLAGS="$CFLAGS -G0"
- fi
- fi
-- if [ $enable_debug -ge 2 ]; then
-- CFLAGS="$CFLAGS -fno-inline"
-- fi
-- if [ $enable_debug -ge 3 ]; then
-- CFLAGS="$CFLAGS -O0"
-- else
-- CFLAGS="$CFLAGS -O2"
-- fi
- fi
-
- if [ $enable_debug -le 2 ]; then
-@@ -1498,11 +1484,6 @@
- CFLAGS="$CFLAGS -fno-expensive-optimizations"
- fi
-
-- if [ "$enable_profiling" != "0" ]; then
-- CFLAGS="$CFLAGS -pg"
-- LDFLAGS="$LDFLAGS -pg"
-- fi
--
- if [ "$with_threads" = "0" ]; then
- CFLAGS="$CFLAGS -DNO_THREADS"
- fi
diff --git a/games-simulation/openttd/files/openttd-1.4.4-freetype.patch b/games-simulation/openttd/files/openttd-1.4.4-freetype.patch
deleted file mode 100644
index 96f1f6205567..000000000000
--- a/games-simulation/openttd/files/openttd-1.4.4-freetype.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Index: trunk/src/fontcache.cpp
-===================================================================
---- trunk/src/fontcache.cpp (revision 27020)
-+++ trunk/src/fontcache.cpp (revision 27079)
-@@ -537,6 +537,6 @@
-
- /* Add 1 pixel for the shadow on the medium font. Our sprite must be at least 1x1 pixel */
-- int width = max(1, slot->bitmap.width + (this->fs == FS_NORMAL));
-- int height = max(1, slot->bitmap.rows + (this->fs == FS_NORMAL));
-+ unsigned int width = max(1U, (unsigned int)slot->bitmap.width + (this->fs == FS_NORMAL));
-+ unsigned int height = max(1U, (unsigned int)slot->bitmap.rows + (this->fs == FS_NORMAL));
-
- /* Limit glyph size to prevent overflows later on. */
-@@ -554,6 +554,6 @@
- /* Draw shadow for medium size */
- if (this->fs == FS_NORMAL && !aa) {
-- for (int y = 0; y < slot->bitmap.rows; y++) {
-- for (int x = 0; x < slot->bitmap.width; x++) {
-+ for (unsigned int y = 0; y < (unsigned int)slot->bitmap.rows; y++) {
-+ for (unsigned int x = 0; x < (unsigned int)slot->bitmap.width; x++) {
- if (aa ? (slot->bitmap.buffer[x + y * slot->bitmap.pitch] > 0) : HasBit(slot->bitmap.buffer[(x / 8) + y * slot->bitmap.pitch], 7 - (x % 8))) {
- sprite.data[1 + x + (1 + y) * sprite.width].m = SHADOW_COLOUR;
-@@ -564,6 +564,6 @@
- }
-
-- for (int y = 0; y < slot->bitmap.rows; y++) {
-- for (int x = 0; x < slot->bitmap.width; x++) {
-+ for (unsigned int y = 0; y < (unsigned int)slot->bitmap.rows; y++) {
-+ for (unsigned int x = 0; x < (unsigned int)slot->bitmap.width; x++) {
- if (aa ? (slot->bitmap.buffer[x + y * slot->bitmap.pitch] > 0) : HasBit(slot->bitmap.buffer[(x / 8) + y * slot->bitmap.pitch], 7 - (x % 8))) {
- sprite.data[x + y * sprite.width].m = FACE_COLOUR;
diff --git a/games-simulation/openttd/openttd-1.4.4.ebuild b/games-simulation/openttd/openttd-1.4.4.ebuild
deleted file mode 100644
index e6c25caa4581..000000000000
--- a/games-simulation/openttd/openttd-1.4.4.ebuild
+++ /dev/null
@@ -1,179 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-1.4.4.ebuild,v 1.6 2015/02/25 15:52:24 ago Exp $
-
-EAPI=5
-inherit eutils gnome2-utils games
-
-DESCRIPTION="OpenTTD is a clone of Transport Tycoon Deluxe"
-HOMEPAGE="http://www.openttd.org/"
-SRC_URI="http://binaries.openttd.org/releases/${PV}/${P}-source.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~ppc64 x86"
-IUSE="aplaymidi debug dedicated iconv icu lzo +openmedia +png cpu_flags_x86_sse +timidity +truetype zlib"
-RESTRICT="test" # needs a graphics set in order to test
-
-RDEPEND="!dedicated? (
- media-libs/libsdl[sound,X,video]
- icu? ( dev-libs/icu:= )
- truetype? (
- media-libs/fontconfig
- media-libs/freetype:2
- sys-libs/zlib
- )
- )
- lzo? ( dev-libs/lzo:2 )
- iconv? ( virtual/libiconv )
- png? ( media-libs/libpng:0 )
- zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-PDEPEND="
- !dedicated? (
- openmedia? (
- games-misc/openmsx
- games-misc/opensfx
- )
- aplaymidi? ( media-sound/alsa-utils )
- !aplaymidi? ( timidity? ( media-sound/timidity++ ) )
- )
- openmedia? ( >=games-misc/opengfx-0.4.7 )"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-cflags.patch \
- "${FILESDIR}"/${P}-freetype.patch
- sed -i \
- -e '/Keywords/s/$/;/' \
- media/openttd.desktop.in || die
-}
-
-src_configure() {
- # there is an allegro interface available as well as sdl, but
- # the configure for it looks broken so the sdl interface is
- # always built instead.
- local myopts=" --without-allegro"
-
- # libtimidity not needed except for some embedded platform
- # nevertheless, it will be automagically linked if it is
- # installed. Hence, we disable it.
- myopts+=" --without-libtimidity"
-
- use debug && myopts+=" --enable-debug=3"
-
- if use dedicated ; then
- myopts+=" --enable-dedicated"
- else
- use aplaymidi && myopts+=" --with-midi='/usr/bin/aplaymidi'"
- myopts+="
- $(use_with truetype freetype)
- $(use_with icu)
- --with-sdl"
- fi
- if use png || { use !dedicated && use truetype; } || use zlib ; then
- myopts+=" --with-zlib"
- else
- myopts+=" --without-zlib"
- fi
-
- # configure is a hand-written bash-script, so econf will not work.
- # It's all built as C++, upstream uses CFLAGS internally.
- CFLAGS="" ./configure \
- --disable-strip \
- --prefix-dir="${EPREFIX}" \
- --binary-dir="${GAMES_BINDIR}" \
- --data-dir="${GAMES_DATADIR}/${PN}" \
- --install-dir="${D}" \
- --icon-dir=/usr/share/pixmaps \
- --menu-dir=/usr/share/applications \
- --icon-theme-dir=/usr/share/icons/hicolor \
- --man-dir=/usr/share/man/man6 \
- --doc-dir=/usr/share/doc/${PF} \
- --menu-group="Game;Simulation;" \
- ${myopts} \
- $(use_with iconv) \
- $(use_with png) \
- $(use_with cpu_flags_x86_sse sse) \
- $(use_with lzo liblzo2) \
- || die
-}
-
-src_compile() {
- emake VERBOSE=1
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- if use dedicated ; then
- newinitd "${FILESDIR}"/${PN}.initd ${PN}
- rm -rf "${ED}"/usr/share/{applications,icons,pixmaps}
- fi
- rm -f "${ED}"/usr/share/doc/${PF}/COPYING
- prepgamesdirs
-}
-
-pkg_preinst() {
- games_pkg_preinst
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
- games_pkg_postinst
-
- if ! use lzo ; then
- elog "OpenTTD was built without 'lzo' in USE. While 'lzo' is not"
- elog "required, disabling it does mean that loading old savegames"
- elog "or scenarios from ancient versions (~0.2) will fail."
- elog
- fi
-
- if use dedicated ; then
- ewarn "Warning: The init script will kill all running openttd"
- ewarn "processes when triggered, including any running client sessions!"
- else
- if use aplaymidi ; then
- elog "You have emerged with 'aplaymidi' for playing MIDI."
- elog "This option is for those with a hardware midi device,"
- elog "or who have set up ALSA to handle midi ports."
- elog "You must set the environment variable ALSA_OUTPUT_PORTS."
- elog "Available ports can be listed by using 'aplaymidi -l'."
- else
- if ! use timidity ; then
- elog "OpenTTD was built with neither 'aplaymidi' nor 'timidity'"
- elog "in USE. Music may or may not work in-game. If you happen"
- elog "to have timidity++ installed, music will work so long"
- elog "as it remains installed, but OpenTTD will not depend on it."
- fi
- fi
- if ! use openmedia ; then
- elog
- elog "OpenTTD was compiled without the 'openmedia' USE flag."
- elog
- elog "In order to play, you must at least install:"
- elog "games-misc/opengfx, and games-misc/opensfx, or copy the "
- elog "following 6 files from a version of Transport Tycoon Deluxe"
- elog "(windows or DOS) to ~/.openttd/data/ or"
- elog "${GAMES_DATADIR}/${PN}/data/."
- elog
- elog "From the WINDOWS version you need: "
- elog "sample.cat trg1r.grf trgcr.grf trghr.grf trgir.grf trgtr.grf"
- elog "OR from the DOS version you need: "
- elog "SAMPLE.CAT TRG1.GRF TRGC.GRF TRGH.GRF TRGI.GRF TRGT.GRF"
- elog
- elog "File names are case sensitive, but should work either with"
- elog "all upper or all lower case names"
- elog
- elog "In addition, in-game music will be unavailable: for music,"
- elog "install games-misc/openmsx, or use the in-game download"
- elog "functionality to get a music set"
- elog
- fi
- fi
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}