summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/hddtemp/ChangeLog12
-rw-r--r--app-admin/hddtemp/files/hddtemp-init6
-rw-r--r--app-admin/hddtemp/hddtemp-0.3_beta15-r20.ebuild95
-rw-r--r--app-admin/hddtemp/hddtemp-0.3_beta15-r22.ebuild (renamed from app-admin/hddtemp/hddtemp-0.3_beta15-r21.ebuild)2
-rw-r--r--app-admin/hddtemp/hddtemp-0.3_beta15-r5.ebuild (renamed from app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild)2
5 files changed, 16 insertions, 101 deletions
diff --git a/app-admin/hddtemp/ChangeLog b/app-admin/hddtemp/ChangeLog
index d111f35aa745..48010786f277 100644
--- a/app-admin/hddtemp/ChangeLog
+++ b/app-admin/hddtemp/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for app-admin/hddtemp
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/ChangeLog,v 1.121 2012/08/26 11:56:31 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/ChangeLog,v 1.122 2012/10/24 18:45:04 aidecoe Exp $
+
+*hddtemp-0.3_beta15-r22 (24 Oct 2012)
+*hddtemp-0.3_beta15-r5 (24 Oct 2012)
+
+ 24 Oct 2012; Amadeusz Żołnowski <aidecoe@gentoo.org>
+ -hddtemp-0.3_beta15-r4.ebuild, +hddtemp-0.3_beta15-r5.ebuild,
+ -hddtemp-0.3_beta15-r20.ebuild, -hddtemp-0.3_beta15-r21.ebuild,
+ +hddtemp-0.3_beta15-r22.ebuild, files/hddtemp-init:
+ init script doesn't depend on net anymore. Old revisions has been removed.
+ All testing ebuilds has been revbumped to enforce update of the init script.
26 Aug 2012; Amadeusz Żołnowski <aidecoe@gentoo.org> files/hddgentoo.db:
TOSHIBA MK3252GSX and SAMSUNG HM160HC to hddgentoo.db. Fixes bug #429918.
diff --git a/app-admin/hddtemp/files/hddtemp-init b/app-admin/hddtemp/files/hddtemp-init
index 887f83de8bc0..414a6722e3ed 100644
--- a/app-admin/hddtemp/files/hddtemp-init
+++ b/app-admin/hddtemp/files/hddtemp-init
@@ -1,10 +1,10 @@
#!/sbin/runscript
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/files/hddtemp-init,v 1.6 2011/06/12 13:18:20 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/files/hddtemp-init,v 1.7 2012/10/24 18:45:04 aidecoe Exp $
depend() {
- need localmount net
+ need localmount
}
start() {
diff --git a/app-admin/hddtemp/hddtemp-0.3_beta15-r20.ebuild b/app-admin/hddtemp/hddtemp-0.3_beta15-r20.ebuild
deleted file mode 100644
index 40c88d37064d..000000000000
--- a/app-admin/hddtemp/hddtemp-0.3_beta15-r20.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.3_beta15-r20.ebuild,v 1.1 2012/07/31 10:40:08 aidecoe Exp $
-
-EAPI=4
-
-inherit eutils autotools
-
-MY_P=${P/_beta/-beta}
-DBV=20080531
-
-DESCRIPTION="A simple utility to read the temperature of SMART capable hard drives"
-HOMEPAGE="http://savannah.nongnu.org/projects/hddtemp/"
-SRC_URI="http://download.savannah.gnu.org/releases/hddtemp/${MY_P}.tar.bz2 mirror://gentoo/hddtemp-${DBV}.db.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~sparc ~x86"
-IUSE="network-cron nls"
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS=(README TODO ChangeLog)
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-satacmds.patch
- epatch "${FILESDIR}"/${P}-byteswap.patch
- epatch "${FILESDIR}"/${P}-execinfo.patch
- epatch "${FILESDIR}"/${P}-nls.patch
- epatch "${FILESDIR}"/${P}-iconv.patch
- AT_M4DIR="m4" eautoreconf
-}
-
-src_configure() {
- local myconf
-
- myconf="--with-db-path=/usr/share/hddtemp/hddtemp.db"
- # disabling nls breaks compiling
- use nls || myconf="--disable-nls ${myconf}"
- econf ${myconf}
-}
-
-src_install() {
- default
-
- insinto /usr/share/hddtemp
- newins "${WORKDIR}/hddtemp-${DBV}.db" hddtemp.db
- doins "${FILESDIR}"/hddgentoo.db
-
- update_db "${D}/usr/share/hddtemp/hddgentoo.db" "${D}/usr/share/hddtemp/hddtemp.db"
- newconfd "${FILESDIR}"/hddtemp-conf.d hddtemp
- newinitd "${FILESDIR}"/hddtemp-init hddtemp
-
- dosbin "${FILESDIR}"/update-hddtemp.db
-
- if use network-cron ; then
- exeinto /etc/cron.monthly
- echo -e "#!/bin/sh\n/usr/sbin/update-hddtemp.db" > "${T}"/hddtemp.cron
- newexe "${T}"/hddtemp.cron update-hddtemp.db
- fi
-}
-
-pkg_postinst() {
- elog "In order to update your hddtemp database, run:"
- elog " update-hddtemp.db"
- elog ""
- elog "If your hard drive is not recognized by hddtemp, please consider"
- elog "submitting your HDD info for inclusion into the Gentoo hddtemp"
- elog "database by filing a bug at https://bugs.gentoo.org/"
- elog ""
- elog "The hddtemp deamon requires a network interface to be up. If you"
- elog "don't have an Ethernet interface, make sure at least the loopback"
- elog "interface is up by setting 'rc_depend_strict=\"NO\"' in /etc/rc.conf."
- echo
- ewarn "If hddtemp complains but finds your HDD temperature sensor, use the"
- ewarn "--quiet option to suppress the warning."
-}
-
-update_db() {
- local src=$1
- local dst=$2
-
- while read line ; do
- if [[ -z $(echo "${line}" | sed -re 's/(^#.*|^\w*$)//') ]]; then
- echo "${line}" >> "${dst}"
- fi
-
- id=$(echo "${line}" | grep -o '"[^"]*"')
-
- grep "${id}" "${dst}" 2>&1 >/dev/null || echo "${line}" >> "${dst}"
- done < "${src}"
-}
diff --git a/app-admin/hddtemp/hddtemp-0.3_beta15-r21.ebuild b/app-admin/hddtemp/hddtemp-0.3_beta15-r22.ebuild
index 6a2a974fc6db..2c7b2131e570 100644
--- a/app-admin/hddtemp/hddtemp-0.3_beta15-r21.ebuild
+++ b/app-admin/hddtemp/hddtemp-0.3_beta15-r22.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.3_beta15-r21.ebuild,v 1.1 2012/07/31 10:40:08 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.3_beta15-r22.ebuild,v 1.1 2012/10/24 18:45:04 aidecoe Exp $
EAPI=4
diff --git a/app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild b/app-admin/hddtemp/hddtemp-0.3_beta15-r5.ebuild
index ebd964c6b280..05f53a35aa8f 100644
--- a/app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild
+++ b/app-admin/hddtemp/hddtemp-0.3_beta15-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.3_beta15-r4.ebuild,v 1.9 2012/07/31 10:49:36 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/hddtemp/hddtemp-0.3_beta15-r5.ebuild,v 1.1 2012/10/24 18:45:04 aidecoe Exp $
inherit eutils autotools