summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/async_extra/ChangeLog8
-rw-r--r--dev-ml/async_extra/async_extra-112.06.00.ebuild38
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-ml/async_extra/ChangeLog b/dev-ml/async_extra/ChangeLog
index c046ef184e65..cf51b4ecda26 100644
--- a/dev-ml/async_extra/ChangeLog
+++ b/dev-ml/async_extra/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/async_extra
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/async_extra/ChangeLog,v 1.14 2014/12/01 14:13:28 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/async_extra/ChangeLog,v 1.15 2014/12/22 10:11:04 aballier Exp $
+
+*async_extra-112.06.00 (22 Dec 2014)
+
+ 22 Dec 2014; Alexis Ballier <aballier@gentoo.org>
+ +async_extra-112.06.00.ebuild:
+ version bump
*async_extra-112.01.00 (01 Dec 2014)
diff --git a/dev-ml/async_extra/async_extra-112.06.00.ebuild b/dev-ml/async_extra/async_extra-112.06.00.ebuild
new file mode 100644
index 000000000000..bee8579d453c
--- /dev/null
+++ b/dev-ml/async_extra/async_extra-112.06.00.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/async_extra/async_extra-112.06.00.ebuild,v 1.1 2014/12/22 10:11:04 aballier Exp $
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Jane Street Capital's asynchronous execution library (extra)"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV}/individual/${MY_P}.tar.gz
+ http://dev.gentoo.org/~aballier/distfiles/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-4.00.0:=
+ >=dev-ml/sexplib-109.20.00:=
+ >=dev-ml/fieldslib-109.20.00:=
+ >=dev-ml/bin-prot-109.15.00:=
+ >=dev-ml/pa_ounit-109.18.00:=
+ >=dev-ml/pipebang-109.15.00:=
+ >=dev-ml/core-${PV}:=
+ >=dev-ml/async_kernel-${PV}:=
+ >=dev-ml/async_unix-${PV}:=
+ dev-ml/custom_printf:=
+ dev-ml/herelib:=
+ dev-ml/pa_test:=
+ dev-ml/camlp4:=
+ "
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"