summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/libguestfs/ChangeLog14
-rw-r--r--app-emulation/libguestfs/files/1.22/0001_add_gentoo_names_to_configure.patch15
-rw-r--r--app-emulation/libguestfs/files/1.22/0002_add_gentooway_to_remove_la_files.patch16
-rw-r--r--app-emulation/libguestfs/files/1.22/0003_add_doc_more_option.patch33
-rw-r--r--app-emulation/libguestfs/files/1.22/0004_add_icoutils_configure_drop_automagic.patch57
-rw-r--r--app-emulation/libguestfs/files/1.22/0005_enable_gtk_docs_in_broken_autotools-utils-eclass.patch21
-rw-r--r--app-emulation/libguestfs/files/1.22/0103_disable_php_bindings_makefile.patch13
-rw-r--r--app-emulation/libguestfs/libguestfs-1.22.6.ebuild162
8 files changed, 330 insertions, 1 deletions
diff --git a/app-emulation/libguestfs/ChangeLog b/app-emulation/libguestfs/ChangeLog
index 15dd83de2028..33fb6abaf4a3 100644
--- a/app-emulation/libguestfs/ChangeLog
+++ b/app-emulation/libguestfs/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for app-emulation/libguestfs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/libguestfs/ChangeLog,v 1.28 2013/04/24 18:03:00 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libguestfs/ChangeLog,v 1.29 2013/10/01 17:51:40 maksbotan Exp $
+
+*libguestfs-1.22.6 (01 Oct 2013)
+
+ 01 Oct 2013; Maxim Koltsov <maksbotan@gentoo.org>
+ +files/1.22/0001_add_gentoo_names_to_configure.patch,
+ +files/1.22/0002_add_gentooway_to_remove_la_files.patch,
+ +files/1.22/0003_add_doc_more_option.patch,
+ +files/1.22/0004_add_icoutils_configure_drop_automagic.patch,
+ +files/1.22/0005_enable_gtk_docs_in_broken_autotools-utils-eclass.patch,
+ +files/1.22/0103_disable_php_bindings_makefile.patch,
+ +libguestfs-1.22.6.ebuild:
+ Bump to 1.22.26, thanks to slepnoga
*libguestfs-1.20.6 (24 Apr 2013)
diff --git a/app-emulation/libguestfs/files/1.22/0001_add_gentoo_names_to_configure.patch b/app-emulation/libguestfs/files/1.22/0001_add_gentoo_names_to_configure.patch
new file mode 100644
index 000000000000..9d209ff53584
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.22/0001_add_gentoo_names_to_configure.patch
@@ -0,0 +1,15 @@
+diff --git a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -482,6 +482,11 @@
+ DISTRO=UBUNTU
+ fi
+ fi
++
++if test -f /etc/gentoo-release; then
++ DISTRO=GENTOO
++fi
++
+ if test -f /etc/arch-release; then
+ DISTRO=ARCHLINUX
+ fi
diff --git a/app-emulation/libguestfs/files/1.22/0002_add_gentooway_to_remove_la_files.patch b/app-emulation/libguestfs/files/1.22/0002_add_gentooway_to_remove_la_files.patch
new file mode 100644
index 000000000000..38a591b811ed
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.22/0002_add_gentooway_to_remove_la_files.patch
@@ -0,0 +1,16 @@
+diff --git a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -1487,8 +1487,10 @@
+
+ dnl Replace libtool with a wrapper that clobbers dependency_libs in *.la files
+ dnl http://lists.fedoraproject.org/pipermail/devel/2010-November/146343.html
+-LIBTOOL='bash $(top_srcdir)/libtool-kill-dependency_libs.sh $(top_builddir)/libtool'
+-AC_SUBST([LIBTOOL])
++dnl LIBTOOL='bash $(top_srcdir)/libtool-kill-dependency_libs.sh $(top_builddir)/libtool'
++dnl AC_SUBST([LIBTOOL])
++LT_INIT
++
+
+ dnl Produce output files.
+ AC_CONFIG_HEADERS([config.h])
diff --git a/app-emulation/libguestfs/files/1.22/0003_add_doc_more_option.patch b/app-emulation/libguestfs/files/1.22/0003_add_doc_more_option.patch
new file mode 100644
index 000000000000..a6a3a2eb8a90
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.22/0003_add_doc_more_option.patch
@@ -0,0 +1,33 @@
+diff --git a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -521,7 +521,7 @@
+ dnl Check for functions not available in earlier versions of Augeas.
+ AC_CHECK_FUNCS([aug_load aug_defvar aug_defnode])
+ LIBS="$old_LIBS"
+-],[AC_MSG_WARN([augeas not found, some core features will be disabled])])
++],[AC_MSG_ERROR([augeas not found, some core features will be disabled])])
+
+ dnl Check for libselinux (optional).
+ AC_CHECK_HEADERS([selinux/selinux.h])
+@@ -594,11 +594,19 @@
+
+ dnl Check for optional xmllint.
+ AC_CHECK_PROG([XMLLINT],[xmllint],[xmllint],[no])
++AS_IF([test "xXMLLINT" = "xno"], [AC_MSG_ERROR([xmllint not installed])],[])
++
+ AM_CONDITIONAL([HAVE_XMLLINT],[test "x$XMLLINT" != "xno"])
+
+ dnl po4a for translating man pages and POD files (optional).
+ AC_CHECK_PROG([PO4A],[po4a],[po4a],[no])
+-AM_CONDITIONAL([HAVE_PO4A], [test "x$PO4A" != "xno"])
++
++AC_ARG_ENABLE([doc],
++ AS_HELP_STRING([--enable-doc], [Enable generation translating man pages and doc]),
++ [enable_doc=no],
++ [enable_doc=yes])
++AS_IF([test "xPO4A" = "xno"], [AC_MSG_WARN([po4a not installed])],[])
++AM_CONDITIONAL([HAVE_PO4A],[test "x$PO4A" != "xno" && test "x$enable_doc" != "xno"])
+
+ dnl Check for db_dump, db_load (optional).
+ AC_CHECK_PROGS([DB_DUMP],
diff --git a/app-emulation/libguestfs/files/1.22/0004_add_icoutils_configure_drop_automagic.patch b/app-emulation/libguestfs/files/1.22/0004_add_icoutils_configure_drop_automagic.patch
new file mode 100644
index 000000000000..ecaaa97afc4e
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.22/0004_add_icoutils_configure_drop_automagic.patch
@@ -0,0 +1,57 @@
+diff --git a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -621,28 +621,36 @@
+ fi
+
+ dnl Check for netpbm programs (optional).
+-AC_CHECK_PROGS([PBMTEXT],[pbmtext],[no])
+-AC_CHECK_PROGS([PNMTOPNG],[pnmtopng],[no])
+-AC_CHECK_PROGS([BMPTOPNM],[bmptopnm],[no])
+-AC_CHECK_PROGS([PAMCUT],[pamcut],[no])
+-if test "x$PBMTEXT" != "xno"; then
+- AC_DEFINE_UNQUOTED([PBMTEXT],["$PBMTEXT"],[Name of pbmtext program.])
+-fi
+-if test "x$PNMTOPNG" != "xno"; then
+- AC_DEFINE_UNQUOTED([PNMTOPNG],["$PNMTOPNG"],[Name of pnmtopng program.])
+-fi
+-if test "x$BMPTOPNM" != "xno"; then
+- AC_DEFINE_UNQUOTED([BMPTOPNM],["$BMPTOPNM"],[Name of bmptopnm program.])
+-fi
+-if test "x$PAMCUT" != "xno"; then
+- AC_DEFINE_UNQUOTED([PAMCUT],["$PAMCUT"],[Name of pamcut program.])
+-fi
++AC_ARG_ENABLE([icoutils],
++ AS_HELP_STRING([with-icoutils], [ Enable ico and bmp icon file inspection]),
++ [enable_icoutils=no],
++ [enable_icoutils=yes])
++AS_IF([test "enable_icoutils" != "xno"],
++ [
++ AC_CHECK_PROGS([PBMTEXT],[pbmtext],[no])
++ AC_CHECK_PROGS([PNMTOPNG],[pnmtopng],[no])
++ AC_CHECK_PROGS([BMPTOPNM],[bmptopnm],[no])
++ AC_CHECK_PROGS([PAMCUT],[pamcut],[no])
++ if test "x$PBMTEXT" != "xno"; then
++ AC_DEFINE_UNQUOTED([PBMTEXT],["$PBMTEXT"],[Name of pbmtext program.])
++ fi
++ if test "x$PNMTOPNG" != "xno"; then
++ AC_DEFINE_UNQUOTED([PNMTOPNG],["$PNMTOPNG"],[Name of pnmtopng program.])
++ fi
++ if test "x$BMPTOPNM" != "xno"; then
++ AC_DEFINE_UNQUOTED([BMPTOPNM],["$BMPTOPNM"],[Name of bmptopnm program.])
++ fi
++ if test "x$PAMCUT" != "xno"; then
++ AC_DEFINE_UNQUOTED([PAMCUT],["$PAMCUT"],[Name of pamcut program.])
++ fi
+
+ dnl Check for icoutils (optional).
+ AC_CHECK_PROGS([WRESTOOL],[wrestool],[no])
+ if test "x$WRESTOOL" != "xno"; then
+- AC_DEFINE_UNQUOTED([WRESTOOL],["$WRESTOOL"],[Name of wrestool program.])
++ AC_DEFINE_UNQUOTED([WRESTOOL],["$WRESTOOL"],[Name of wrestool program.])
+ fi
++],
++[])
+
+ dnl Check for QEMU for running binaries on this $host_cpu, fall
+ dnl back to basic 'qemu'. Allow the user to override it.
diff --git a/app-emulation/libguestfs/files/1.22/0005_enable_gtk_docs_in_broken_autotools-utils-eclass.patch b/app-emulation/libguestfs/files/1.22/0005_enable_gtk_docs_in_broken_autotools-utils-eclass.patch
new file mode 100644
index 000000000000..69b3ae6d0d2d
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.22/0005_enable_gtk_docs_in_broken_autotools-utils-eclass.patch
@@ -0,0 +1,21 @@
+diff --git a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -1491,11 +1491,12 @@
+ ])
+
+ # check for gtk-doc
+-m4_ifdef([GTK_DOC_CHECK], [
+- GTK_DOC_CHECK([1.14],[--flavour no-tmpl])
+-],[
+- AM_CONDITIONAL([ENABLE_GTK_DOC], false)
+-])
++#m4_ifdef([GTK_DOC_CHECK], [
++# GTK_DOC_CHECK([1.14],[--flavour no-tmpl])
++#],[
++# AM_CONDITIONAL([ENABLE_GTK_DOC], false)
++#])
++GTK_DOC_CHECK([1.14],[--flavour no-tmpl])
+
+ dnl Library versioning.
+ MAX_PROC_NR=`cat $srcdir/src/MAX_PROC_NR`
diff --git a/app-emulation/libguestfs/files/1.22/0103_disable_php_bindings_makefile.patch b/app-emulation/libguestfs/files/1.22/0103_disable_php_bindings_makefile.patch
new file mode 100644
index 000000000000..34ab42d27903
--- /dev/null
+++ b/app-emulation/libguestfs/files/1.22/0103_disable_php_bindings_makefile.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.am b/Makefile.am
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -88,9 +88,6 @@
+ if HAVE_HASKELL
+ SUBDIRS += haskell
+ endif
+-if HAVE_PHP
+-SUBDIRS += php
+-endif
+ if HAVE_ERLANG
+ SUBDIRS += erlang erlang/examples
+ endif
diff --git a/app-emulation/libguestfs/libguestfs-1.22.6.ebuild b/app-emulation/libguestfs/libguestfs-1.22.6.ebuild
new file mode 100644
index 000000000000..47653d656107
--- /dev/null
+++ b/app-emulation/libguestfs/libguestfs-1.22.6.ebuild
@@ -0,0 +1,162 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libguestfs/libguestfs-1.22.6.ebuild,v 1.1 2013/10/01 17:51:40 maksbotan Exp $
+
+EAPI="5"
+
+WANT_LIBTOOL=latest
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit autotools-utils autotools versionator eutils \
+multilib linux-info perl-module base
+
+MY_PV_1="$(get_version_component_range 1-2)"
+MY_PV_2="$(get_version_component_range 2)"
+
+[[ $(( $(get_version_component_range 2) % 2 )) -eq 0 ]] && SD="stable" || SD="development"
+
+DESCRIPTION="Tools for accessing, inspect and modifying virtual machine (VM) disk images"
+HOMEPAGE="http://libguestfs.org/"
+SRC_URI="http://libguestfs.org/download/${MY_PV_1}-${SD}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0/${MY_PV_1}"
+
+KEYWORDS="~amd64"
+IUSE="erlang +fuse debug ocaml doc +perl ruby static-libs
+selinux systemtap introspection inspect-icons test lua"
+
+# Failires - doc
+# Failures - bash-completion, see GBZ #486306
+
+COMMON_DEPEND="
+ sys-libs/ncurses
+ sys-devel/gettext
+ >=app-misc/hivex-1.3.1
+ dev-libs/libpcre
+ app-arch/cpio
+ dev-lang/perl
+ app-cdr/cdrkit
+ >=app-emulation/qemu-1.2.2[qemu_user_targets_x86_64,qemu_softmmu_targets_x86_64,tci,systemtap?,selinux?,filecaps]
+ sys-apps/fakeroot
+ sys-apps/file
+ app-emulation/libvirt
+ dev-libs/libxml2:2
+ >=sys-apps/fakechroot-2.8
+ >=app-admin/augeas-0.7.1
+ sys-fs/squashfs-tools
+ dev-libs/libconfig
+ dev-libs/libpcre
+ sys-libs/readline
+ >=sys-libs/db-4.6
+ perl? ( virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/Sys-Virt-0.2.4
+ virtual/perl-Getopt-Long
+ virtual/perl-Data-Dumper
+ dev-perl/libintl-perl
+ >=app-misc/hivex-1.3.1[perl?]
+ dev-perl/String-ShellQuote
+ )
+ fuse? ( sys-fs/fuse )
+ introspection? (
+ >=dev-libs/gobject-introspection-1.30.0
+ dev-libs/gjs
+ )
+ selinux? ( sys-libs/libselinux sys-libs/libsemanage )
+ systemtap? ( dev-util/systemtap )
+ ocaml? ( dev-lang/ocaml[ocamlopt]
+ dev-ml/findlib[ocamlopt]
+ dev-ml/ocaml-gettext
+ )
+ erlang? ( dev-lang/erlang )
+ inspect-icons? ( media-libs/netpbm
+ media-gfx/icoutils
+ )
+ virtual/acl
+ sys-libs/libcap
+ lua? ( dev-lang/lua )
+ "
+
+DEPEND="${COMMON_DEPEND}
+ dev-util/gperf
+ doc? ( app-text/po4a )
+ ruby? ( dev-lang/ruby virtual/rubygems dev-ruby/rake )
+ "
+RDEPEND="${COMMON_DEPEND}
+ app-emulation/libguestfs-appliance
+ "
+
+PATCHES=("${FILESDIR}"/1.22/0*.patch )
+
+DOCS=(AUTHORS BUGS ChangeLog HACKING README ROADMAP TODO)
+
+pkg_setup () {
+ CONFIG_CHECK="~KVM ~VIRTIO"
+ [ -n "${CONFIG_CHECK}" ] && check_extra_config;
+}
+
+src_prepare() {
+ base_src_prepare
+ eaclocal
+ eautomake
+ eautoconf
+}
+
+src_configure() {
+
+ # Disable feature test for kvm for more reason
+ # i.e: not loaded module in __build__ time,
+ # build server not supported kvm, etc. ...
+ #
+ # In fact, this feature is virtio support and requires
+ # configured kernel.
+ export vmchannel_test=no
+
+ local myeconfargs=(
+ $(use_enable test gcc-warnings)
+ --disable-appliance
+ --disable-daemon
+ --with-extra="-gentoo"
+ --with-readline
+ --disable-php
+ --disable-python
+ --without-java
+ $(use_enable perl)
+ $(use_enable fuse)
+ $(use_enable ocaml)
+ $(use_enable ruby)
+ --disable-haskell
+ $(use_enable doc)
+ $(use_enable introspection gobject)
+ $(use_enable erlang)
+ $(use_enable systemtap probes)
+ $(use_enable lua)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+}
+
+src_test() {
+ autotools-utils_src_test
+}
+
+src_install() {
+ strip-linguas -i po
+ autotools-utils_src_install "LINGUAS=""${LINGUAS}"""
+
+ use perl && fixlocalpod
+}
+
+pkg_postinst() {
+
+ if !use perl ; then
+ einfo "Perl based tools NOT build"
+ fi
+ if !use ocaml ; then
+ einfo "Ocaml based tools ( sysprep , ... ) NOT installed"
+ fi
+}