summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/goaccess/ChangeLog9
-rw-r--r--net-analyzer/goaccess/goaccess-0.9.ebuild53
-rw-r--r--net-analyzer/goaccess/metadata.xml6
3 files changed, 65 insertions, 3 deletions
diff --git a/net-analyzer/goaccess/ChangeLog b/net-analyzer/goaccess/ChangeLog
index 5a03226750ed..7ac4eaefc0aa 100644
--- a/net-analyzer/goaccess/ChangeLog
+++ b/net-analyzer/goaccess/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/goaccess
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/goaccess/ChangeLog,v 1.8 2015/04/07 06:47:44 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/goaccess/ChangeLog,v 1.9 2015/04/29 22:47:56 idella4 Exp $
+
+*goaccess-0.9 (29 Apr 2015)
+
+ 29 Apr 2015; Ian Delaney <idella4@gentoo.org> +goaccess-0.9.ebuild,
+ metadata.xml:
+ bump; adjust metadata.xml to accommodate changed flag, ebuild supplied by
+ proxy maintainer in bug #530112
*goaccess-0.8.5 (07 Apr 2015)
diff --git a/net-analyzer/goaccess/goaccess-0.9.ebuild b/net-analyzer/goaccess/goaccess-0.9.ebuild
new file mode 100644
index 000000000000..47e54ae9130e
--- /dev/null
+++ b/net-analyzer/goaccess/goaccess-0.9.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/goaccess/goaccess-0.9.ebuild,v 1.1 2015/04/29 22:47:56 idella4 Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="A real-time web log analyzer and interactive viewer that runs in a terminal"
+HOMEPAGE="http://goaccess.io"
+SRC_URI="http://tar.goaccess.io/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+
+IUSE="btree debug geoip tokyocabinet unicode"
+
+REQUIRED_USE="btree? ( tokyocabinet )"
+
+RDEPEND="
+ sys-libs/ncurses[unicode?]
+ geoip? ( dev-libs/geoip )
+ !tokyocabinet? ( dev-libs/glib:2 )
+ tokyocabinet? (
+ dev-db/tokyocabinet
+ btree? (
+ app-arch/bzip2
+ sys-libs/zlib
+ )
+ )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch_user
+
+ # Fix path to GeoIP bases in config
+ sed -e s':/usr/local:/usr:' -i config/goaccess.conf || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable geoip) \
+ $(use_enable unicode utf8) \
+ $(use_enable tokyocabinet tcb) \
+ $(use_enable btree bzip) \
+ $(use_enable btree zlib) \
+ $(usex tokyocabinet "--enable-tcb=$(usex btree btree memhash)" '')
+}
diff --git a/net-analyzer/goaccess/metadata.xml b/net-analyzer/goaccess/metadata.xml
index 296ae1f94a4e..4f26acaf061a 100644
--- a/net-analyzer/goaccess/metadata.xml
+++ b/net-analyzer/goaccess/metadata.xml
@@ -5,7 +5,7 @@
<maintainer>
<email>spiderx@spiderx.dp.ua</email>
<name>Vladimir Pavljuchenkov</name>
- <description>Proxy maintainer</description>
+ <description>Proxy maintainer</description>
</maintainer>
<longdescription>GoAccess is an open source real-time web log analyzer and
interactive viewer that runs in a terminal in *nix systems. It provides fast and valuable
@@ -13,7 +13,9 @@ HTTP statistics for system administrators that require a visual server report on
</longdescription>
<use>
<flag name="btree">Enable Tokyo Cabinet's on-disk B+ Tree database backend</flag>
- <flag name="memhash">Enable Tokyo Cabinet's on-memory hash database backend</flag></use>
+ <flag name="memhash">Enable Tokyo Cabinet's on-memory hash database backend</flag>
+ <flag name="tokyocabinet">Enable Tokyo Cabinet's on-memory hash database backend</flag>
+ </use>
<upstream>
<changelog>https://github.com/allinurl/goaccess/blob/master/ChangeLog</changelog>
<doc>http://goaccess.io/faq</doc>