summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/2mandvd/2mandvd-1.3.5.ebuild77
-rw-r--r--media-video/2mandvd/ChangeLog11
-rw-r--r--media-video/2mandvd/files/2mandvd-fix-const-char-concatenation.patch15
3 files changed, 102 insertions, 1 deletions
diff --git a/media-video/2mandvd/2mandvd-1.3.5.ebuild b/media-video/2mandvd/2mandvd-1.3.5.ebuild
new file mode 100644
index 000000000000..885e04a300ed
--- /dev/null
+++ b/media-video/2mandvd/2mandvd-1.3.5.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/2mandvd/2mandvd-1.3.5.ebuild,v 1.1 2010/06/14 00:02:28 hwoarang Exp $
+
+EAPI="2"
+LANGS="de en he it pl pt ru"
+
+inherit qt4-r2
+
+MY_PN="2ManDVD"
+
+DESCRIPTION="The successor of ManDVD"
+HOMEPAGE="http://kde-apps.org/content/show.php?content=99450"
+SRC_URI="http://download.tuxfamily.org/${PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="dev-lang/perl
+ media-video/dvdauthor
+ media-video/ffmpegthumbnailer
+ media-fonts/dejavu
+ media-sound/sox
+ media-video/mplayer
+ media-libs/netpbm
+ media-video/mjpegtools
+ || ( app-cdr/cdrkit app-cdr/cdrtools )
+ media-libs/xine-lib
+ x11-libs/qt-gui:4
+ x11-libs/qt-webkit:4"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-fix-const-char-concatenation.patch"
+)
+
+S="${WORKDIR}/${MY_PN}"
+
+src_prepare() {
+ # fix installation path
+ for file in mainfrm.cpp media_browser.cpp rendering.cpp; do
+ sed -i "s:qApp->applicationDirPath().\?+.\?\":\"/usr/share/${PN}/:" \
+ ${file} || die "sed failed"
+ done
+
+ sed -i "s:qApp->applicationDirPath():\"/usr/share/${PN}/\":" \
+ mainfrm.cpp || die "sed failed"
+
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ eqmake4 ${MY_PN}.pro
+}
+
+src_install() {
+ newbin 2ManDVD ${PN} || die "newbin failed"
+ dodoc README.txt || die "dodoc failed"
+ insinto /usr/share/${PN}/
+ doins -r Bibliotheque || die "failed to install Bibliotheque"
+ doins -r Interface || die "failed to install Interface"
+ #bug 305625
+ doins fake.pl || "failed to install fake.pl"
+ doicon Interface/mandvdico.png || die "doicon failed"
+ # Desktop icon
+ make_desktop_entry ${PN} 2ManDVD mandvdico "Qt;AudioVideo;Video" \
+ || die "make_desktop_entry failed"
+ insinto /usr/share/${PN}
+ for lang in ${LINGUAS}; do
+ for x in ${LANGS}; do
+ [[ ${lang} == ${x} ]] && doins ${PN}_${x}.qm
+ done
+ done
+ [[ -z ${LINGUAS} ]] && doins ${PN}_en.qm
+}
diff --git a/media-video/2mandvd/ChangeLog b/media-video/2mandvd/ChangeLog
index 8bc1212cc478..ed1c5301f184 100644
--- a/media-video/2mandvd/ChangeLog
+++ b/media-video/2mandvd/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for media-video/2mandvd
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/2mandvd/ChangeLog,v 1.8 2010/04/29 08:00:45 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/2mandvd/ChangeLog,v 1.9 2010/06/14 00:02:28 hwoarang Exp $
+
+ 14 Jun 2010; Markos Chandras <hwoarang@gentoo.org>
+ +files/2mandvd-fix-const-char-concatenation.patch, +2mandvd-1.3.5.ebuild:
+ Version bump
+
+*2mandvd-1.3.5 (13 Jun 2010)
+
+ 13 Jun 2010; Markos Chandras <hwoarang@gentoo.org> +2mandvd-1.3.5.ebuild:
+ Version bump
29 Apr 2010; Markos Chandras <hwoarang@gentoo.org> 2mandvd-1.1.1.ebuild,
2mandvd-1.2-r1.ebuild:
diff --git a/media-video/2mandvd/files/2mandvd-fix-const-char-concatenation.patch b/media-video/2mandvd/files/2mandvd-fix-const-char-concatenation.patch
new file mode 100644
index 000000000000..b8d01e50a280
--- /dev/null
+++ b/media-video/2mandvd/files/2mandvd-fix-const-char-concatenation.patch
@@ -0,0 +1,15 @@
+Index: 2ManDVD/mainfrm.cpp
+===================================================================
+--- 2ManDVD.orig/mainfrm.cpp
++++ 2ManDVD/mainfrm.cpp
+@@ -1045,8 +1045,8 @@ mainfrm::mainfrm(QWidget *parent) : QMai
+ outext << "growisofs" << endl;
+ outext << "mpeg2enc" << endl;
+ outext << "jpegtopnm /dev/null" << endl;
+- outext << "cat " + "/usr/share/2mandvd//fake.pl" << endl;
+- outext << "rm -f " + homeDir.path() + "/.mdvdep.sh" << endl;
++ outext << "cat " << "/usr/share/2mandvd//fake.pl" << endl;
++ outext << "rm -f " << homeDir.path()<<"/.mdvdep.sh" << endl;
+ outext << "exit" << endl;
+ wmyficext.close();
+ QString programf = "bash";