summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/sdl-image/ChangeLog6
-rw-r--r--media-libs/sdl-image/sdl-image-1.2.3-r1.ebuild23
2 files changed, 16 insertions, 13 deletions
diff --git a/media-libs/sdl-image/ChangeLog b/media-libs/sdl-image/ChangeLog
index b8ed09c17a23..6a8d85e48426 100644
--- a/media-libs/sdl-image/ChangeLog
+++ b/media-libs/sdl-image/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/sdl-image
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-image/ChangeLog,v 1.15 2004/08/09 03:30:20 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-image/ChangeLog,v 1.16 2004/08/12 00:36:08 mr_bones_ Exp $
+
+ 11 Aug 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ sdl-image-1.2.3-r1.ebuild:
+ always gnuconfig_update; tidy
08 Aug 2004; Tom Gall <tgall@gentoo.org> sdl-image-1.2.3-r1.ebuild:
stable on ppc64, bug #57991
diff --git a/media-libs/sdl-image/sdl-image-1.2.3-r1.ebuild b/media-libs/sdl-image/sdl-image-1.2.3-r1.ebuild
index cf49df61e835..8b7447aa9003 100644
--- a/media-libs/sdl-image/sdl-image-1.2.3-r1.ebuild
+++ b/media-libs/sdl-image/sdl-image-1.2.3-r1.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-image/sdl-image-1.2.3-r1.ebuild,v 1.3 2004/08/09 03:30:20 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-image/sdl-image-1.2.3-r1.ebuild,v 1.4 2004/08/12 00:36:08 mr_bones_ Exp $
inherit gnuconfig
-IUSE="gif jpeg tiff png"
MY_P="${P/sdl-/SDL_}"
S=${WORKDIR}/${MY_P}
@@ -12,9 +11,10 @@ DESCRIPTION="image file loading library"
HOMEPAGE="http://www.libsdl.org/projects/SDL_image/index.html"
SRC_URI="http://www.libsdl.org/projects/SDL_image/release/${MY_P}.tar.gz"
-SLOT="0"
LICENSE="LGPL-2"
+SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~amd64 ppc64"
+IUSE="gif jpeg tiff png"
DEPEND="sys-libs/zlib
>=media-libs/libsdl-1.2.4
@@ -25,16 +25,17 @@ DEPEND="sys-libs/zlib
src_unpack() {
unpack ${A}
- use ppc64 && gnuconfig_update
+ cd ${S}
+ gnuconfig_update
}
src_compile() {
econf \
- `use_enable gif` \
- `use_enable jpeg jpg` \
- `use_enable tiff tif` \
- `use_enable png` \
- `use_enable png pnm` \
+ $(use_enable gif) \
+ $(use_enable jpeg jpg) \
+ $(use_enable tiff tif) \
+ $(use_enable png) \
+ $(use_enable png pnm) \
--enable-bmp \
--enable-lbm \
--enable-pcx \
@@ -42,13 +43,11 @@ src_compile() {
--enable-xcf \
--enable-xpm \
|| die
-
emake || die
}
src_install() {
- make DESTDIR=${D} install || die "make install failed"
-
+ make DESTDIR="${D}" install || die "make install failed"
into /usr
dobin .libs/showimage
dodoc CHANGES README