summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pygobject/ChangeLog10
-rw-r--r--dev-python/pygobject/files/pygobject-2.21.4-make_check.patch55
-rw-r--r--dev-python/pygobject/metadata.xml2
-rw-r--r--dev-python/pygobject/pygobject-2.21.5.ebuild127
4 files changed, 193 insertions, 1 deletions
diff --git a/dev-python/pygobject/ChangeLog b/dev-python/pygobject/ChangeLog
index 10622aad88d5..e65c11e1d5d0 100644
--- a/dev-python/pygobject/ChangeLog
+++ b/dev-python/pygobject/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/pygobject
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.101 2010/10/02 18:10:15 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/ChangeLog,v 1.102 2010/11/05 22:06:04 eva Exp $
+
+*pygobject-2.21.5 (05 Nov 2010)
+
+ 05 Nov 2010; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/pygobject-2.21.4-make_check.patch, +pygobject-2.21.5.ebuild,
+ metadata.xml:
+ Version bump. Enable introspection support but disable related tests, they
+ seem broken.
02 Oct 2010; Fabian Groffen <grobian@gentoo.org>
pygobject-2.20.0-r1.ebuild:
diff --git a/dev-python/pygobject/files/pygobject-2.21.4-make_check.patch b/dev-python/pygobject/files/pygobject-2.21.4-make_check.patch
new file mode 100644
index 000000000000..0d8e93c84677
--- /dev/null
+++ b/dev-python/pygobject/files/pygobject-2.21.4-make_check.patch
@@ -0,0 +1,55 @@
+--- a/tests/Makefile.am
++++ b/tests/Makefile.am
+@@ -12,7 +12,7 @@ EXTRA_DIST = \
+ test-thread.h \
+ test-unknown.h
+
+-noinst_LTLIBRARIES = testhelper.la
++check_LTLIBRARIES = testhelper.la
+ linked_LIBS = testhelper.la
+
+ testhelper_la_LDFLAGS = -module -avoid-version
+@@ -46,13 +46,11 @@ endif
+ testhelper.la: $(testhelper_la_OBJECTS) $(testhelper_la_DEPENDENCIES)
+ $(LINK) -rpath $(pkgpyexecdir) $(testhelper_la_LDFLAGS) $(testhelper_la_OBJECTS) $(testhelper_la_LIBADD) $(LIBS)
+
+-check-local: $(LTLIBRARIES:.la=.so)
++check-local: $(check_LTLIBRARIES:.la=.so)
+ $(EXEC_NAME) $(PYTHON) $(srcdir)/runtests.py $(top_builddir) $(tests)
+
+-all: $(LTLIBRARIES:.la=.so)
+-
+ clean-local:
+- rm -f $(LTLIBRARIES:.la=.so)
++ rm -f $(check_LTLIBRARIES:.la=.so)
+
+ .la.so:
+ $(LN_S) .libs/$@ $@ || true
+--- a/tests/runtests.py
++++ b/tests/runtests.py
+@@ -6,6 +6,9 @@ import unittest
+
+ import common
+
++# Some tests fail with translated messages.
++os.environ["LC_ALL"] = "C"
++
+ program = None
+ if len(sys.argv) < 2:
+ raise ValueError('Need at least 2 parameters: runtests.py <build-dir> '
+--- a/tests/test_gio.py
++++ b/tests/test_gio.py
+@@ -410,9 +410,10 @@ class TestFile(unittest.TestCase):
+
+ def testQueryWritableNamespaces(self):
+ infolist = self.file.query_writable_namespaces()
+- for info in infolist:
+- if info.name == "xattr":
+- self.assertEqual(info.type, gio.FILE_ATTRIBUTE_TYPE_STRING)
++ if infolist:
++ for info in infolist:
++ if info.name == "xattr":
++ self.assertEqual(info.type, gio.FILE_ATTRIBUTE_TYPE_STRING)
+
+ def testSetAttribute(self):
+ self._f.write("testing attributes")
diff --git a/dev-python/pygobject/metadata.xml b/dev-python/pygobject/metadata.xml
index c693e1cc2fb8..a6226e03834b 100644
--- a/dev-python/pygobject/metadata.xml
+++ b/dev-python/pygobject/metadata.xml
@@ -4,6 +4,8 @@
<herd>gnome</herd>
<herd>python</herd>
<use>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg> for
+ introspection</flag>
<flag name='libffi'>Enable support to connect to signals on python objects from C.</flag>
</use>
</pkgmetadata>
diff --git a/dev-python/pygobject/pygobject-2.21.5.ebuild b/dev-python/pygobject/pygobject-2.21.5.ebuild
new file mode 100644
index 000000000000..022d1035954a
--- /dev/null
+++ b/dev-python/pygobject/pygobject-2.21.5.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygobject/pygobject-2.21.5.ebuild,v 1.1 2010/11/05 22:06:04 eva Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEPEND="2:2.5"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+inherit alternatives autotools gnome2 python virtualx
+
+DESCRIPTION="GLib's GObject library bindings for Python"
+HOMEPAGE="http://www.pygtk.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples +introspection libffi test"
+
+RDEPEND=">=dev-libs/glib-2.22.4:2
+ !<dev-python/pygtk-2.13
+ introspection? (
+ >=dev-libs/gobject-introspection-0.9.1
+ >=dev-python/pycairo-1.0.2 )
+ libffi? ( virtual/libffi )"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-libs/libxslt
+ >=app-text/docbook-xsl-stylesheets-1.70.1 )
+ test? (
+ media-fonts/font-cursor-misc
+ media-fonts/font-misc-misc )
+ >=dev-util/pkgconfig-0.12"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog* NEWS README"
+ G2CONF="${G2CONF}
+ --disable-dependency-tracking
+ $(use_enable doc docs)
+ $(use_enable introspection)
+ $(use_with libffi ffi)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix FHS compliance, see upstream bug #535524
+ epatch "${FILESDIR}/${PN}-2.15.4-fix-codegen-location.patch"
+
+ # Do not build tests if unneeded, bug #226345
+ epatch "${FILESDIR}/${PN}-2.21.4-make_check.patch"
+
+ # Support installation for multiple Python versions
+ epatch "${FILESDIR}/${PN}-2.18.0-support_multiple_python_versions.patch"
+
+ # introspection related tests seem broken
+ sed -e '/if ENABLE_INTROSPECTION/,/endif/ d' \
+ -i tests/Makefile.am || die "sed failed"
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+
+ eautoreconf
+
+ python_copy_sources
+}
+
+src_configure() {
+ python_execute_function -s gnome2_src_configure
+}
+
+src_compile() {
+ python_execute_function -d -s
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+
+ testing() {
+ if has ${PYTHON_ABI} 2.4 2.5; then
+ einfo "Skipping tests with Python ${PYTHON_ABI}. dev-python/pycairo supports only Python >=2.6."
+ return 0
+ fi
+
+ Xemake check PYTHON=$(PYTHON -a)
+ }
+ python_execute_function -s testing
+}
+
+src_install() {
+ [[ -z ${ED} ]] && local ED="${D}"
+ installation() {
+ gnome2_src_install
+ mv "${ED}$(python_get_sitedir)/pygtk.py" "${ED}$(python_get_sitedir)/pygtk.py-2.0"
+ mv "${ED}$(python_get_sitedir)/pygtk.pth" "${ED}$(python_get_sitedir)/pygtk.pth-2.0"
+ }
+ python_execute_function -s installation
+
+ python_clean_installation_image
+
+ if use examples; then
+ insinto /usr/share/doc/${P}
+ doins -r examples || die "doins failed"
+ fi
+}
+
+pkg_postinst() {
+ create_symlinks() {
+ alternatives_auto_makesym $(python_get_sitedir)/pygtk.py pygtk.py-[0-9].[0-9]
+ alternatives_auto_makesym $(python_get_sitedir)/pygtk.pth pygtk.pth-[0-9].[0-9]
+ }
+ python_execute_function create_symlinks
+
+ python_mod_optimize gtk-2.0 pygtk.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup gtk-2.0 pygtk.py
+
+ create_symlinks() {
+ alternatives_auto_makesym $(python_get_sitedir)/pygtk.py pygtk.py-[0-9].[0-9]
+ alternatives_auto_makesym $(python_get_sitedir)/pygtk.pth pygtk.pth-[0-9].[0-9]
+ }
+ python_execute_function create_symlinks
+}