summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-haskell/uniplate/ChangeLog10
-rw-r--r--dev-haskell/uniplate/metadata.xml38
-rw-r--r--dev-haskell/uniplate/uniplate-1.6.12.ebuild35
3 files changed, 83 insertions, 0 deletions
diff --git a/dev-haskell/uniplate/ChangeLog b/dev-haskell/uniplate/ChangeLog
new file mode 100644
index 000000000000..83d4b32e5f64
--- /dev/null
+++ b/dev-haskell/uniplate/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-haskell/uniplate
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/uniplate/ChangeLog,v 1.1 2014/01/29 21:50:07 slyfox Exp $
+
+*uniplate-1.6.12 (29 Jan 2014)
+
+ 29 Jan 2014; Sergei Trofimovich <slyfox@gentoo.org> +metadata.xml,
+ +uniplate-1.6.12.ebuild:
+ Initial import. Help writing simple, concise and fast generic operations in
+ haskell. A dev-haskell/hlint depend.
diff --git a/dev-haskell/uniplate/metadata.xml b/dev-haskell/uniplate/metadata.xml
new file mode 100644
index 000000000000..6d98a7411d9d
--- /dev/null
+++ b/dev-haskell/uniplate/metadata.xml
@@ -0,0 +1,38 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Uniplate is library for writing simple and concise generic operations.
+ Uniplate has similar goals to the original Scrap Your Boilerplate work,
+ but is substantially simpler and faster. The Uniplate manual is available at
+ &lt;http://community.haskell.org/~ndm/darcs/uniplate/uniplate.htm&gt;.
+
+ To get started with Uniplate you should import one of the three following
+ modules:
+
+ * &quot;Data.Generics.Uniplate.Data&quot; - to quickly start writing generic functions.
+ Most users should start by importing this module.
+
+ * &quot;Data.Generics.Uniplate.Direct&quot; - a replacement for &quot;Data.Generics.Uniplate.Data&quot;
+ with substantially higher performance (around 5 times), but requires writing
+ instance declarations.
+
+ * &quot;Data.Generics.Uniplate.Operations&quot; - definitions of all the operations defined
+ by Uniplate. Both the above two modules re-export this module.
+
+ In addition, some users may want to make use of the following modules:
+
+ * &quot;Data.Generics.Uniplate.Zipper&quot; - a zipper built on top of Uniplate instances.
+
+ * &quot;Data.Generics.SYB&quot; - users transitioning from the Scrap Your Boilerplate library.
+
+ * &quot;Data.Generics.Compos&quot; - users transitioning from the Compos library.
+
+ * &quot;Data.Generics.Uniplate.DataOnly&quot; - users making use of both @Data@ and @Direct@
+ to avoid getting instance conflicts.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/uniplate/uniplate-1.6.12.ebuild b/dev-haskell/uniplate/uniplate-1.6.12.ebuild
new file mode 100644
index 000000000000..753090d539c5
--- /dev/null
+++ b/dev-haskell/uniplate/uniplate-1.6.12.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/uniplate/uniplate-1.6.12.ebuild,v 1.1 2014/01/29 21:50:07 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+#hackport: flags: +separate_syb,+typeable_fingerprint
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Help writing simple, concise and fast generic operations."
+HOMEPAGE="http://community.haskell.org/~ndm/uniplate/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/hashable-1.1.2.3:=[profile?] <dev-haskell/hashable-1.3:=[profile?]
+ dev-haskell/syb:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.1:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=separate_syb \
+ --flag=typeable_fingerprint
+}