summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/a2ps/a2ps-4.13b-r3.ebuild29
-rw-r--r--app-text/acroread/acroread-4.05-r4.ebuild10
2 files changed, 16 insertions, 23 deletions
diff --git a/app-text/a2ps/a2ps-4.13b-r3.ebuild b/app-text/a2ps/a2ps-4.13b-r3.ebuild
index 6a16f274ee2b..5a3b50c621ea 100644
--- a/app-text/a2ps/a2ps-4.13b-r3.ebuild
+++ b/app-text/a2ps/a2ps-4.13b-r3.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/a2ps-4.13b-r3.ebuild,v 1.3 2002/04/12 16:56:03 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/a2ps-4.13b-r3.ebuild,v 1.4 2002/04/27 08:19:14 seemant Exp $
-P=a2ps-4.13b
-S=${WORKDIR}/a2ps-4.13
+S=${WORKDIR}/${P/b/}
DESCRIPTION="a2ps is an Any to PostScript filter"
SRC_URI="ftp://ftp.enst.fr/pub/unix/a2ps/${P}.tar.gz"
HOMEPAGE="http://www-inf.enst.fr/~demaille/a2ps"
@@ -16,23 +15,16 @@ DEPEND=">=app-text/ghostscript-6.23
RDEPEND="${DEPEND}
nls? ( sys-devel/gettext )"
-
src_compile() {
local myconf
use nls || myconf="--disable-nls"
-
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc/a2ps \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --enable-shared \
- --enable-static \
- ${myconf} || die
+
+ myconf="${myconf} --sysconfdir=/etc/a2ps"
+
+ econf ${myconf} || die "configure failed"
emake || die
}
@@ -41,12 +33,13 @@ src_install() {
dodir /usr/share/emacs/site-lisp
- make \
- prefix=${D}/usr \
+ make \
+ prefix=${D}/usr \
+ datadir=${D}/usr/share/a2ps \
sysconfdir=${D}/etc/a2ps \
- mandir=${D}/usr/share/man \
+ mandir=${D}/usr/share/man \
infodir=${D}/usr/share/info \
- lispdir=${D}/usr/share/emacs/site-lisp \
+ lispdir=${D}/usr/share/emacs/site-lisp \
install || die
dodoc ANNOUNCE AUTHORS ChangeLog COPYING FAQ NEWS README THANKS TODO
diff --git a/app-text/acroread/acroread-4.05-r4.ebuild b/app-text/acroread/acroread-4.05-r4.ebuild
index 83268029fc5f..f6a388ac60ed 100644
--- a/app-text/acroread/acroread-4.05-r4.ebuild
+++ b/app-text/acroread/acroread-4.05-r4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author: system@gentoo.org
-# $Header: /var/cvsroot/gentoo-x86/app-text/acroread/acroread-4.05-r4.ebuild,v 1.1 2002/04/05 05:48:41 tod Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/acroread/acroread-4.05-r4.ebuild,v 1.2 2002/04/27 08:20:10 seemant Exp $
MY_P=linux-ar-405
S=${WORKDIR}/ILINXR.install
@@ -14,10 +14,10 @@ RDEPEND="virtual/x11"
src_unpack() {
- unpack ${A}
- cd ${S}
- tar xvf ILINXR.TAR
- tar xvf READ.TAR
+ unpack ${A}
+ cd ${S}
+ tar xvf ILINXR.TAR
+ tar xvf READ.TAR
}
src_compile () {