summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-dicts/kasumi/ChangeLog7
-rw-r--r--app-dicts/kasumi/kasumi-2.5.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/app-dicts/kasumi/ChangeLog b/app-dicts/kasumi/ChangeLog
index 53663059d3d9..2bcd6df0f424 100644
--- a/app-dicts/kasumi/ChangeLog
+++ b/app-dicts/kasumi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-dicts/kasumi
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/kasumi/ChangeLog,v 1.40 2009/01/29 14:29:07 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/kasumi/ChangeLog,v 1.41 2009/08/02 23:41:06 matsuu Exp $
+
+*kasumi-2.5 (02 Aug 2009)
+
+ 02 Aug 2009; MATSUU Takuto <matsuu@gentoo.org> +kasumi-2.5.ebuild:
+ Version bumped.
*kasumi-2.4 (29 Jan 2009)
diff --git a/app-dicts/kasumi/kasumi-2.5.ebuild b/app-dicts/kasumi/kasumi-2.5.ebuild
new file mode 100644
index 000000000000..1081622f17bf
--- /dev/null
+++ b/app-dicts/kasumi/kasumi-2.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/kasumi/kasumi-2.5.ebuild,v 1.1 2009/08/02 23:41:06 matsuu Exp $
+
+DESCRIPTION="Anthy dictionary maintenance tool"
+HOMEPAGE="http://kasumi.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/41436/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ nls? ( virtual/libintl )
+ virtual/libiconv
+ >=app-i18n/anthy-6131"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ econf $(use_enable nls) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README
+}