summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--perl-core/DB_File/ChangeLog7
-rw-r--r--perl-core/DB_File/DB_File-1.817.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/perl-core/DB_File/ChangeLog b/perl-core/DB_File/ChangeLog
index 76b6e96ea3a6..4b029b87661a 100644
--- a/perl-core/DB_File/ChangeLog
+++ b/perl-core/DB_File/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for perl-core/DB_File
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/perl-core/DB_File/ChangeLog,v 1.25 2008/03/28 06:39:12 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/perl-core/DB_File/ChangeLog,v 1.26 2008/12/08 03:31:46 robbat2 Exp $
+
+*DB_File-1.817 (08 Dec 2008)
+
+ 08 Dec 2008; Robin H. Johnson <robbat2@gentoo.org> +DB_File-1.817.ebuild:
+ Version bump.
28 Mar 2008; Jeroen Roovers <jer@gentoo.org> DB_File-1.815.ebuild:
Stable for HPPA too.
diff --git a/perl-core/DB_File/DB_File-1.817.ebuild b/perl-core/DB_File/DB_File-1.817.ebuild
new file mode 100644
index 000000000000..af21e5888aca
--- /dev/null
+++ b/perl-core/DB_File/DB_File-1.817.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/DB_File/DB_File-1.817.ebuild,v 1.1 2008/12/08 03:31:46 robbat2 Exp $
+
+inherit perl-module multilib eutils
+
+DESCRIPTION="A Berkeley DB Support Perl Module"
+HOMEPAGE="http://www.cpan.org/modules/by-module/DB_File/${P}.readme"
+SRC_URI="mirror://cpan/authors/id/P/PM/PMQS/${P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ sys-libs/db"
+
+SRC_TEST="do"
+
+src_unpack() {
+ unpack ${A}
+ if [ $(get_libdir) != "lib" ] ; then
+ sed -i -e "s:^LIB.*:LIB = /usr/$(get_libdir):" \
+ ${S}/config.in || die
+ fi
+ cd ${S}
+ epatch ${FILESDIR}/DB_File-MakeMaker.patch
+}