summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-libs/freeipmi/ChangeLog12
-rw-r--r--sys-libs/freeipmi/files/freeipmi-0.6.10+glibc-2.8.patch179
-rw-r--r--sys-libs/freeipmi/freeipmi-0.6.10.ebuild56
-rw-r--r--sys-libs/freeipmi/freeipmi-1.0.1.ebuild71
4 files changed, 81 insertions, 237 deletions
diff --git a/sys-libs/freeipmi/ChangeLog b/sys-libs/freeipmi/ChangeLog
index 3960e31a4aba..8c8bbeb740e8 100644
--- a/sys-libs/freeipmi/ChangeLog
+++ b/sys-libs/freeipmi/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-libs/freeipmi
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/freeipmi/ChangeLog,v 1.29 2010/10/05 19:52:13 maekke Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/freeipmi/ChangeLog,v 1.30 2011/01/31 17:46:49 flameeyes Exp $
+
+*freeipmi-1.0.1 (31 Jan 2011)
+
+ 31 Jan 2011; Diego E. Pettenò <flameeyes@gentoo.org>
+ -freeipmi-0.6.10.ebuild, -files/freeipmi-0.6.10+glibc-2.8.patch,
+ +freeipmi-1.0.1.ebuild:
+ Version bump, remove old version and patch. Thanks to Christian (idl0r) in
+ bug #353327.
05 Oct 2010; Markus Meier <maekke@gentoo.org> freeipmi-0.8.9.ebuild:
x86 stable, bug #339140
diff --git a/sys-libs/freeipmi/files/freeipmi-0.6.10+glibc-2.8.patch b/sys-libs/freeipmi/files/freeipmi-0.6.10+glibc-2.8.patch
deleted file mode 100644
index 57ec5df7bc4c..000000000000
--- a/sys-libs/freeipmi/files/freeipmi-0.6.10+glibc-2.8.patch
+++ /dev/null
@@ -1,179 +0,0 @@
-Index: freeipmi-0.6.10/ipmi-oem/src/ipmi-oem-argp.c
-===================================================================
---- freeipmi-0.6.10.orig/ipmi-oem/src/ipmi-oem-argp.c
-+++ freeipmi-0.6.10/ipmi-oem/src/ipmi-oem-argp.c
-@@ -93,6 +93,7 @@ parse_opt (int key, char *arg, struct ar
- }
- else
- {
-+#if 0
- if (cmd_args->oem_options_count < ARG_MAX)
- {
- if (!(cmd_args->oem_options[cmd_args->oem_options_count] = strdup(arg)))
-@@ -103,6 +104,7 @@ parse_opt (int key, char *arg, struct ar
- cmd_args->oem_options_count++;
- break;
- }
-+#endif
- }
- break;
- }
-@@ -126,7 +128,9 @@ ipmi_oem_argp_parse (int argc, char **ar
-
- cmd_args->oem_id = NULL;
- cmd_args->oem_command = NULL;
-+#if 0
- memset (cmd_args->oem_options, 0, sizeof(cmd_args->oem_options));
-+#endif
- cmd_args->oem_options_count = 0;
-
- argp_parse (&argp, argc, argv, ARGP_IN_ORDER, NULL, cmd_args);
-Index: freeipmi-0.6.10/ipmi-oem/src/ipmi-oem.h
-===================================================================
---- freeipmi-0.6.10.orig/ipmi-oem/src/ipmi-oem.h
-+++ freeipmi-0.6.10/ipmi-oem/src/ipmi-oem.h
-@@ -20,7 +20,6 @@
- #define _IPMI_OEM_H
-
- #include <freeipmi/freeipmi.h>
--#include <limits.h> /* ARG_MAX */
-
- #include "tool-cmdline-common.h"
- #include "pstdout.h"
-@@ -31,7 +30,9 @@ struct ipmi_oem_arguments
- struct hostrange_cmd_args hostrange;
- char *oem_id;
- char *oem_command;
-+#if 0
- char *oem_options[ARG_MAX];
-+#endif
- unsigned int oem_options_count;
- };
-
-Index: freeipmi-0.6.10/ipmipower/src/Makefile.am
-===================================================================
---- freeipmi-0.6.10.orig/ipmipower/src/Makefile.am
-+++ freeipmi-0.6.10/ipmipower/src/Makefile.am
-@@ -32,7 +32,8 @@ ipmipower_CPPFLAGS = \
- -I$(srcdir)/../../ipmidetect/src/libipmidetect \
- -I$(srcdir)/../../libfreeipmi/include \
- -DWITH_LSD_FATAL_ERROR_FUNC=1 \
-- -DWITH_LSD_NOMEM_ERROR_FUNC=1
-+ -DWITH_LSD_NOMEM_ERROR_FUNC=1 \
-+ -D_GNU_SOURCE
-
- noinst_HEADERS= \
- argv.h \
-Index: freeipmi-0.6.10/ipmi-raw/src/ipmi-raw-argp.c
-===================================================================
---- freeipmi-0.6.10.orig/ipmi-raw/src/ipmi-raw-argp.c
-+++ freeipmi-0.6.10/ipmi-raw/src/ipmi-raw-argp.c
-@@ -24,6 +24,7 @@
- #include <stdlib.h>
- #if STDC_HEADERS
- #include <string.h>
-+#include <unistd.h>
- #endif /* STDC_HEADERS */
- #include <argp.h>
-
-@@ -139,7 +140,7 @@ ipmi_raw_argp_parse (int argc, char **ar
- init_hostrange_cmd_args (&(cmd_args->hostrange));
-
- cmd_args->cmd_file = NULL;
-- memset (cmd_args->cmd, 0, sizeof(cmd_args->cmd));
-+ cmd_args->cmd = calloc(sysconf(_SC_ARG_MAX), sizeof(uint8_t));
- cmd_args->cmd_length = 0;
-
- argp_parse (&argp, argc, argv, ARGP_IN_ORDER, NULL, cmd_args);
-Index: freeipmi-0.6.10/ipmi-raw/src/ipmi-raw.c
-===================================================================
---- freeipmi-0.6.10.orig/ipmi-raw/src/ipmi-raw.c
-+++ freeipmi-0.6.10/ipmi-raw/src/ipmi-raw.c
-@@ -24,9 +24,9 @@
- #include <stdlib.h>
- #if STDC_HEADERS
- #include <string.h>
-+#include <unistd.h>
- #endif /* STDC_HEADERS */
- #include <argp.h>
--#include <limits.h>
- #include <assert.h>
-
- #include <freeipmi/freeipmi.h>
-@@ -46,13 +46,17 @@ ipmi_raw_cmdline (ipmi_raw_state_data_t
- uint8_t *bytes_rq = NULL;
- int send_len;
- int i;
-- uint8_t bytes_rs[ARG_MAX];
-+ uint8_t *bytes_rs;
-+ long arg_max;
- int32_t rs_len;
-
- assert(state_data);
- assert(state_data->prog_data->args->cmd);
- assert(state_data->prog_data->args->cmd_length);
-
-+ arg_max = sysconf(_SC_ARG_MAX);
-+ bytes_rs = calloc(arg_max, sizeof(uint8_t));
-+
- args = state_data->prog_data->args;
-
- bytes_rq = args->cmd;
-@@ -72,7 +76,7 @@ ipmi_raw_cmdline (ipmi_raw_state_data_t
- &bytes_rq[2],
- send_len - 2,
- bytes_rs,
-- ARG_MAX)) >= 0)
-+ arg_max)) >= 0)
- {
- pstdout_printf (state_data->pstate, "rcvd: ");
- for (i = 0; i < rs_len; i++)
-@@ -210,13 +214,17 @@ ipmi_raw_stream (ipmi_raw_state_data_t *
- size_t n = 0;
- uint8_t *bytes_rq = NULL;
- int send_len;
-- uint8_t bytes_rs[ARG_MAX];
-+ uint8_t *bytes_rs;
-+ long arg_max;
- int32_t rs_len;
- int i, rv = -1;
-
- assert(state_data);
- assert(stream);
-
-+ arg_max = sysconf(_SC_ARG_MAX);
-+ bytes_rs = calloc(arg_max, sizeof(uint8_t));
-+
- args = state_data->prog_data->args;
-
- while (1)
-@@ -246,7 +254,7 @@ ipmi_raw_stream (ipmi_raw_state_data_t *
- &bytes_rq[2],
- send_len - 2,
- bytes_rs,
-- ARG_MAX)) < 0)
-+ arg_max)) < 0)
- {
- pstdout_fprintf(state_data->pstate,
- stderr,
-Index: freeipmi-0.6.10/ipmi-raw/src/ipmi-raw.h
-===================================================================
---- freeipmi-0.6.10.orig/ipmi-raw/src/ipmi-raw.h
-+++ freeipmi-0.6.10/ipmi-raw/src/ipmi-raw.h
-@@ -20,7 +20,6 @@
- #define _IPMI_RAW_H
-
- #include <freeipmi/freeipmi.h>
--#include <limits.h> /* ARG_MAX */
-
- #include "tool-cmdline-common.h"
- #include "pstdout.h"
-@@ -35,7 +34,7 @@ struct ipmi_raw_arguments
- struct common_cmd_args common;
- struct hostrange_cmd_args hostrange;
- char *cmd_file;
-- uint8_t cmd[ARG_MAX];
-+ uint8_t *cmd;
- int cmd_length;
- };
-
diff --git a/sys-libs/freeipmi/freeipmi-0.6.10.ebuild b/sys-libs/freeipmi/freeipmi-0.6.10.ebuild
deleted file mode 100644
index 9875a01a1c63..000000000000
--- a/sys-libs/freeipmi/freeipmi-0.6.10.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/freeipmi/freeipmi-0.6.10.ebuild,v 1.3 2009/10/01 09:44:50 flameeyes Exp $
-
-WANT_AUTOMAKE=1.9
-
-inherit autotools
-
-DESCRIPTION="Provides Remote-Console and System Management Software as per IPMI v1.5/2.0"
-HOMEPAGE="http://www.gnu.org/software/freeipmi/"
-SRC_URI="ftp://ftp.zresearch.com/pub/${PN}/${PV}/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug syslog"
-
-RDEPEND="dev-libs/libgcrypt"
-DEPEND="${RDEPEND}
- virtual/os-headers"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${P}+glibc-2.8.patch"
- AT_M4DIR="config" eautomake
-}
-
-src_compile() {
- econf \
- --disable-init-scripts \
- $(use_enable debug) \
- --enable-logrotate-config \
- $(use_enable syslog) \
- --localstatedir=/var \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}" install || die "emake install failed"
-
- dodoc AUTHORS ChangeLog* DISCLAIMER* NEWS README* TODO
- dodoc doc/*.txt
-
- rm "${D}"/usr/share/doc/${PF}/COPYING* "${D}"/usr/share/doc/${PF}/INSTALL
-
- keepdir \
- /var/cache/ipmimonitoringsdrcache \
- /var/lib/freeipmi \
- /var/log/{freeipmi,ipmiconsole}
-
- newinitd "${FILESDIR}/ipmidetectd.initd" ipmidetectd
- newinitd "${FILESDIR}/bmc-watchdog.initd" bmc-watchdog
- newconfd "${FILESDIR}/bmc-watchdog.confd" bmc-watchdog
-}
diff --git a/sys-libs/freeipmi/freeipmi-1.0.1.ebuild b/sys-libs/freeipmi/freeipmi-1.0.1.ebuild
new file mode 100644
index 000000000000..6cfdfa1a5606
--- /dev/null
+++ b/sys-libs/freeipmi/freeipmi-1.0.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/freeipmi/freeipmi-1.0.1.ebuild,v 1.1 2011/01/31 17:46:49 flameeyes Exp $
+
+EAPI=2
+
+inherit autotools
+
+DESCRIPTION="Provides Remote-Console and System Management Software as per IPMI v1.5/2.0"
+HOMEPAGE="http://www.gnu.org/software/freeipmi/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
+ http://ftp.gluster.com/pub/${PN}/${PV}/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="dev-libs/libgcrypt"
+DEPEND="${RDEPEND}
+ virtual/os-headers"
+
+src_prepare() {
+ # Fix build mistake, only causes warnings but at least stop it.
+ sed -i -e '/-module/d' "${S}"/libfreeipmi/src/Makefile.am || die
+
+ AT_M4DIR="config" eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ --enable-fast-install \
+ --disable-static \
+ --disable-init-scripts \
+ --enable-logrotate-config \
+ --localstatedir=/var
+}
+
+# There are no tests
+src_test() { :; }
+
+src_install() {
+ emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}" install || die "emake install failed"
+ find "${D}" -name '*.la' -delete
+
+ # freeipmi by defaults install _all_ commands to /usr/sbin, but
+ # quite a few can be run remotely as standard user, so move them
+ # in /usr/bin afterwards.
+ dodir /usr/bin
+ for file in ipmi{detect,ping,power,console}; do
+ mv "${D}"/usr/{s,}bin/${file} || die
+
+ # The default install symlinks these commands to add a dash
+ # after the ipmi prefix; we repeat those after move for
+ # consistency.
+ rm "${D}"/usr/sbin/${file/ipmi/ipmi-}
+ dosym ${file} /usr/bin/${file/ipmi/ipmi-}
+ done
+
+ dodoc AUTHORS ChangeLog* DISCLAIMER* NEWS README* TODO doc/*.txt || die
+
+ keepdir \
+ /var/cache/ipmimonitoringsdrcache \
+ /var/lib/freeipmi \
+ /var/log/{freeipmi,ipmiconsole}
+
+ newinitd "${FILESDIR}/ipmidetectd.initd" ipmidetectd
+ newinitd "${FILESDIR}/bmc-watchdog.initd" bmc-watchdog
+ newconfd "${FILESDIR}/bmc-watchdog.confd" bmc-watchdog
+}