summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/commoncpp2/commoncpp2-1.0.1.ebuild36
-rw-r--r--dev-python/ReportLab/ReportLab-1.11.ebuild22
2 files changed, 20 insertions, 38 deletions
diff --git a/dev-libs/commoncpp2/commoncpp2-1.0.1.ebuild b/dev-libs/commoncpp2/commoncpp2-1.0.1.ebuild
index c4311c2a1652..c5b282c340a3 100644
--- a/dev-libs/commoncpp2/commoncpp2-1.0.1.ebuild
+++ b/dev-libs/commoncpp2/commoncpp2-1.0.1.ebuild
@@ -1,25 +1,19 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/commoncpp2/commoncpp2-1.0.1.ebuild,v 1.3 2002/10/05 05:39:10 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/commoncpp2/commoncpp2-1.0.1.ebuild,v 1.4 2002/11/12 06:30:27 vapier Exp $
-IUSE="doc xml2"
-
-S=${WORKDIR}/${P}
-DESCRIPTION="GNU Common C++ is a C++ framework offering portable support for\
-threading, sockets, file access, daemons, persistence, serial I/O, XML parsing,\
-and system services"
+DESCRIPTION="C++ framework offering portable support for threading, sockets, file access, daemons, persistence, serial I/O, XML parsing, and system services"
SRC_URI="mirror://gnu/commonc++/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/commonc++/"
-DEPEND="sys-libs/zlib
- xml2? ( dev-libs/libxml2 )
- doc? ( app-doc/doxygen )"
-
-RDEPEND=${DEPEND}
-
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86"
+IUSE="doc xml2"
+
+DEPEND="sys-libs/zlib
+ xml2? ( dev-libs/libxml2 )
+ doc? ( app-doc/doxygen )"
src_compile() {
local myconf=""
@@ -28,24 +22,20 @@ src_compile() {
&& myconf="${myconf} --with-xml" \
|| myconf="${myconf} --without-xml"
- econf ${myconf} || die "./configure failed"
+ econf ${myconf}
- emake || die
+ emake || die "emake failed"
# kdoc disabled for now, it errors out
use doc && make doxy
}
-src_install () {
-
- einstall || die
+src_install() {
+ einstall
- dodoc AUTHORS INSTALL NEWS ChangeLog README\
+ dodoc AUTHORS INSTALL NEWS ChangeLog README \
THANKS TODO COPYING COPYING.addendum
# the docs come out already compressed
- use doc && ( \
- dodoc commoncpp2-html-manual-1.0.1.tar.gz \
- commoncpp2-latex-manual-1.0.1.tar.gz
- )
+ use doc && dodoc commoncpp2-{html,latex}-manual-1.0.1.tar.gz
}
diff --git a/dev-python/ReportLab/ReportLab-1.11.ebuild b/dev-python/ReportLab/ReportLab-1.11.ebuild
index 3323e324bb7a..df961f1cd247 100644
--- a/dev-python/ReportLab/ReportLab-1.11.ebuild
+++ b/dev-python/ReportLab/ReportLab-1.11.ebuild
@@ -1,33 +1,30 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/ReportLab/ReportLab-1.11.ebuild,v 1.6 2002/10/17 16:36:53 bjb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ReportLab/ReportLab-1.11.ebuild,v 1.7 2002/11/12 06:32:09 vapier Exp $
#goofy tarball versioning
vmaj=${PV%%.*}
vmin=${PV##*.}
-S=${WORKDIR}/reportlab
DESCRIPTION="Tools for generating printable PDF documents from any data source."
SRC_URI="http://www.reportlab.com/ftp/${PN}_${vmaj}_${vmin}.tgz"
HOMEPAGE="http://www.reportlab.com/"
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86 sparc sparc64 alpha"
+
DEPEND=">=dev-lang/python-2.0
>=sys-libs/zlib-0.95
dev-python/Imaging"
-RDEPEND=${DEPEND}
-
-SLOT="0"
-LICENSE="as-is"
-KEYWORDS="x86 sparc sparc64 alpha"
+S=${WORKDIR}/reportlab
src_install() {
-
#grab python verision so ebuild doesn't depend on it
local pv
pv=$(python -V 2>&1 | sed -e 's:Python \([0-9].[0-9]\).*:\1:')
-
insinto /usr/lib/python$pv/site-packages
echo "reportlab" > reportlab.pth
doins reportlab.pth
@@ -36,10 +33,5 @@ src_install() {
cp -a reportlab ${D}/usr/lib/python$pv/site-packages
cd ${S}
- dodoc README license.txt
-
+ dodoc README license.txt
}
-
-
-
-