summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/PyXML/ChangeLog7
-rw-r--r--dev-python/PyXML/Manifest9
-rw-r--r--dev-python/PyXML/PyXML-0.8.2.ebuild39
-rw-r--r--dev-python/PyXML/files/digest-PyXML-0.8.21
4 files changed, 55 insertions, 1 deletions
diff --git a/dev-python/PyXML/ChangeLog b/dev-python/PyXML/ChangeLog
index 9408c078bbe2..face83cb3add 100644
--- a/dev-python/PyXML/ChangeLog
+++ b/dev-python/PyXML/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/PyXML
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyXML/ChangeLog,v 1.11 2003/04/09 03:05:55 todd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyXML/ChangeLog,v 1.12 2003/04/24 22:16:15 liquidx Exp $
+
+*PyXML-0.8.2 (24 Apr 2003)
+
+ 24 Apr 2003; Alastair Tse <liquidx@gentoo.org> PyXML-0.8.2.ebuild:
+ version bump because the older one doesn't work with newest expat (#14081)
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/dev-python/PyXML/Manifest b/dev-python/PyXML/Manifest
new file mode 100644
index 000000000000..7ac94b00b7ef
--- /dev/null
+++ b/dev-python/PyXML/Manifest
@@ -0,0 +1,9 @@
+MD5 a8eea9bbf52f89ead0ce6796053e3d7d ChangeLog 1961
+MD5 56512cbd7bf0cd1288761d7766ab0efd PyXML-0.7.1.ebuild 525
+MD5 bb8d85d07aa4721cb5f1542a16075aed PyXML-0.7.ebuild 534
+MD5 efa1bb008a71ddfee41346b39a68be23 PyXML-0.8.1.ebuild 621
+MD5 c6f9abf73f59f736f0497c032814735f PyXML-0.8.2.ebuild 878
+MD5 a6d6278775bfbaf841ba3212396dd604 files/digest-PyXML-0.7 61
+MD5 48d09a937fff9bfc8bd524919617a7d8 files/digest-PyXML-0.7.1 63
+MD5 b83e36b4dc90c3ce5840f0d2e432b7b2 files/digest-PyXML-0.8.1 63
+MD5 6a14eefbf90c139b1f9b058131cb211f files/digest-PyXML-0.8.2 63
diff --git a/dev-python/PyXML/PyXML-0.8.2.ebuild b/dev-python/PyXML/PyXML-0.8.2.ebuild
new file mode 100644
index 000000000000..a6c9878c69fc
--- /dev/null
+++ b/dev-python/PyXML/PyXML-0.8.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyXML/PyXML-0.8.2.ebuild,v 1.1 2003/04/24 22:16:15 liquidx Exp $
+
+IUSE=""
+
+inherit distutils
+
+DESCRIPTION="A collection of libraries to process XML with Python."
+SRC_URI="mirror://sourceforge/pyxml/${P}.tar.gz"
+HOMEPAGE="http://pyxml.sourceforge.net/"
+
+DEPEND="virtual/python
+ >=dev-libs/expat-1.95.6"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+LICENSE="PYTHON"
+
+src_compile() {
+ local myconf
+
+ # if you want to use 4Suite, then their XSLT/XPATH is
+ # better according to the docs
+ if has_version "dev-python/4Suite"; then
+ myconf="--without-xslt --without-xpath"
+ fi
+
+ distutils_src_compile ${myconf}
+}
+
+src_install() {
+
+ mydoc="ANNOUNCE CREDITS PKG-INFO doc/*.tex"
+ distutils_src_install
+
+ dohtml -r doc/*
+
+}
diff --git a/dev-python/PyXML/files/digest-PyXML-0.8.2 b/dev-python/PyXML/files/digest-PyXML-0.8.2
new file mode 100644
index 000000000000..22e7e83e6c34
--- /dev/null
+++ b/dev-python/PyXML/files/digest-PyXML-0.8.2
@@ -0,0 +1 @@
+MD5 089949423213bfee633e016da54cb90c PyXML-0.8.2.tar.gz 727458