summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-calculators/gonvert/ChangeLog10
-rw-r--r--sci-calculators/gonvert/gonvert-0.2.32.ebuild30
-rw-r--r--sci-calculators/gonvert/metadata.xml12
3 files changed, 44 insertions, 8 deletions
diff --git a/sci-calculators/gonvert/ChangeLog b/sci-calculators/gonvert/ChangeLog
index ce70e535eb8b..f7cc2aed3631 100644
--- a/sci-calculators/gonvert/ChangeLog
+++ b/sci-calculators/gonvert/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-calculators/gonvert
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/gonvert/ChangeLog,v 1.12 2012/08/04 21:15:30 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/gonvert/ChangeLog,v 1.13 2013/03/12 13:09:48 jlec Exp $
+
+*gonvert-0.2.32 (12 Mar 2013)
+
+ 12 Mar 2013; Justin Lecher <jlec@gentoo.org> +gonvert-0.2.32.ebuild,
+ metadata.xml:
+ Version Bump; fix for new python eclasses
04 Aug 2012; Sébastien Fabbro <bicatali@gentoo.org> -files/0.2.12-about.patch,
-files/0.2.15-glade.patch, -files/0.2.19-paths.patch,
diff --git a/sci-calculators/gonvert/gonvert-0.2.32.ebuild b/sci-calculators/gonvert/gonvert-0.2.32.ebuild
new file mode 100644
index 000000000000..93bbdf59bc5e
--- /dev/null
+++ b/sci-calculators/gonvert/gonvert-0.2.32.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/gonvert/gonvert-0.2.32.ebuild,v 1.1 2013/03/12 13:09:48 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit python-single-r1
+
+DESCRIPTION="Unit conversion utility written in PyGTK"
+HOMEPAGE="http://unihedron.com/projects/gonvert/index.php"
+SRC_URI="http://unihedron.com/projects/gonvert/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/pygtk:2[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/0.2.23-paths.patch )
+
+src_install () {
+ emake install DESTDIR="${D}" prefix="${EPREFIX}/usr"
+ python_fix_shebang "${ED}"/usr/bin
+ rm -fr "${ED}/usr/share/doc/${PN}"
+ dodoc doc/{CHANGELOG,FAQ,README,THANKS,TODO}
+}
diff --git a/sci-calculators/gonvert/metadata.xml b/sci-calculators/gonvert/metadata.xml
index 1f73393c5b8d..c9d73bdff576 100644
--- a/sci-calculators/gonvert/metadata.xml
+++ b/sci-calculators/gonvert/metadata.xml
@@ -1,12 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<maintainer>
- <email>chainsaw@gentoo.org</email>
- <name>Tony Vroon</name>
-</maintainer>
-<longdescription lang='en'>
+ <herd>sci</herd>
+ <maintainer>
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+ </maintainer>
+ <longdescription lang="en">
gonvert is a conversion utility that allows conversion between many
units like CGS, Ancient, Imperial with many categories like length,
mass, numbers, etc. All units converted values shown at once as you