summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--xfce-extra/xfce4-battery/ChangeLog8
-rw-r--r--xfce-extra/xfce4-battery/files/digest-xfce4-battery-0.5.0-r23
-rw-r--r--xfce-extra/xfce4-battery/files/xfce4-battery-0.5.0-2.6.21.patch16
-rw-r--r--xfce-extra/xfce4-battery/xfce4-battery-0.5.0-r2.ebuild28
4 files changed, 54 insertions, 1 deletions
diff --git a/xfce-extra/xfce4-battery/ChangeLog b/xfce-extra/xfce4-battery/ChangeLog
index 8ae612c4b44a..ecd939f11c71 100644
--- a/xfce-extra/xfce4-battery/ChangeLog
+++ b/xfce-extra/xfce4-battery/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-battery
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-battery/ChangeLog,v 1.51 2007/03/15 15:54:29 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-battery/ChangeLog,v 1.52 2007/04/29 14:23:46 drac Exp $
+
+*xfce4-battery-0.5.0-r2 (29 Apr 2007)
+
+ 29 Apr 2007; Samuli Suominen <drac@gentoo.org>
+ +files/xfce4-battery-0.5.0-2.6.21.patch, +xfce4-battery-0.5.0-r2.ebuild:
+ Patch libacpi to support Linux 2.6.21 for bug 176458, thanks to Phillip Berndt.
15 Mar 2007; Samuli Suominen <drac@gentoo.org>
xfce4-battery-0.5.0-r1.ebuild:
diff --git a/xfce-extra/xfce4-battery/files/digest-xfce4-battery-0.5.0-r2 b/xfce-extra/xfce4-battery/files/digest-xfce4-battery-0.5.0-r2
new file mode 100644
index 000000000000..6ccdc2f2dd92
--- /dev/null
+++ b/xfce-extra/xfce4-battery/files/digest-xfce4-battery-0.5.0-r2
@@ -0,0 +1,3 @@
+MD5 c1d923bb90b79087ca7044bcc24bab5a xfce4-battery-plugin-0.5.0.tar.bz2 222269
+RMD160 bbf64994c7686b11b6a51bd7728569cd2a5d9777 xfce4-battery-plugin-0.5.0.tar.bz2 222269
+SHA256 4428f2fe1f5f28e6cc711278fd9c5c90f325cf0c5298f98a5d60940116cbcef8 xfce4-battery-plugin-0.5.0.tar.bz2 222269
diff --git a/xfce-extra/xfce4-battery/files/xfce4-battery-0.5.0-2.6.21.patch b/xfce-extra/xfce4-battery/files/xfce4-battery-0.5.0-2.6.21.patch
new file mode 100644
index 000000000000..61fe3dacf70a
--- /dev/null
+++ b/xfce-extra/xfce4-battery/files/xfce4-battery-0.5.0-2.6.21.patch
@@ -0,0 +1,16 @@
+diff -Nru xfce4-battery-plugin-0.5.0-old/panel-plugin/libacpi.c xfce4-battery-plugin-0.5.0/panel-plugin/libacpi.c
+--- xfce4-battery-plugin-0.5.0-old/panel-plugin/libacpi.c 2007-04-29 15:08:23.670477251 +0000
++++ xfce4-battery-plugin-0.5.0/panel-plugin/libacpi.c 2007-04-29 15:17:23.213224040 +0000
+@@ -207,10 +207,10 @@
+ #ifdef __linux__
+ FILE *acpi;
+
+- if (!(acpi = fopen ("/proc/acpi/info", "r")))
++ if ( (!(acpi = fopen ("/proc/acpi/info", "r"))) && (!(acpi = fopen ("/sys/module/acpi/parameters/acpica_version", "r"))) )
+ {
+ #ifdef DEBUG
+- printf("DBG:no acpi: /proc/acpi/info not found!\n");
++ printf("DBG:no acpi: /proc/acpi/info and /sys/module/acpi/parameters/acpica_version not found!\n");
+ #endif
+ return 1;
+ }
diff --git a/xfce-extra/xfce4-battery/xfce4-battery-0.5.0-r2.ebuild b/xfce-extra/xfce4-battery/xfce4-battery-0.5.0-r2.ebuild
new file mode 100644
index 000000000000..758ba45491a7
--- /dev/null
+++ b/xfce-extra/xfce4-battery/xfce4-battery-0.5.0-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-battery/xfce4-battery-0.5.0-r2.ebuild,v 1.1 2007/04/29 14:23:46 drac Exp $
+
+inherit eutils xfce44
+
+xfce44
+
+RESTRICT="test"
+
+DESCRIPTION="Battery status panel plugin"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="debug"
+
+DEPEND="dev-util/pkgconfig
+ dev-util/intltool"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-freebsd.patch
+ epatch "${FILESDIR}"/${P}-libacpi.patch
+ epatch "${FILESDIR}"/${P}-2.6.21.patch
+}
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+xfce44_goodies_panel_plugin