summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-video/subtitlecomposer/ChangeLog6
-rw-r--r--media-video/subtitlecomposer/files/subtitlecomposer-0.5.3-gcc45.patch15
-rw-r--r--media-video/subtitlecomposer/subtitlecomposer-0.5.3.ebuild3
3 files changed, 22 insertions, 2 deletions
diff --git a/media-video/subtitlecomposer/ChangeLog b/media-video/subtitlecomposer/ChangeLog
index 7b5594fae4f8..dda07d1e6540 100644
--- a/media-video/subtitlecomposer/ChangeLog
+++ b/media-video/subtitlecomposer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/subtitlecomposer
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/subtitlecomposer/ChangeLog,v 1.4 2010/06/08 03:16:40 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/subtitlecomposer/ChangeLog,v 1.5 2010/06/24 18:44:27 xarthisius Exp $
+
+ 24 Jun 2010; Kacper Kowalik <xarthisius@gentoo.org>
+ subtitlecomposer-0.5.3.ebuild, +files/subtitlecomposer-0.5.3-gcc45.patch:
+ Fix build with GCC-4.5 wrt bug 323055. Thanks to Diego for reporting.
08 Jun 2010; Maciej Mrozowski <reavertm@gentoo.org>
subtitlecomposer-0.5.3.ebuild:
diff --git a/media-video/subtitlecomposer/files/subtitlecomposer-0.5.3-gcc45.patch b/media-video/subtitlecomposer/files/subtitlecomposer-0.5.3-gcc45.patch
new file mode 100644
index 000000000000..4439071173b1
--- /dev/null
+++ b/media-video/subtitlecomposer/files/subtitlecomposer-0.5.3-gcc45.patch
@@ -0,0 +1,15 @@
+Fix build with GCC-4.5
+
+http://bugs.gentoo.org/show_bug.cgi?id=323055
+
+--- src/core/sstring.cpp
++++ src/core/sstring.cpp
+@@ -1112,7 +1112,7 @@
+ append( str );
+ }
+
+-SStringList::SStringList( const SStringList::SStringList& list ):
++SStringList::SStringList( const SStringList& list ):
+ QList<SString>( list )
+ {
+ }
diff --git a/media-video/subtitlecomposer/subtitlecomposer-0.5.3.ebuild b/media-video/subtitlecomposer/subtitlecomposer-0.5.3.ebuild
index 7a9f0c1ba1ff..c55ed1cb4ec6 100644
--- a/media-video/subtitlecomposer/subtitlecomposer-0.5.3.ebuild
+++ b/media-video/subtitlecomposer/subtitlecomposer-0.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/subtitlecomposer/subtitlecomposer-0.5.3.ebuild,v 1.2 2010/06/08 03:16:40 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/subtitlecomposer/subtitlecomposer-0.5.3.ebuild,v 1.3 2010/06/24 18:44:27 xarthisius Exp $
EAPI="2"
@@ -30,6 +30,7 @@ src_prepare() {
# linkage issue
epatch "${FILESDIR}/${PN}-linkage-patch.patch"
+ epatch "${FILESDIR}"/${P}-gcc45.patch
sed -e '/ADD_SUBDIRECTORY( api )/s/^/# DISABLED/' \
-i src/main/scripting/examples/CMakeLists.txt \