summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-wm/metacity/ChangeLog9
-rw-r--r--x11-wm/metacity/files/metacity-2.4.1-ppc-gcc3.2.diff52
-rw-r--r--x11-wm/metacity/metacity-2.4.1.ebuild14
3 files changed, 69 insertions, 6 deletions
diff --git a/x11-wm/metacity/ChangeLog b/x11-wm/metacity/ChangeLog
index f6818a6153ed..54a08649a8f1 100644
--- a/x11-wm/metacity/ChangeLog
+++ b/x11-wm/metacity/ChangeLog
@@ -1,9 +1,12 @@
# ChangeLog for x11-wm/metacity
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/ChangeLog,v 1.12 2002/09/20 23:23:49 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/ChangeLog,v 1.13 2002/09/26 02:32:38 gerk Exp $
+
+*metacity-2.4.1 (20 Sep 2002)
+ 25 Sep 2002; Mark Guertin <gerk@gentoo.org> metacity-2.4.1.ebuild :
+ updated ppc patch and re-insterted (still needed). Patch is being
+ re-submitted upstream.
-*metacit-2.4.1 (20 Sep 2002)
-
20 Sep 2002; Spider <spider@gentoo.org> metacity-2.4.1.ebuild : version bump,
removed the ppc patch
diff --git a/x11-wm/metacity/files/metacity-2.4.1-ppc-gcc3.2.diff b/x11-wm/metacity/files/metacity-2.4.1-ppc-gcc3.2.diff
new file mode 100644
index 000000000000..8f12a2576455
--- /dev/null
+++ b/x11-wm/metacity/files/metacity-2.4.1-ppc-gcc3.2.diff
@@ -0,0 +1,52 @@
+--- metacity-2.4.1.orig/src/screen.c Tue Aug 6 14:25:48 2002
++++ metacity-2.4.1/src/screen.c Thu Aug 15 00:35:11 2002
+@@ -1334,6 +1334,7 @@
+ }
+ }
+
++
+ void
+ meta_screen_calc_workspace_layout (MetaScreen *screen,
+ int num_workspaces,
+@@ -1368,17 +1369,34 @@
+ if (rows <= 0 && cols <= 0)
+ cols = num_workspaces;
+
+- if (rows <= 0)
+- rows = num_workspaces / cols + ((num_workspaces % cols) > 0 ? 1 : 0);
+- if (cols <= 0)
+- cols = num_workspaces / rows + ((num_workspaces % rows) > 0 ? 1 : 0);
++ if (rows <= 0) {
++ /* fix PPC compile issue
++ * ICE occurs using embedded macro in calculation, split
++ * into if statements
++ */
++ if ((num_workspaces % cols) > 0) {
++ rows = num_workspaces / cols + 1;
++ } else {
++ rows = num_workspaces / cols;
++ }
++ }
++ if (cols <= 0) {
++ /* another fix for PPC compile issue */
++ if ((num_workspaces % rows) > 0) {
++ cols = num_workspaces / rows + 1;
++ } else {
++ cols = num_workspaces / rows;
++ }
++ }
+
+ /* paranoia */
++
+ if (rows < 1)
+ rows = 1;
+ if (cols < 1)
+ cols = 1;
+
+- *r = rows;
+- *c = cols;
++ r[0] = rows;
++ c[0] = cols;
+ }
++
+
diff --git a/x11-wm/metacity/metacity-2.4.1.ebuild b/x11-wm/metacity/metacity-2.4.1.ebuild
index 55ace6716982..c10fbdfa5fbe 100644
--- a/x11-wm/metacity/metacity-2.4.1.ebuild
+++ b/x11-wm/metacity/metacity-2.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/metacity-2.4.1.ebuild,v 1.1 2002/09/20 23:23:49 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/metacity-2.4.1.ebuild,v 1.2 2002/09/26 02:32:38 gerk Exp $
inherit gnome2
@@ -28,5 +28,13 @@ DEPEND="${RDEPEND}
G2CONF="${G2CONF} --enable-platform-gnome-2"
DOCS="AUTHORS COPYING ChangeLog HACKING INSTALL NEWS README"
-
-
+src_unpack(){
+ unpack ${A}
+ # causes ICE on ppc w/ gcc (still)
+ use ppc && (
+ [ -z "${CC}" ] && CC=gcc
+ if [ "`${CC} -dumpversion | cut -d. -f1,2`" != "2.95" ] ; then
+ patch -p0 < ${FILESDIR}/metacity-2.4.1-ppc-gcc3.2.diff || die "patch failed"
+ fi
+ )
+}