summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-client/firefox/ChangeLog8
-rw-r--r--www-client/firefox/firefox-24.0-r1.ebuild (renamed from www-client/firefox/firefox-24.0.ebuild)13
2 files changed, 16 insertions, 5 deletions
diff --git a/www-client/firefox/ChangeLog b/www-client/firefox/ChangeLog
index c80eab1e8cb1..0e1657cc3248 100644
--- a/www-client/firefox/ChangeLog
+++ b/www-client/firefox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-client/firefox
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/ChangeLog,v 1.272 2013/09/24 11:58:29 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/ChangeLog,v 1.273 2013/09/24 14:23:08 axs Exp $
+
+*firefox-24.0-r1 (24 Sep 2013)
+
+ 24 Sep 2013; Ian Stakenvicius <axs@gentoo.org> +firefox-24.0-r1.ebuild,
+ -firefox-24.0.ebuild:
+ Fix bug #485838 and bug #485816
24 Sep 2013; Jeroen Roovers <jer@gentoo.org> firefox-24.0.ebuild:
Marked ~hppa too.
diff --git a/www-client/firefox/firefox-24.0.ebuild b/www-client/firefox/firefox-24.0-r1.ebuild
index 1b3d0e10897e..7bb70ccf3d99 100644
--- a/www-client/firefox/firefox-24.0.ebuild
+++ b/www-client/firefox/firefox-24.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/firefox-24.0.ebuild,v 1.2 2013/09/24 11:58:29 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/firefox-24.0-r1.ebuild,v 1.1 2013/09/24 14:23:08 axs Exp $
EAPI="3"
VIRTUALX_REQUIRED="pgo"
@@ -36,7 +36,7 @@ inherit check-reqs flag-o-matic toolchain-funcs eutils gnome2-utils mozconfig-3
DESCRIPTION="Firefox Web Browser"
HOMEPAGE="http://www.mozilla.com/firefox"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
SLOT="0"
LICENSE="MPL-2.0 GPL-2 LGPL-2.1"
IUSE="bindist gstreamer +jit +minimal pgo pulseaudio selinux system-cairo system-icu system-jpeg system-sqlite"
@@ -157,6 +157,12 @@ src_prepare() {
"${S}"/build/unix/run-mozilla.sh || die "sed failed!"
fi
+ # Ensure that are plugins dir is enabled as default
+ sed -i -e "s:/usr/lib/mozilla/plugins:/usr/lib/nsbrowser/plugins:" \
+ "${S}"/xpcom/io/nsAppFileLocationProvider.cpp || die "sed failed to replace plugin path for 32bit!"
+ sed -i -e "s:/usr/lib64/mozilla/plugins:/usr/lib64/nsbrowser/plugins:" \
+ "${S}"/xpcom/io/nsAppFileLocationProvider.cpp || die "sed failed to replace plugin path for 64bit!"
+
# Fix sandbox violations during make clean, bug 372817
sed -e "s:\(/no-such-file\):${T}\1:g" \
-i "${S}"/config/rules.mk \
@@ -216,15 +222,14 @@ src_configure() {
mozconfig_use_enable gstreamer
mozconfig_use_enable pulseaudio
+ mozconfig_use_enable system-cairo
mozconfig_use_enable system-sqlite
mozconfig_use_with system-jpeg
mozconfig_use_with system-icu
mozconfig_use_enable system-icu intl-api
# Feature is know to cause problems on hardened
mozconfig_use_enable jit methodjit
- mozconfig_use_enable jit tracejit
mozconfig_use_enable jit ion
- mozconfig_use_enable system-cairo
# Allow for a proper pgo build
if use pgo; then