summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-arcade/aop/ChangeLog10
-rw-r--r--games-arcade/aop/Manifest2
-rw-r--r--games-arcade/aop/aop-0.6.ebuild33
-rw-r--r--games-arcade/aop/files/digest-aop-0.61
-rw-r--r--games-arcade/aop/metadata.xml5
5 files changed, 51 insertions, 0 deletions
diff --git a/games-arcade/aop/ChangeLog b/games-arcade/aop/ChangeLog
new file mode 100644
index 000000000000..20245914b7db
--- /dev/null
+++ b/games-arcade/aop/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-arcade/aop
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/aop/ChangeLog,v 1.1 2004/12/02 10:26:27 mr_bones_ Exp $
+
+*aop-0.6 (02 Dec 2004)
+
+ 02 Dec 2004; Michael Sterrett <mr_bones_@gentoo.org> +metadata.xml,
+ +aop-0.6.ebuild:
+ initial commit - ebuild submitted by Adrian Fruehwirth via bug #72611
+
diff --git a/games-arcade/aop/Manifest b/games-arcade/aop/Manifest
new file mode 100644
index 000000000000..b84f70344e3e
--- /dev/null
+++ b/games-arcade/aop/Manifest
@@ -0,0 +1,2 @@
+MD5 da1c3da6eb72cdaa3b97863712dfedf9 aop-0.6.ebuild 668
+MD5 6a167f4c9b66b497b9c2bf5431c89033 files/digest-aop-0.6 58
diff --git a/games-arcade/aop/aop-0.6.ebuild b/games-arcade/aop/aop-0.6.ebuild
new file mode 100644
index 000000000000..86616c8243ce
--- /dev/null
+++ b/games-arcade/aop/aop-0.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/aop/aop-0.6.ebuild,v 1.1 2004/12/02 10:26:27 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Ambassador of Pain is a cursed based game with only 64 lines of code."
+HOMEPAGE="http://aop.raffi.at/"
+SRC_URI="http://www.raffi.at/code/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "s#/usr/local/share#${GAMES_DATADIR}#" \
+ aop.c \
+ || die "sed failed"
+}
+
+src_install() {
+ dogamesbin aop || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins aop-level-*.txt || die "doins failed"
+ prepgamesdirs
+}
+
diff --git a/games-arcade/aop/files/digest-aop-0.6 b/games-arcade/aop/files/digest-aop-0.6
new file mode 100644
index 000000000000..a3a9a08ebf08
--- /dev/null
+++ b/games-arcade/aop/files/digest-aop-0.6
@@ -0,0 +1 @@
+MD5 8057b3ec240db608253d653eb692d244 aop-0.6.tar.gz 11811
diff --git a/games-arcade/aop/metadata.xml b/games-arcade/aop/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/aop/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>