summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-plugins/gimp-lensfun/ChangeLog9
-rw-r--r--media-plugins/gimp-lensfun/files/0.2.3-remove-deprecated-output.patch22
-rw-r--r--media-plugins/gimp-lensfun/gimp-lensfun-0.2.3.ebuild6
3 files changed, 33 insertions, 4 deletions
diff --git a/media-plugins/gimp-lensfun/ChangeLog b/media-plugins/gimp-lensfun/ChangeLog
index 80e61c49d88c..a573a321271b 100644
--- a/media-plugins/gimp-lensfun/ChangeLog
+++ b/media-plugins/gimp-lensfun/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/gimp-lensfun
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gimp-lensfun/ChangeLog,v 1.6 2014/05/30 13:15:03 swift Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gimp-lensfun/ChangeLog,v 1.7 2015/03/30 09:11:33 idella4 Exp $
+
+ 30 Mar 2015; Ian Delaney <idella4@gentoo.org>
+ +files/0.2.3-remove-deprecated-output.patch, gimp-lensfun-0.2.3.ebuild:
+ add patch sourced from upstream, supplied by maintainer in bug #537130, fixes
+ bug
*gimp-lensfun-0.2.3 (30 May 2014)
diff --git a/media-plugins/gimp-lensfun/files/0.2.3-remove-deprecated-output.patch b/media-plugins/gimp-lensfun/files/0.2.3-remove-deprecated-output.patch
new file mode 100644
index 000000000000..3b4e7162e827
--- /dev/null
+++ b/media-plugins/gimp-lensfun/files/0.2.3-remove-deprecated-output.patch
@@ -0,0 +1,22 @@
+From 730e1280bb1968ec1e31f8c87949187b022a74bb Mon Sep 17 00:00:00 2001
+From: Sebastian Kraft <mail@sebastiankraft.net>
+Date: Mon, 11 Aug 2014 21:30:07 +0200
+Subject: [PATCH] CCI has been removed from lensfun, also remove it here
+
+---
+ src/gimplensfun.cpp | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/src/gimplensfun.cpp b/src/gimplensfun.cpp
+index 0b4bb8f..6a66a8f 100644
+--- a/src/gimplensfun.cpp
++++ b/src/gimplensfun.cpp
+@@ -297,7 +297,6 @@ static void PrintLens (const lfLens *lens)
+ g_print ("\tFocal: %g-%g\n", lens->MinFocal, lens->MaxFocal);
+ g_print ("\tAperture: %g-%g\n", lens->MinAperture, lens->MaxAperture);
+ g_print ("\tCenter: %g,%g\n", lens->CenterX, lens->CenterY);
+- g_print ("\tCCI: %g/%g/%g\n", lens->RedCCI, lens->GreenCCI, lens->BlueCCI);
+ if (lens->Mounts)
+ for (int j = 0; lens->Mounts [j]; j++)
+ g_print ("\tMount: %s\n", lf_db_mount_name (ldb, lens->Mounts [j]));
+
diff --git a/media-plugins/gimp-lensfun/gimp-lensfun-0.2.3.ebuild b/media-plugins/gimp-lensfun/gimp-lensfun-0.2.3.ebuild
index 1b45d4df293f..b97cffcf8f3e 100644
--- a/media-plugins/gimp-lensfun/gimp-lensfun-0.2.3.ebuild
+++ b/media-plugins/gimp-lensfun/gimp-lensfun-0.2.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gimp-lensfun/gimp-lensfun-0.2.3.ebuild,v 1.1 2014/05/30 13:15:03 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gimp-lensfun/gimp-lensfun-0.2.3.ebuild,v 1.2 2015/03/30 09:11:33 idella4 Exp $
EAPI="5"
@@ -32,6 +32,8 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${PV}-remove-deprecated-output.patch
+
if ! use openmp; then
sed -i "s/-fopenmp//g" Makefile
fi