summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/lcd4linux/lcd4linux-0.9.10.ebuild22
-rw-r--r--app-misc/lcdproc/lcdproc-0.4.3-r2.ebuild15
-rw-r--r--app-misc/linup/linup-1.1.1-r1.ebuild14
-rw-r--r--app-misc/magicdev/magicdev-1.1.4.ebuild20
-rw-r--r--app-misc/mc/mc-4.6.0-r3.ebuild4
-rw-r--r--app-misc/mc/mc-4.6.0-r4.ebuild4
-rw-r--r--app-misc/mc/mc-4.6.0-r5.ebuild40
-rw-r--r--app-misc/mtail/mtail-1.1.1-r1.ebuild15
-rw-r--r--app-misc/mwavem/mwavem-1.0.4.ebuild9
-rw-r--r--app-misc/screen/screen-4.0.1-r2.ebuild8
10 files changed, 73 insertions, 78 deletions
diff --git a/app-misc/lcd4linux/lcd4linux-0.9.10.ebuild b/app-misc/lcd4linux/lcd4linux-0.9.10.ebuild
index 3b60850a7be4..ba1bf917dd59 100644
--- a/app-misc/lcd4linux/lcd4linux-0.9.10.ebuild
+++ b/app-misc/lcd4linux/lcd4linux-0.9.10.ebuild
@@ -1,44 +1,46 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lcd4linux/lcd4linux-0.9.10.ebuild,v 1.2 2004/01/18 14:39:04 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lcd4linux/lcd4linux-0.9.10.ebuild,v 1.3 2004/04/06 04:19:22 vapier Exp $
+
+inherit eutils
DESCRIPTION="system and ISDN information is shown on an external display or in a X11 window."
+HOMEPAGE="http://lcd4linux.sourceforge.net/"
SRC_URI="mirror://sourceforge/lcd4linux/${P}.tar.gz
http://branched.modestolan.com/${P}-cf634.diff"
-HOMEPAGE="http://lcd4linux.sourceforge.net/"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
IUSE="kde pda png X usb"
DEPEND="png? ( media-libs/libpng
- sys-libs/zlib
- media-libs/libgd )"
+ sys-libs/zlib
+ media-libs/libgd )"
src_unpack() {
unpack ${P}.tar.gz
cd ${S}
epatch ${DISTDIR}/${P}-cf634.diff
}
+
src_compile() {
local myconf
-
use png || myconf=",!PNG"
use pda || myconf="${myconf},!PalmPilot"
use X || myconf="${myconf},!X11"
use usb || myconf="${myconf},!USBLCD"
-
econf \
--sysconfdir=/etc/lcd4linux \
- --with-drivers="all${myconf},!PNG"
+ --with-drivers="all${myconf},!PNG" \
+ || die
emake || die
}
src_install() {
CONFIG_PROTECT="${CONFIG_PROTECT} /etc/lcd4linux"
- einstall
+ einstall || die
insinto /etc/lcd4linux
cp lcd4linux.conf.sample lcd4linux.conf
@@ -47,7 +49,7 @@ src_install() {
dodoc README* NEWS COPYING INSTALL TODO CREDITS FAQ
dodoc lcd4linux.conf.sample lcd4linux.kdelnk lcd4linux.xpm
- if [ `use kde` ] ; then
+ if use kde ; then
insinto /etc/lcd4linux
insopts -o root -g root -m 0600
doins lcd4kde.conf
diff --git a/app-misc/lcdproc/lcdproc-0.4.3-r2.ebuild b/app-misc/lcdproc/lcdproc-0.4.3-r2.ebuild
index 99d40d110e86..473071d4a730 100644
--- a/app-misc/lcdproc/lcdproc-0.4.3-r2.ebuild
+++ b/app-misc/lcdproc/lcdproc-0.4.3-r2.ebuild
@@ -1,13 +1,15 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lcdproc/lcdproc-0.4.3-r2.ebuild,v 1.6 2004/03/08 20:47:24 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lcdproc/lcdproc-0.4.3-r2.ebuild,v 1.7 2004/04/06 04:19:50 vapier Exp $
+
+inherit eutils
-SRC_URI="mirror://sourceforge/lcdproc/${P}.tar.gz"
DESCRIPTION="Client/Server suite to drive all kinds of LCD (-like) devices"
HOMEPAGE="http://lcdproc.org/"
+SRC_URI="mirror://sourceforge/lcdproc/${P}.tar.gz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86 amd64"
IUSE="doc ncurses svga"
@@ -28,7 +30,6 @@ src_unpack() {
}
src_compile() {
-
# By default, all drivers that are supported by the given plattform/hardware
# are compiled (of course respecting the existing USE flags). If the
# LCDPROC_DRIVERS environment variable is set to a comma separated list, only
@@ -62,7 +63,7 @@ src_compile() {
econf ${myconf} || die
emake || die
- if [ `use doc` ]; then
+ if use doc ; then
cd ${S}/docs/lcdproc-user
docbook2html lcdproc-user.docbook
fi
@@ -74,9 +75,9 @@ src_install() {
doman docs/lcdproc.1 docs/LCDd.8
- dodoc README ChangeLog COPYING INSTALL
+ dodoc README ChangeLog INSTALL
- if [ `use doc` ]; then
+ if use doc ; then
insinto /usr/share/doc/${PF}/lcdproc-user
doins docs/lcdproc-user/*.html
fi
diff --git a/app-misc/linup/linup-1.1.1-r1.ebuild b/app-misc/linup/linup-1.1.1-r1.ebuild
index f27d238350ba..5c51bde620a2 100644
--- a/app-misc/linup/linup-1.1.1-r1.ebuild
+++ b/app-misc/linup/linup-1.1.1-r1.ebuild
@@ -1,18 +1,20 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/linup/linup-1.1.1-r1.ebuild,v 1.2 2004/03/14 10:59:03 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/linup/linup-1.1.1-r1.ebuild,v 1.3 2004/04/06 04:20:08 vapier Exp $
+
+inherit eutils
DESCRIPTION="Linux Uptime Client"
HOMEPAGE="ftp://ftp.smux.net/people/sena/linup/"
SRC_URI="ftp://ftp.smux.net/people/sena/linup/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="x86"
-IUSE=""
RDEPEND="virtual/glibc"
-S="${WORKDIR}/${PN}"
+S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
@@ -24,9 +26,9 @@ src_compile() {
emake || die "compile problem"
}
-src_install () {
- dobin linup
- dodoc COPYING README
+src_install() {
+ dobin linup || die
+ dodoc README
}
pkg_postinst() {
diff --git a/app-misc/magicdev/magicdev-1.1.4.ebuild b/app-misc/magicdev/magicdev-1.1.4.ebuild
index 27e256f11591..c5cbec1cfe16 100644
--- a/app-misc/magicdev/magicdev-1.1.4.ebuild
+++ b/app-misc/magicdev/magicdev-1.1.4.ebuild
@@ -1,34 +1,32 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/magicdev/magicdev-1.1.4.ebuild,v 1.3 2004/01/16 03:21:46 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/magicdev/magicdev-1.1.4.ebuild,v 1.4 2004/04/06 04:20:43 vapier Exp $
-inherit gnome2
+inherit gnome2 eutils
RPM_V="7"
-DESCRIPTION="A GNOME tool to automount/unmount removable media."
+DESCRIPTION="A GNOME tool to automount/unmount removable media"
HOMEPAGE="http://www.gnome.org/"
SRC_URI="ftp://ftp.redhat.com/pub/redhat/linux/beta/severn/en/os/i386/SRPMS/${P}-${RPM_V}.src.rpm"
-LICENSE="GPL-2"
-DOCS="AUTHORS ChangeLog COPYING README"
+LICENSE="GPL-2"
SLOT="0"
-IUSE=""
KEYWORDS="x86"
+
RDEPEND=">=gnome-base/libgnomeui-2.1.90
>=gnome-base/libglade-2
>=x11-libs/gtk+-2
>=gnome-base/gconf-2"
-
DEPEND="${RDEPEND}
app-arch/rpm2targz"
+DOCS="AUTHORS ChangeLog README"
+
src_unpack() {
- cd ${WORKDIR}
rpm2targz ${DISTDIR}/${P}-${RPM_V}.src.rpm
- tar zxf ${P}-${RPM_V}.src.tar.gz
- tar zxf ${P}.tar.gz
+ unpack ${P}-${RPM_V}.src.tar.gz
+ unpack ${P}.tar.gz
epatch magicdev-1.1.4-O_EXCL.patch
epatch magicdev-1.1.4-blacklist.patch
}
-
diff --git a/app-misc/mc/mc-4.6.0-r3.ebuild b/app-misc/mc/mc-4.6.0-r3.ebuild
index 0eb845ae08d2..ec255b362515 100644
--- a/app-misc/mc/mc-4.6.0-r3.ebuild
+++ b/app-misc/mc/mc-4.6.0-r3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.6.0-r3.ebuild,v 1.13 2004/03/14 10:52:01 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.6.0-r3.ebuild,v 1.14 2004/04/06 04:20:51 vapier Exp $
-inherit flag-o-matic
+inherit flag-o-matic eutils
IUSE="gpm nls samba ncurses X slang"
diff --git a/app-misc/mc/mc-4.6.0-r4.ebuild b/app-misc/mc/mc-4.6.0-r4.ebuild
index 6829361be6b0..99be68941d93 100644
--- a/app-misc/mc/mc-4.6.0-r4.ebuild
+++ b/app-misc/mc/mc-4.6.0-r4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.6.0-r4.ebuild,v 1.7 2004/03/14 10:52:01 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.6.0-r4.ebuild,v 1.8 2004/04/06 04:20:58 vapier Exp $
-inherit flag-o-matic
+inherit flag-o-matic eutils
IUSE="gpm nls samba ncurses X slang"
diff --git a/app-misc/mc/mc-4.6.0-r5.ebuild b/app-misc/mc/mc-4.6.0-r5.ebuild
index 663e246f8673..8464a6babda9 100644
--- a/app-misc/mc/mc-4.6.0-r5.ebuild
+++ b/app-misc/mc/mc-4.6.0-r5.ebuild
@@ -1,10 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.6.0-r5.ebuild,v 1.1 2004/03/29 10:46:26 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mc/mc-4.6.0-r5.ebuild,v 1.2 2004/04/06 04:22:43 vapier Exp $
-inherit flag-o-matic
-
-IUSE="gpm nls samba ncurses X slang"
+inherit flag-o-matic eutils
DESCRIPTION="GNU Midnight Commander cli-based file manager"
HOMEPAGE="http://www.ibiblio.org/mc/"
@@ -12,6 +10,11 @@ SRC_URI="http://www.ibiblio.org/pub/Linux/utils/file/managers/${PN}/${P}.tar.gz
http://www.spock.mga.com.pl/public/gentoo/${P}-sambalib-3.0.0.patch.bz2
http://www.spock.mga.com.pl/public/gentoo/${P}-sambalib.patch.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ia64 x86 ppc sparc alpha mips hppa amd64"
+IUSE="gpm nls samba ncurses X slang"
+
DEPEND=">=sys-fs/e2fsprogs-1.19
ncurses? ( >=sys-libs/ncurses-5.2-r5 )
=dev-libs/glib-2*
@@ -21,12 +24,6 @@ DEPEND=">=sys-fs/e2fsprogs-1.19
samba? ( net-fs/samba )
X? ( virtual/x11 )"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="ia64 x86 ppc sparc alpha mips hppa amd64"
-
-filter-flags -malign-double
-
src_unpack() {
unpack ${P}.tar.gz
cd ${S}
@@ -41,30 +38,25 @@ src_unpack() {
}
src_compile() {
+ filter-flags -malign-double
+
local myconf=""
- if ! use slang && ! use ncurses
- then
+ if ! use slang && ! use ncurses ; then
myconf="${myconf} --with-screen=mcslang"
- elif
- use ncurses && ! use slang
- then
+ elif use ncurses && ! use slang ; then
myconf="${myconf} --with-screen=ncurses"
- else
+ else
use slang && myconf="${myconf} --with-screen=slang"
fi
- use gpm \
- && myconf="${myconf} --with-gpm-mouse" \
- || myconf="${myconf} --without-gpm-mouse"
+ myconf="${myconf} `use_with gpm gpm-mouse`"
use nls \
&& myconf="${myconf} --with-included-gettext" \
|| myconf="${myconf} --disable-nls"
- use X \
- && myconf="${myconf} --with-x" \
- || myconf="${myconf} --without-x"
+ myconf="${myconf} `use_with X x`"
use samba \
&& myconf="${myconf} --with-samba --with-configdir=/etc/samba
@@ -84,11 +76,11 @@ src_compile() {
src_install() {
cat ${FILESDIR}/chdir-4.6.0.gentoo >>\
- ${S}/lib/mc-wrapper.sh
+ ${S}/lib/mc-wrapper.sh
einstall || die
- dodoc ABOUT-NLS COPYING* ChangeLog AUTHORS MAINTAINERS FAQ INSTALL* NEWS README*
+ dodoc ChangeLog AUTHORS MAINTAINERS FAQ INSTALL* NEWS README*
insinto /usr/share/mc
doins ${FILESDIR}/mc.gentoo
diff --git a/app-misc/mtail/mtail-1.1.1-r1.ebuild b/app-misc/mtail/mtail-1.1.1-r1.ebuild
index 76d02561db23..71630d992186 100644
--- a/app-misc/mtail/mtail-1.1.1-r1.ebuild
+++ b/app-misc/mtail/mtail-1.1.1-r1.ebuild
@@ -1,29 +1,28 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mtail/mtail-1.1.1-r1.ebuild,v 1.5 2004/02/16 21:46:32 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mtail/mtail-1.1.1-r1.ebuild,v 1.6 2004/04/06 04:23:08 vapier Exp $
+
+inherit eutils
DESCRIPTION="tail workalike, that performs output colourising"
HOMEPAGE="http://matt.immute.net/src/mtail/"
SRC_URI="http://matt.immute.net/src/mtail/mtail-${PV}.tgz
http://matt.immute.net/src/mtail/mtailrc-syslog.sample"
-LICENSE="as-is"
+LICENSE="as-is"
SLOT="0"
KEYWORDS="x86 alpha sparc amd64 ~mips"
-IUSE=""
DEPEND=""
-
RDEPEND="dev-lang/python"
-S=${WORKDIR}/${P}
-
src_unpack() {
unpack ${P}.tgz
- cd ${S}; epatch ${FILESDIR}/${P}-remove-blanks.patch
+ cd ${S}
+ epatch ${FILESDIR}/${P}-remove-blanks.patch
}
src_install() {
dobin mtail
- dodoc CHANGES LICENSE mtailrc.sample README ${DISTDIR}/mtailrc-syslog.sample
+ dodoc CHANGES mtailrc.sample README ${DISTDIR}/mtailrc-syslog.sample
}
diff --git a/app-misc/mwavem/mwavem-1.0.4.ebuild b/app-misc/mwavem/mwavem-1.0.4.ebuild
index 450a31eef868..5e8bb330bfe7 100644
--- a/app-misc/mwavem/mwavem-1.0.4.ebuild
+++ b/app-misc/mwavem/mwavem-1.0.4.ebuild
@@ -1,16 +1,17 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mwavem/mwavem-1.0.4.ebuild,v 1.1 2004/01/12 23:04:47 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mwavem/mwavem-1.0.4.ebuild,v 1.2 2004/04/06 04:23:28 vapier Exp $
+
+inherit eutils
-S=${WORKDIR}/${P}
DESCRIPTION="User level application for IBM Mwave modem"
HOMEPAGE="http://oss.software.ibm.com/acpmodem/"
SRC_URI="ftp://www-126.ibm.com/pub/acpmodem/1.0.4/${P}.tar.gz"
-IUSE="X"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86"
+IUSE="X"
DEPEND="virtual/glibc
X? ( virtual/x11 )"
diff --git a/app-misc/screen/screen-4.0.1-r2.ebuild b/app-misc/screen/screen-4.0.1-r2.ebuild
index cf05e36110c4..798cb653c159 100644
--- a/app-misc/screen/screen-4.0.1-r2.ebuild
+++ b/app-misc/screen/screen-4.0.1-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/screen/screen-4.0.1-r2.ebuild,v 1.8 2004/04/04 04:12:47 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/screen/screen-4.0.1-r2.ebuild,v 1.9 2004/04/06 04:24:01 vapier Exp $
-inherit flag-o-matic
+inherit flag-o-matic eutils
DESCRIPTION="Screen is a full-screen window manager that multiplexes a physical terminal between several processes"
HOMEPAGE="http://www.guckes.net/screen/ http://www.gnu.org/software/screen/"
@@ -82,7 +82,7 @@ src_compile() {
emake || die "emake failed"
}
-src_install () {
+src_install() {
dobin screen || die "dobin failed"
keepdir /var/run/screen
fowners root:utmp /{usr/bin,var/run}/screen
@@ -106,7 +106,7 @@ src_install () {
}
pkg_postinst() {
- chmod 0775 /var/run/screen
+ chmod 0775 ${ROOT}/var/run/screen
einfo "Some dangerous key bindings have been removed or changed to more safe values."
einfo "For more info, please check /etc/screenrc"