summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/dictd-devils/dictd-devils-0.ebuild10
-rw-r--r--app-text/dictd-elements/dictd-elements-2000.22.07.ebuild9
-rw-r--r--app-text/dictd-foldoc/dictd-foldoc-2001.03.13.ebuild9
-rw-r--r--app-text/dictd-gazetteer/dictd-gazetteer-1.2.ebuild9
-rw-r--r--app-text/dictd-jargon/dictd-jargon-4.2.3.ebuild9
-rw-r--r--app-text/dictd-misc/dictd-misc-1.5b.ebuild10
-rw-r--r--app-text/dictd-vera/dictd-vera-1.7.ebuild9
-rw-r--r--app-text/dictd-web1913/dictd-web1913-1.4.ebuild9
-rw-r--r--app-text/dictd-wn/dictd-wn-1.5.ebuild10
-rw-r--r--app-text/dictd/dictd-1.5.5.ebuild10
10 files changed, 76 insertions, 18 deletions
diff --git a/app-text/dictd-devils/dictd-devils-0.ebuild b/app-text/dictd-devils/dictd-devils-0.ebuild
index 2ae4deaae7d1..942b6f7539b3 100644
--- a/app-text/dictd-devils/dictd-devils-0.ebuild
+++ b/app-text/dictd-devils/dictd-devils-0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Michael Conrad Tilstra <michael@gentoo.org> <tadpol@tadpol.org>
-# $Header: /var/cvsroot/gentoo-x86/app-text/dictd-devils/dictd-devils-0.ebuild,v 1.1 2001/04/24 22:07:29 michael Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dictd-devils/dictd-devils-0.ebuild,v 1.2 2001/04/24 22:58:35 michael Exp $
#P=
A=devils-dict-pre.tar.gz
@@ -25,6 +25,14 @@ cat >> /etc/dict/dictd.conf << __EOF__
database devils { data "/usr/lib/dict/devils.dict.dz"
index "/usr/lib/dict/devils.index" }
__EOF__
+fi
+}
+
+pkg_postrm() {
+if [ -f /etc/dict/dictd.conf ]; then
+ cat /etc/dict/dictd.conf | sed -e '/devils/d' > /etc/dict/dictd.conf.$$
+ mv /etc/dict/dictd.conf.$$ /etc/dict/dictd.conf
+fi
}
# vim: ai et sw=4 ts=4
diff --git a/app-text/dictd-elements/dictd-elements-2000.22.07.ebuild b/app-text/dictd-elements/dictd-elements-2000.22.07.ebuild
index beb772426b02..2ea6c0c519fc 100644
--- a/app-text/dictd-elements/dictd-elements-2000.22.07.ebuild
+++ b/app-text/dictd-elements/dictd-elements-2000.22.07.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Michael Conrad Tilstra <michael@gentoo.org> <tadpol@tadpol.org>
-# $Header: /var/cvsroot/gentoo-x86/app-text/dictd-elements/dictd-elements-2000.22.07.ebuild,v 1.1 2001/04/24 22:07:29 michael Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dictd-elements/dictd-elements-2000.22.07.ebuild,v 1.2 2001/04/24 22:58:35 michael Exp $
#P=
A=elements-20001107-pre.tar.gz
@@ -28,4 +28,11 @@ __EOF__
fi
}
+pkg_postrm() {
+if [ -f /etc/dict/dictd.conf ]; then
+ cat /etc/dict/dictd.conf | sed -e '/elements/d' > /etc/dict/dictd.conf.$$
+ mv /etc/dict/dictd.conf.$$ /etc/dict/dictd.conf
+fi
+}
+
# vim: ai et sw=4 ts=4
diff --git a/app-text/dictd-foldoc/dictd-foldoc-2001.03.13.ebuild b/app-text/dictd-foldoc/dictd-foldoc-2001.03.13.ebuild
index cacb1ea0fca0..c09ff3d5d0e1 100644
--- a/app-text/dictd-foldoc/dictd-foldoc-2001.03.13.ebuild
+++ b/app-text/dictd-foldoc/dictd-foldoc-2001.03.13.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Michael Conrad Tilstra <michael@gentoo.org> <tadpol@tadpol.org>
-# $Header: /var/cvsroot/gentoo-x86/app-text/dictd-foldoc/dictd-foldoc-2001.03.13.ebuild,v 1.1 2001/04/24 22:07:29 michael Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dictd-foldoc/dictd-foldoc-2001.03.13.ebuild,v 1.2 2001/04/24 22:58:35 michael Exp $
#P=
A=foldoc-20010313.tar.gz
@@ -28,5 +28,12 @@ __EOF__
fi
}
+pkg_postrm() {
+if [ -f /etc/dict/dictd.conf ]; then
+ cat /etc/dict/dictd.conf | sed -e '/foldoc/d' > /etc/dict/dictd.conf.$$
+ mv /etc/dict/dictd.conf.$$ /etc/dict/dictd.conf
+fi
+}
+
# vim: ai et sw=4 ts=4
diff --git a/app-text/dictd-gazetteer/dictd-gazetteer-1.2.ebuild b/app-text/dictd-gazetteer/dictd-gazetteer-1.2.ebuild
index de073f9d368b..673f1b12b1b3 100644
--- a/app-text/dictd-gazetteer/dictd-gazetteer-1.2.ebuild
+++ b/app-text/dictd-gazetteer/dictd-gazetteer-1.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Michael Conrad Tilstra <michael@gentoo.org> <tadpol@tadpol.org>
-# $Header: /var/cvsroot/gentoo-x86/app-text/dictd-gazetteer/dictd-gazetteer-1.2.ebuild,v 1.1 2001/04/24 22:07:29 michael Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dictd-gazetteer/dictd-gazetteer-1.2.ebuild,v 1.2 2001/04/24 22:58:35 michael Exp $
#P=
A=dict-gazetteer-1.2-pre.tar.gz
@@ -28,5 +28,12 @@ __EOF__
fi
}
+pkg_postrm() {
+if [ -f /etc/dict/dictd.conf ]; then
+ cat /etc/dict/dictd.conf | sed -e '/gazetteer/d' > /etc/dict/dictd.conf.$$
+ mv /etc/dict/dictd.conf.$$ /etc/dict/dictd.conf
+fi
+}
+
# vim: ai et sw=4 ts=4
diff --git a/app-text/dictd-jargon/dictd-jargon-4.2.3.ebuild b/app-text/dictd-jargon/dictd-jargon-4.2.3.ebuild
index 72e2706d8b6f..078669a1e1b7 100644
--- a/app-text/dictd-jargon/dictd-jargon-4.2.3.ebuild
+++ b/app-text/dictd-jargon/dictd-jargon-4.2.3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Michael Conrad Tilstra <michael@gentoo.org> <tadpol@tadpol.org>
-# $Header: /var/cvsroot/gentoo-x86/app-text/dictd-jargon/dictd-jargon-4.2.3.ebuild,v 1.1 2001/04/24 22:07:29 michael Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dictd-jargon/dictd-jargon-4.2.3.ebuild,v 1.2 2001/04/24 22:58:35 michael Exp $
#P=
A=jargon_4.2.3.tar.gz
@@ -29,5 +29,12 @@ __EOF__
fi
}
+pkg_postrm() {
+if [ -f /etc/dict/dictd.conf ]; then
+ cat /etc/dict/dictd.conf | sed -e '/jargon/d' > /etc/dict/dictd.conf.$$
+ mv /etc/dict/dictd.conf.$$ /etc/dict/dictd.conf
+fi
+}
+
# vim: ai et sw=4 ts=4
diff --git a/app-text/dictd-misc/dictd-misc-1.5b.ebuild b/app-text/dictd-misc/dictd-misc-1.5b.ebuild
index 2e058a32f128..f208f55e5a48 100644
--- a/app-text/dictd-misc/dictd-misc-1.5b.ebuild
+++ b/app-text/dictd-misc/dictd-misc-1.5b.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Michael Conrad Tilstra <michael@gentoo.org> <tadpol@tadpol.org>
-# $Header: /var/cvsroot/gentoo-x86/app-text/dictd-misc/dictd-misc-1.5b.ebuild,v 1.1 2001/04/24 22:07:29 michael Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dictd-misc/dictd-misc-1.5b.ebuild,v 1.2 2001/04/24 22:58:35 michael Exp $
#P=
A=dict-misc-1.5b-pre.tar.gz
@@ -36,5 +36,13 @@ __EOF__
fi
}
+pkg_postrm() {
+if [ -f /etc/dict/dictd.conf ]; then
+ cat /etc/dict/dictd.conf | sed -e '/easton/d' -e '/hitchcock/d' \
+ -e '/world95/d' > /etc/dict/dictd.conf.$$
+ mv /etc/dict/dictd.conf.$$ /etc/dict/dictd.conf
+fi
+}
+
# vim: ai et sw=4 ts=4
diff --git a/app-text/dictd-vera/dictd-vera-1.7.ebuild b/app-text/dictd-vera/dictd-vera-1.7.ebuild
index f50a62557524..9ca3ca8bcbaa 100644
--- a/app-text/dictd-vera/dictd-vera-1.7.ebuild
+++ b/app-text/dictd-vera/dictd-vera-1.7.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Michael Conrad Tilstra <michael@gentoo.org> <tadpol@tadpol.org>
-# $Header: /var/cvsroot/gentoo-x86/app-text/dictd-vera/dictd-vera-1.7.ebuild,v 1.1 2001/04/24 22:07:29 michael Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dictd-vera/dictd-vera-1.7.ebuild,v 1.2 2001/04/24 22:58:35 michael Exp $
#P=
A=vera_1.7.tar.gz
@@ -28,5 +28,12 @@ __EOF__
fi
}
+pkg_postrm() {
+if [ -f /etc/dict/dictd.conf ]; then
+ cat /etc/dict/dictd.conf | sed -e '/vera/d' > /etc/dict/dictd.conf.$$
+ mv /etc/dict/dictd.conf.$$ /etc/dict/dictd.conf
+fi
+}
+
# vim: ai et sw=4 ts=4
diff --git a/app-text/dictd-web1913/dictd-web1913-1.4.ebuild b/app-text/dictd-web1913/dictd-web1913-1.4.ebuild
index e4ff8de27bc3..29dd840b087f 100644
--- a/app-text/dictd-web1913/dictd-web1913-1.4.ebuild
+++ b/app-text/dictd-web1913/dictd-web1913-1.4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Michael Conrad Tilstra <michael@gentoo.org> <tadpol@tadpol.org>
-# $Header: /var/cvsroot/gentoo-x86/app-text/dictd-web1913/dictd-web1913-1.4.ebuild,v 1.1 2001/04/24 22:07:29 michael Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dictd-web1913/dictd-web1913-1.4.ebuild,v 1.2 2001/04/24 22:58:35 michael Exp $
#P=
A=dict-web1913-1.4-pre.tar.gz
@@ -28,5 +28,12 @@ __EOF__
fi
}
+pkg_postrm() {
+if [ -f /etc/dict/dictd.conf ]; then
+ cat /etc/dict/dictd.conf | sed -e '/web1913/d' > /etc/dict/dictd.conf.$$
+ mv /etc/dict/dictd.conf.$$ /etc/dict/dictd.conf
+fi
+}
+
# vim: ai et sw=4 ts=4
diff --git a/app-text/dictd-wn/dictd-wn-1.5.ebuild b/app-text/dictd-wn/dictd-wn-1.5.ebuild
index 6d38a38b56bf..7081fb16f21c 100644
--- a/app-text/dictd-wn/dictd-wn-1.5.ebuild
+++ b/app-text/dictd-wn/dictd-wn-1.5.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Michael Conrad Tilstra <michael@gentoo.org> <tadpol@tadpol.org>
-# $Header: /var/cvsroot/gentoo-x86/app-text/dictd-wn/dictd-wn-1.5.ebuild,v 1.1 2001/04/24 22:07:29 michael Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dictd-wn/dictd-wn-1.5.ebuild,v 1.2 2001/04/24 22:58:35 michael Exp $
#P=
A=dict-wn-1.5-pre.tar.gz
@@ -28,5 +28,13 @@ __EOF__
fi
}
+pkg_postrm() {
+if [ -f /etc/dict/dictd.conf ]; then
+ cat /etc/dict/dictd.conf | sed -e '/wn.dict/d' -e '/wn.index/d' \
+ > /etc/dict/dictd.conf.$$
+ mv /etc/dict/dictd.conf.$$ /etc/dict/dictd.conf
+fi
+}
+
# vim: ai et sw=4 ts=4
diff --git a/app-text/dictd/dictd-1.5.5.ebuild b/app-text/dictd/dictd-1.5.5.ebuild
index 387c8f8593ef..a59208c17410 100644
--- a/app-text/dictd/dictd-1.5.5.ebuild
+++ b/app-text/dictd/dictd-1.5.5.ebuild
@@ -1,21 +1,13 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Michael Conrad Tilstra <michael@gentoo.org> <tadpol@tadpol.org>
-# $header$
+# $Header: /var/cvsroot/gentoo-x86/app-text/dictd/dictd-1.5.5.ebuild,v 1.2 2001/04/24 22:58:35 michael Exp $
#P=
A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="Dictionary Client/Server for the DICT protocol"
SRC_URI="ftp://ftp.dict.org/pub/dict/${A}"
-# ftp://ftp.dict.org/pub/dict/dict-web1913-1.4-pre.tar.gz
-# ftp://ftp.dict.org/pub/dict/dict-wn-1.5-pre.tar.gz
-# ftp://ftp.dict.org/pub/dict/jargon_4.2.3.tar.gz
-# ftp://ftp.dict.org/pub/dict/devils-dict-pre.tar.gz
-# ftp://ftp.dict.org/pub/dict/dict-gazetteer-1.2-pre.tar.gz
-# ftp://ftp.dict.org/pub/dict/dict-misc-1.5b-pre.tar.gz
-# ftp://ftp.dict.org/pub/dict/elements-20001107-pre.tar.gz
-# ftp://ftp.dict.org/pub/dict/vera_1.7.tar.gz"
HOMEPAGE="http://www.dict.org"
DEPEND="virtual/glibc