summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/pidgin/ChangeLog9
-rw-r--r--net-im/pidgin/files/pidgin-2.10.9-fix-gtkmedia.patch10
-rw-r--r--net-im/pidgin/files/pidgin-2.10.9-python3_fix1.patch28
-rw-r--r--net-im/pidgin/files/pidgin-2.10.9-python3_fix2.patch32
-rw-r--r--net-im/pidgin/pidgin-2.10.9-r1.ebuild8
-rw-r--r--net-im/pidgin/pidgin-2.10.9.ebuild8
6 files changed, 88 insertions, 7 deletions
diff --git a/net-im/pidgin/ChangeLog b/net-im/pidgin/ChangeLog
index 1ce230343621..533d864c33be 100644
--- a/net-im/pidgin/ChangeLog
+++ b/net-im/pidgin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-im/pidgin
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/ChangeLog,v 1.332 2014/02/18 06:51:10 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/ChangeLog,v 1.333 2014/02/18 08:11:43 polynomial-c Exp $
+
+ 18 Feb 2014; Lars Wendler <polynomial-c@gentoo.org> pidgin-2.10.9.ebuild,
+ pidgin-2.10.9-r1.ebuild, +files/pidgin-2.10.9-fix-gtkmedia.patch,
+ +files/pidgin-2.10.9-python3_fix1.patch,
+ +files/pidgin-2.10.9-python3_fix2.patch:
+ Fixed compilation with python3 (bug #499760) and some undefined reference to
+ gtkmedia (bug #500762).
18 Feb 2014; Pacho Ramos <pacho@gentoo.org> pidgin-2.10.9-r1.ebuild:
Use subslots for net-libs/farsight2 dep (#479326)
diff --git a/net-im/pidgin/files/pidgin-2.10.9-fix-gtkmedia.patch b/net-im/pidgin/files/pidgin-2.10.9-fix-gtkmedia.patch
new file mode 100644
index 000000000000..4cec32663808
--- /dev/null
+++ b/net-im/pidgin/files/pidgin-2.10.9-fix-gtkmedia.patch
@@ -0,0 +1,10 @@
+--- a/pidgin/Makefile.am 2014-02-02 22:29:20.000000000 +0100
++++ b/pidgin/Makefile.am 2014-02-14 19:35:24.347547795 +0100
+@@ -154,6 +154,7 @@
+ $(GSTREAMER_LIBS) \
+ $(XSS_LIBS) \
+ $(SM_LIBS) \
++ $(X11_LIBS) \
+ $(INTLLIBS) \
+ $(GTKSPELL_LIBS) \
+ $(LIBXML_LIBS) \
diff --git a/net-im/pidgin/files/pidgin-2.10.9-python3_fix1.patch b/net-im/pidgin/files/pidgin-2.10.9-python3_fix1.patch
new file mode 100644
index 000000000000..67e94312f770
--- /dev/null
+++ b/net-im/pidgin/files/pidgin-2.10.9-python3_fix1.patch
@@ -0,0 +1,28 @@
+
+# HG changeset patch
+# User Ed Catmur <ed@catmur.co.uk>
+# Date 1392340585 18000
+# Node ID c8bb4edd63253b5b23006e8674c015c854075981
+# Parent eeb82d3d33b1720024ee7aef9bdfba87bb1b163d
+Fix build of Finch against Python3.
+
+Fixes #15969.
+
+diff --git a/finch/libgnt/gntwm.c b/finch/libgnt/gntwm.c
+--- a/finch/libgnt/gntwm.c
++++ b/finch/libgnt/gntwm.c
+@@ -1281,7 +1281,12 @@
+ {
+ char *dir = g_path_get_dirname(path);
+ FILE *file = fopen(path, "r");
+- PyObject *pp = PySys_GetObject("path"), *dirobj = PyString_FromString(dir);
++ PyObject *pp = PySys_GetObject("path");
++#if PY_MAJOR_VERSION >= 3
++ PyObject *dirobj = PyUnicode_FromString(dir);
++#else
++ PyObject *dirobj = PyString_FromString(dir);
++#endif
+
+ PyList_Insert(pp, 0, dirobj);
+ Py_DECREF(dirobj);
+
diff --git a/net-im/pidgin/files/pidgin-2.10.9-python3_fix2.patch b/net-im/pidgin/files/pidgin-2.10.9-python3_fix2.patch
new file mode 100644
index 000000000000..06ccaef7175f
--- /dev/null
+++ b/net-im/pidgin/files/pidgin-2.10.9-python3_fix2.patch
@@ -0,0 +1,32 @@
+
+# HG changeset patch
+# User Elliott Sales de Andrade <qulogic@pidgin.im>
+# Date 1392341598 18000
+# Node ID 922e7abddb4dbc1a397aad9c1d3b6fd091c4e392
+# Parent a591c0486b041e029075e12b446430cf32b27d24
+Fix call to Py_SetProgramName in Python3.
+
+Refs #15969.
+
+diff --git a/finch/libgnt/gntwm.c b/finch/libgnt/gntwm.c
+--- a/finch/libgnt/gntwm.c
++++ b/finch/libgnt/gntwm.c
+@@ -1577,7 +1577,17 @@
+ gnt_bindable_class_register_action(GNT_BINDABLE_CLASS(klass), "run-python", run_python,
+ GNT_KEY_F3, NULL);
+ if (!Py_IsInitialized()) {
++#if PY_MAJOR_VERSION >= 3
++ wchar_t *name;
++ size_t len;
++ len = mbstowcs(NULL, "gnt", 0);
++ name = g_new(wchar_t, len + 1);
++ mbstowcs(name, "gnt", len + 1);
++ Py_SetProgramName(name);
++ g_free(name);
++#else
+ Py_SetProgramName("gnt");
++#endif
+ Py_Initialize();
+ started_python = TRUE;
+ }
+
diff --git a/net-im/pidgin/pidgin-2.10.9-r1.ebuild b/net-im/pidgin/pidgin-2.10.9-r1.ebuild
index df2f836851e6..1f3c18b654e6 100644
--- a/net-im/pidgin/pidgin-2.10.9-r1.ebuild
+++ b/net-im/pidgin/pidgin-2.10.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.10.9-r1.ebuild,v 1.6 2014/02/18 06:51:10 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.10.9-r1.ebuild,v 1.7 2014/02/18 08:11:43 polynomial-c Exp $
EAPI=5
@@ -138,8 +138,10 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}/${PN}-2.10.0-gold.patch" \
- "${WORKDIR}/${PN}-eds-3.6.patch"
-
+ "${WORKDIR}/${PN}-eds-3.6.patch" \
+ "${FILESDIR}/${P}-fix-gtkmedia.patch" \
+ "${FILESDIR}/${P}-python3_fix1.patch" \
+ "${FILESDIR}/${P}-python3_fix2.patch"
epatch_user
eautoreconf
diff --git a/net-im/pidgin/pidgin-2.10.9.ebuild b/net-im/pidgin/pidgin-2.10.9.ebuild
index 76f3bd92f200..3e89af8715e6 100644
--- a/net-im/pidgin/pidgin-2.10.9.ebuild
+++ b/net-im/pidgin/pidgin-2.10.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.10.9.ebuild,v 1.9 2014/02/16 12:05:34 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.10.9.ebuild,v 1.10 2014/02/18 08:11:43 polynomial-c Exp $
EAPI=5
@@ -136,8 +136,10 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}/${PN}-2.10.0-gold.patch"
-
+ epatch "${FILESDIR}/${PN}-2.10.0-gold.patch" \
+ "${FILESDIR}/${P}-fix-gtkmedia.patch" \
+ "${FILESDIR}/${P}-python3_fix1.patch" \
+ "${FILESDIR}/${P}-python3_fix2.patch"
epatch_user
eautoreconf