summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-block/rts5229/ChangeLog8
-rw-r--r--sys-block/rts5229/files/rts5229-linux-3.8.patch29
-rw-r--r--sys-block/rts5229/rts5229-1.07-r1.ebuild34
3 files changed, 70 insertions, 1 deletions
diff --git a/sys-block/rts5229/ChangeLog b/sys-block/rts5229/ChangeLog
index 8fe8b6faa54d..3a20a11bbf89 100644
--- a/sys-block/rts5229/ChangeLog
+++ b/sys-block/rts5229/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-block/rts5229
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-block/rts5229/ChangeLog,v 1.1 2013/02/28 17:39:19 vikraman Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-block/rts5229/ChangeLog,v 1.2 2013/05/28 19:50:51 vikraman Exp $
+
+*rts5229-1.07-r1 (28 May 2013)
+
+ 28 May 2013; Vikraman <vikraman@gentoo.org> +rts5229-1.07-r1.ebuild,
+ +files/rts5229-linux-3.8.patch:
+ Patch to fix build on linux 3.8
*rts5229-1.07 (28 Feb 2013)
diff --git a/sys-block/rts5229/files/rts5229-linux-3.8.patch b/sys-block/rts5229/files/rts5229-linux-3.8.patch
new file mode 100644
index 000000000000..81779aef2767
--- /dev/null
+++ b/sys-block/rts5229/files/rts5229-linux-3.8.patch
@@ -0,0 +1,29 @@
+--- rts5229.a/rtsx.c 2012-03-21 07:10:18.000000000 +0530
++++ rts5229.b/rtsx.c 2013-05-29 01:06:32.333737569 +0530
+@@ -911,7 +911,7 @@
+ chip->support_mmc = 1;
+ }
+
+-static int __devinit rtsx_probe(struct pci_dev *pci, const struct pci_device_id *pci_id)
++static int rtsx_probe(struct pci_dev *pci, const struct pci_device_id *pci_id)
+ {
+ struct Scsi_Host *host;
+ struct rtsx_dev *dev;
+@@ -1066,7 +1066,7 @@
+ }
+
+
+-static void __devexit rtsx_remove(struct pci_dev *pci)
++static void rtsx_remove(struct pci_dev *pci)
+ {
+ struct rtsx_dev *dev = (struct rtsx_dev *)pci_get_drvdata(pci);
+
+@@ -1092,7 +1092,7 @@
+ .name = CR_DRIVER_NAME,
+ .id_table = rts5229_ids,
+ .probe = rtsx_probe,
+- .remove = __devexit_p(rtsx_remove),
++ .remove = rtsx_remove,
+ #ifdef CONFIG_PM
+ .suspend = rtsx_suspend,
+ .resume = rtsx_resume,
diff --git a/sys-block/rts5229/rts5229-1.07-r1.ebuild b/sys-block/rts5229/rts5229-1.07-r1.ebuild
new file mode 100644
index 000000000000..bc2aa26e64bf
--- /dev/null
+++ b/sys-block/rts5229/rts5229-1.07-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-block/rts5229/rts5229-1.07-r1.ebuild,v 1.1 2013/05/28 19:50:51 vikraman Exp $
+
+EAPI=4
+
+inherit linux-mod
+
+DESCRIPTION="PCIE RTS5229 card reader driver for Linux"
+HOMEPAGE="http://www.realtek.com.tw/Downloads/downloadsView.aspx?PNid=15&PFid=25&Level=4&Conn=3&DownTypeID=3"
+SRC_URI="http://dev.gentoo.org/~vikraman/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+MODULE_NAMES="rts5229(kernel/drivers/scsi)"
+BUILD_TARGETS="default"
+
+src_prepare() {
+ sed -i -e 's/\/lib\/modules\/\$(shell uname -r)\/build\//\$(KERNELDIR)/g' Makefile || die "Sed failed!"
+ epatch "${FILESDIR}/${PN}-linux-3.8.patch"
+}
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNELDIR=${KERNEL_DIR}"
+}