summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-kernel/linux-sources/linux-sources-2.4.17-r5.ebuild3
-rw-r--r--sys-kernel/linux-sources/linux-sources-2.4.18.ebuild3
-rw-r--r--sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre3.ebuild3
3 files changed, 6 insertions, 3 deletions
diff --git a/sys-kernel/linux-sources/linux-sources-2.4.17-r5.ebuild b/sys-kernel/linux-sources/linux-sources-2.4.17-r5.ebuild
index 373b4e757684..78c35d23a1ba 100644
--- a/sys-kernel/linux-sources/linux-sources-2.4.17-r5.ebuild
+++ b/sys-kernel/linux-sources/linux-sources-2.4.17-r5.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/linux-sources-2.4.17-r5.ebuild,v 1.4 2002/03/20 23:12:12 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/linux-sources-2.4.17-r5.ebuild,v 1.5 2002/03/22 05:26:09 drobbins Exp $
#OKV=original kernel version, KV=patched kernel version. They can be the same.
#we use this next variable to avoid duplicating stuff on cvs
@@ -110,6 +110,7 @@ pkg_preinst() {
pkg_postinst() {
[ "$PN" = "linux-headers" ] && return
cd ${ROOT}usr/src/linux-${KV}
+ make mrproper
if [ -e "${ROOT}usr/src/linux/.config" ]
then
cp "${ROOT}usr/src/linux/.config" .config
diff --git a/sys-kernel/linux-sources/linux-sources-2.4.18.ebuild b/sys-kernel/linux-sources/linux-sources-2.4.18.ebuild
index f82b16ab79ed..36f28a8155ca 100644
--- a/sys-kernel/linux-sources/linux-sources-2.4.18.ebuild
+++ b/sys-kernel/linux-sources/linux-sources-2.4.18.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/linux-sources-2.4.18.ebuild,v 1.4 2002/03/20 23:12:12 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-sources/linux-sources-2.4.18.ebuild,v 1.5 2002/03/22 05:26:09 drobbins Exp $
#OKV=original kernel version, KV=patched kernel version. They can be the same.
#we use this next variable to avoid duplicating stuff on cvs
@@ -108,6 +108,7 @@ pkg_preinst() {
pkg_postinst() {
[ "$PN" = "linux-headers" ] && return
+ make mrproper
cd ${ROOT}usr/src/linux-${KV}
if [ -e "${ROOT}usr/src/linux/.config" ]
then
diff --git a/sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre3.ebuild b/sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre3.ebuild
index cf025b4f1c6c..1df31a7cfe89 100644
--- a/sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre3.ebuild
+++ b/sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre3.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre3.ebuild,v 1.3 2002/03/22 05:17:33 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openmosix-sources/openmosix-sources-2.4.17_pre3.ebuild,v 1.4 2002/03/22 05:26:09 drobbins Exp $
#OKV=original kernel version, KV=patched kernel version. They can be the same.
#we use this next variable to avoid duplicating stuff on cvs
@@ -60,6 +60,7 @@ src_install() {
pkg_postinst() {
cd ${ROOT}usr/src/${DIRNAME}
+ make mrproper
if [ -e "${ROOT}usr/src/linux/.config" ]
then
cp "${ROOT}usr/src/linux/.config" .config