summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-geosciences/googleearth/ChangeLog6
-rw-r--r--sci-geosciences/googleearth/googleearth-5.1.3533.1731-r1.ebuild136
-rw-r--r--sci-geosciences/googleearth/googleearth-5.2.1.1329_beta.ebuild5
3 files changed, 8 insertions, 139 deletions
diff --git a/sci-geosciences/googleearth/ChangeLog b/sci-geosciences/googleearth/ChangeLog
index 8d2eeacc0fa6..1e2a01c60a14 100644
--- a/sci-geosciences/googleearth/ChangeLog
+++ b/sci-geosciences/googleearth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-geosciences/googleearth
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/googleearth/ChangeLog,v 1.15 2010/06/20 16:41:06 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/googleearth/ChangeLog,v 1.16 2010/08/03 11:26:01 caster Exp $
+
+ 03 Aug 2010; Vlastimil Babka <caster@gentoo.org>
+ -googleearth-5.1.3533.1731-r1.ebuild, googleearth-5.2.1.1329_beta.ebuild:
+ Remove the unfetchable version; more info in 5.2.1 postinst messages.
20 Jun 2010; Christian Faulhammer <fauli@gentoo.org>
googleearth-5.1.3535.3218-r1.ebuild:
diff --git a/sci-geosciences/googleearth/googleearth-5.1.3533.1731-r1.ebuild b/sci-geosciences/googleearth/googleearth-5.1.3533.1731-r1.ebuild
deleted file mode 100644
index 5ee2bf08a088..000000000000
--- a/sci-geosciences/googleearth/googleearth-5.1.3533.1731-r1.ebuild
+++ /dev/null
@@ -1,136 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/googleearth/googleearth-5.1.3533.1731-r1.ebuild,v 1.4 2010/06/20 08:51:30 caster Exp $
-
-EAPI=2
-
-inherit eutils fdo-mime versionator toolchain-funcs
-
-DESCRIPTION="A 3D interface to the planet"
-HOMEPAGE="http://earth.google.com/"
-# no upstream versioning, version determined from help/about
-# incorrect digest means upstream bumped and thus needs version bump
-SRC_URI="GoogleEarthLinux-${PV}.bin"
-
-LICENSE="googleearth MIT SGI-B-1.1 openssl as-is ZLIB"
-SLOT="0"
-KEYWORDS="amd64 x86"
-RESTRICT="fetch strip"
-IUSE="qt-bundled"
-
-GCC_NEEDED="4.2"
-
-RDEPEND=">=sys-devel/gcc-${GCC_NEEDED}[-nocxx]
- x86? (
- media-libs/fontconfig
- media-libs/freetype
- virtual/opengl
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libXi
- x11-libs/libXext
- x11-libs/libXrender
- x11-libs/libXau
- x11-libs/libXdmcp
- sys-libs/zlib
- dev-libs/glib:2
- !qt-bundled? (
- >=x11-libs/qt-core-4.5.3
- >=x11-libs/qt-gui-4.5.3
- >=x11-libs/qt-webkit-4.5.3
- )
- )
- amd64? (
- >=app-emulation/emul-linux-x86-xlibs-20081109
- >=app-emulation/emul-linux-x86-baselibs-20081109
- !qt-bundled? (
- >=app-emulation/emul-linux-x86-qtlibs-20091231-r1
- )
- )
- virtual/ttf-fonts"
-
-S="${WORKDIR}"
-
-QA_TEXTRELS="opt/googleearth/libgps.so
-opt/googleearth/libgooglesearch.so
-opt/googleearth/libevll.so
-opt/googleearth/librender.so
-opt/googleearth/libinput_plugin.so
-opt/googleearth/libflightsim.so
-opt/googleearth/libcollada.so
-opt/googleearth/libminizip.so
-opt/googleearth/libauth.so
-opt/googleearth/libbasicingest.so
-opt/googleearth/libmeasure.so
-opt/googleearth/libgoogleearth_lib.so
-opt/googleearth/libmoduleframework.so
-"
-
-QA_DT_HASH="opt/${PN}/.*"
-
-pkg_nofetch() {
- elog "This version is no longer available from Google and the license prevents mirroring."
- elog "This ebuild is meant for those who already downloaded it, until the current version is stabilized."
- elog "If you can get the distfile from e.g. another computer of yours,"
- elog "copy the file ${SRC_URI} to ${DISTDIR}."
- elog "Otherwise, you need to unmask the 5.1.3535.3218-r1 version,"
- elog "stabilization is tracked at https://bugs.gentoo.org/show_bug.cgi?id=320065"
-}
-
-pkg_setup() {
- GCC_VER="$(gcc-version)"
- if ! version_is_at_least ${GCC_NEEDED} ${GCC_VER}; then
- ewarn "${PN} needs libraries from gcc-${GCC_NEEDED} or higher to run"
- ewarn "Your active gcc version is only ${GCC_VER}"
- ewarn "Please consult the GCC upgrade guide to set a higher version:"
- ewarn "http://www.gentoo.org/doc/en/gcc-upgrading.xml"
- fi
-}
-
-src_unpack() {
- unpack_makeself
-}
-
-src_prepare() {
- # make the postinst script only create the files; it's installation
- # are too complicated and inserting them ourselves is easier than
- # hacking around it
- sed -i -e 's:$SETUP_INSTALLPATH/::' \
- -e 's:$SETUP_INSTALLPATH:1:' \
- -e "s:^xdg-desktop-icon.*$::" \
- -e "s:^xdg-desktop-menu.*$::" \
- -e "s:^xdg-mime.*$::" postinstall.sh
-}
-
-src_install() {
- make_wrapper ${PN} ./${PN} /opt/${PN} . || die "make_wrapper failed"
- ./postinstall.sh
- insinto /usr/share/mime/packages
- doins ${PN}-mimetypes.xml
- domenu Google-${PN}.desktop
- doicon ${PN}-icon.png
- dodoc README.linux
-
- cd bin
- tar xf "${WORKDIR}"/${PN}-linux-x86.tar
- # bug #262780
- epatch "${FILESDIR}/decimal-separator.patch"
- exeinto /opt/${PN}
- doexe *
-
- cd "${D}"/opt/${PN}
- tar xf "${WORKDIR}"/${PN}-data.tar
-
- if ! use qt-bundled; then
- rm -rvf libQt{Core,Gui,Network,WebKit}.so.4 plugins/imageformats qt.conf || die
- fi
-
- fowners -R root:root /opt/${PN}
- fperms -R a-x,a+X /opt/googleearth/resources
-}
-
-pkg_postinst() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
-}
diff --git a/sci-geosciences/googleearth/googleearth-5.2.1.1329_beta.ebuild b/sci-geosciences/googleearth/googleearth-5.2.1.1329_beta.ebuild
index 990ff65c3929..8187cd2ee2b2 100644
--- a/sci-geosciences/googleearth/googleearth-5.2.1.1329_beta.ebuild
+++ b/sci-geosciences/googleearth/googleearth-5.2.1.1329_beta.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/googleearth/googleearth-5.2.1.1329_beta.ebuild,v 1.1 2010/06/15 08:55:42 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/googleearth/googleearth-5.2.1.1329_beta.ebuild,v 1.2 2010/08/03 11:26:01 caster Exp $
EAPI=2
@@ -158,5 +158,6 @@ pkg_postinst() {
fdo-mime_mime_database_update
elog "The qt-bundled flag is now enabled by default due to crashes on startup with system Qt."
- elog "Testing and reporting outcome with/without the flag is welcome."
+ elog "Testing and reporting outcome with/without the flag is welcome (bug #319813)."
+ elog "If it crashes in both cases, put this version in your package.mask and revert to the stable 5.1.*"
}