summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/webapp-config/webapp-config-9999.ebuild')
-rw-r--r--app-admin/webapp-config/webapp-config-9999.ebuild16
1 files changed, 4 insertions, 12 deletions
diff --git a/app-admin/webapp-config/webapp-config-9999.ebuild b/app-admin/webapp-config/webapp-config-9999.ebuild
index 685a54fb8fd7..666f64919cd9 100644
--- a/app-admin/webapp-config/webapp-config-9999.ebuild
+++ b/app-admin/webapp-config/webapp-config-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-9999.ebuild,v 1.2 2013/07/05 00:29:10 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-9999.ebuild,v 1.3 2013/08/03 13:56:20 blueness Exp $
EAPI="5"
@@ -30,16 +30,6 @@ SLOT="0"
DEPEND="app-text/xmlto"
-# We can't use-dep on portage for 9999 else we make repoman angry!
-if [[ ${PV} = 9999* ]]
-then
- IUSE=""
- RDEPEND=""
-else
- IUSE="+portage"
- RDEPEND="portage? ( sys-apps/portage[${PYTHON_USEDEP}] )"
-fi
-
python_compile_all() {
emake -C doc/
}
@@ -54,13 +44,15 @@ python_install() {
}
python_install_all() {
+ distutils-r1_python_install_all
+
insinto /etc/vhosts
doins config/webapp-config
keepdir /usr/share/webapps
keepdir /var/db/webapps
- dodoc AUTHORS TODO
+ dodoc AUTHORS
doman doc/*.[58]
dohtml doc/*.[58].html
}