summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/xarchiver')
-rw-r--r--app-arch/xarchiver/ChangeLog8
-rw-r--r--app-arch/xarchiver/xarchiver-0.5.2-r1.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/app-arch/xarchiver/ChangeLog b/app-arch/xarchiver/ChangeLog
index e798c9defc30..7062ff6aa3cf 100644
--- a/app-arch/xarchiver/ChangeLog
+++ b/app-arch/xarchiver/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/xarchiver
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/xarchiver/ChangeLog,v 1.15 2010/01/01 19:46:36 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/xarchiver/ChangeLog,v 1.16 2010/02/10 15:28:23 darkside Exp $
+
+*xarchiver-0.5.2-r1 (10 Feb 2010)
+
+ 10 Feb 2010; Jeremy Olexa <darkside@gentoo.org>
+ +xarchiver-0.5.2-r1.ebuild:
+ Revbump to fix doc location (bug 296103) and homepage (bug 301606)
01 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
xarchiver-0.5.2.ebuild:
diff --git a/app-arch/xarchiver/xarchiver-0.5.2-r1.ebuild b/app-arch/xarchiver/xarchiver-0.5.2-r1.ebuild
new file mode 100644
index 000000000000..995dc6bbad43
--- /dev/null
+++ b/app-arch/xarchiver/xarchiver-0.5.2-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/xarchiver/xarchiver-0.5.2-r1.ebuild,v 1.1 2010/02/10 15:28:23 darkside Exp $
+
+EAPI=2
+
+inherit xfconf
+
+DESCRIPTION="a GTK+ based and advanced archive manager that can be used with Thunar"
+HOMEPAGE="http://xarchiver.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND=">=x11-libs/gtk+-2.10:2
+ >=dev-libs/glib-2.10:2"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/${P}-stack-smash.patch )
+ XFCONF="--disable-dependency-tracking
+ $(use_enable debug)"
+}
+
+src_install() {
+ xfconf_src_install
+
+ rm "${D}"/usr/share/doc/${PN}/COPYING
+ mv "${D}"/usr/share/doc/{${PN},${PF}}
+}
+
+pkg_postinst() {
+ xfconf_pkg_postinst
+ elog "You need external programs for some formats, including"
+ elog "7zip - app-arch/p7zip"
+ elog "arj - app-arch/unarj app-arch/arj"
+ elog "lha - app-arch/lha"
+ elog "lzop - app-arch/lzop"
+ elog "rar - app-arch/unrar app-arch/rar"
+ elog "zip - app-arch/unzip app-arch/zip"
+ elog "Make sure to install xfce-extra/thunar-archive-plugin."
+}