summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/tiobench/tiobench-0.3.3-r2.ebuild')
-rw-r--r--app-benchmarks/tiobench/tiobench-0.3.3-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-benchmarks/tiobench/tiobench-0.3.3-r2.ebuild b/app-benchmarks/tiobench/tiobench-0.3.3-r2.ebuild
new file mode 100644
index 000000000000..965efad05ca8
--- /dev/null
+++ b/app-benchmarks/tiobench/tiobench-0.3.3-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/tiobench/tiobench-0.3.3-r2.ebuild,v 1.1 2005/03/22 12:51:46 swegener Exp $
+
+inherit eutils
+
+DESCRIPTION="Portable, robust, fully-threaded I/O benchmark program"
+HOMEPAGE="http://tiobench.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~ppc64"
+IUSE=""
+
+RDEPEND="virtual/libc
+ dev-lang/perl"
+DEPEND=">=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/0.3.3-column-description-fix.patch
+
+ sed -i \
+ -e 's:/usr/local/bin:/usr/sbin:' tiobench.pl \
+ || die "sed tiobench.pl failed"
+ sed -i \
+ -e '/DLARGEFILES/ s/^#//' \
+ -e "/^CFLAGS/ s:=.*:= ${CFLAGS}:" Makefile \
+ || die "sed Makefile failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ dosbin tiotest tiobench.pl tiosum.pl || die "dosbin failed"
+ dodoc BUGS ChangeLog README TODO || die "dodoc failed"
+}